Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

MOZILLA_PKIX_ERROR_KEY_PINNING_FAILURE & unsecure message

  • 22 uphendule
  • 11 zinale nkinga
  • 7608 views
  • Igcine ukuphendulwa ngu teammachine

more options

Hi,

I'm not able to access https://pixabay.com/ as I get the message above (question bar) showing. Having checked out Q&A I tried deleting the cert8.db file then re-starting Mozilla, no joy. I am a bit reluctant to do a refresh as I'm unsure how it would affect my system? I am not that computer literate! I did do an SSL check & both their server & info bar url came back as A+.

Around the same time I now also can't access https://personofinterestdiscussion.com/ I did an SSL check & that came up with vulnerabiities. (I made a note of some if needed.) Their overall safety rating is F - grade capped to C . I haven't made any changes to my laptop lately (Windows 7) & haven't had problems accessing either site until a couple of days ago & I just don't know what to do to get back onto both. I have anti virus, anti spyware, anti malware etc installed with no problems, also Mozilla's website protection. I scan my laptop daily. This has came on so suddenly & I really want to get back onto both sites, so any help would be very much appreciated. Thanks!  :)

Isisombululo esikhethiwe

Thank you FredMcD & Tonnes :)

When I came online today I tried the PoI site again and got the same result so then I clicked on 'Advanced' which led me to a message saying there's a problem with their certificate, altho' the SSL test says their certificate is valid until 2019?! I had emailed the owner & they sent a link which led me to 'exceptions' so I altered the 'permission' and now I can access the site again, but with Mozilla showing a grey padlock with orange exclamation mark. The grey white shield notice says it is blocking parts of the page that may not be secure (the images) ...

Tonnes ... both links in the support column showed green.

I hope you don't think I have been a waste of your time and a complete doofus! I am so grateful to you both for your patience & all your help & sharing of knowledge, which hopefully will help me in the future become more PC literate! Many thanks. :)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Thanks FredMcD - I flagged my last post Problem Solved. :)

Tonnes - yes, I did try deleting the file, several times. Perhaps it was me cocking up, ? but it didn't make any difference re: gaining site access. I was hesitant about using advanced to over-ride ? Mozilla, but decided to try. I will see if I checkmarked for permanent exception, as I take your point that as the fault lies with the site & not my laptop, I shouldn't need to. If so I will remove it, follow your steps & get back to you. Thanks! :)

Okulungisiwe ngu teammachine

more options

Tonnes said

No problem, as long as you keep reading and follow suggestions. :) Important to know: did you try the steps above (delete the file) before what you wrote above? If not, what changed things so you could add an exception today using Advanced, or was it possible earlier? (I thought you weren’t able to.) The grey padlock with an orange/yellow exclamation mark is fine for this page as it contains mixed content as described in the How do I tell if my connection to a website is secure? article. However, you should not need to add an exception for this website, as the fault is at your end, not theirs, so I think you haven’t tried the steps. In that case, if you have added a permanent exception by leaving the checkmark next to Permanently store this exception, could you remove it and try the steps? First, open Options > Advanced > Certificates > View Certificates > Servers tab - you’ll probably find the website under The USERTRUST network, where you can delete it. Then retry the page so you should see the error again (you may need to reload using Ctrl-F5 and restart Firefox), then close Firefox, delete the file and retry.

Hi Tonnes ...

I followed your steps & found the USERTRUST network but the PoI site isn't listed!? So, I just tried the site again & the 'Insecure Connection' page is back up, so no access again. I went into 'Advanced' & I think what I clicked on was 'Confirm Security Exception' as the box for permanent exception isn't checkmarked & wasn't 'highlighted'. I haven't done anything else as I can't find the file under USERTRUST to delete it. ? But I will close Mozilla & retry.

EDIT: I closed Firefox then tried again to find the file but it isn't there. Site still blocked as I am loathe to make the exception again. Thanks again & sorry to be a pain.

Forgot to say, both showed green, I moved the folder, tried again, access still blocked. Thanks for all your efforts, Tonnes. :)

Okulungisiwe ngu teammachine

  1. 1
  2. 2