X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Greek font characters in website are not displayed properly, but when i refresh any page then Greek characters are displayed correctly

Kuphostiwe

Hi everyone !

I'm currently using Mozilla Firefox v.49.0.2.

I'm quite desperate after spending over 45 hours in working around to resolve the following specific problem that's appeared only with Mozilla browser:

My website address is: "www.visvikisbarlou.gr/index.asp" The main page is loaded perfectly and shows Greek font text, but when i click-follow any of the menu links, the Greek font characters are shown in little boxes with hex code in all pages !

I would like to mention the following crucial facts: 1) This problem exists only with Mozilla. In Chrome and IE the Greek font characters are rendered perfectly in all pages. 2) If i reload any of the pages in Mozilla, then suddenly the page works and shows up the Greek font text ! It's really weird. 3) I've declared and <meta charset="windows-1253"> in the header of all pages and when i check the encoding in Mozilla browser it looks that Mozilla clearly understands that -Mozilla shows as encoding Greek (Windows) in all of my pages. But in the pages the Greek text is shown up as little boxes with hex code. 4) If i enter directly the address of a page e.g. http://www.visvikisbarlou.gr/news.asp then the page shows Greek characters correctly without any issue. I really can't figure out why this is happening. Any help on resolving this problem will be much appreciated !! Thanks everyone in advance. Kind regards, George

Hi everyone ! I'm currently using Mozilla Firefox v.49.0.2. I'm quite desperate after spending over 45 hours in working around to resolve the following specific problem that's appeared only with Mozilla browser: My website address is: "www.visvikisbarlou.gr/index.asp" The main page is loaded perfectly and shows Greek font text, but when i click-follow any of the menu links, the Greek font characters are shown in little boxes with hex code in all pages ! I would like to mention the following crucial facts: 1) This problem exists only with Mozilla. In Chrome and IE the Greek font characters are rendered perfectly in all pages. 2) If i reload any of the pages in Mozilla, then suddenly the page works and shows up the Greek font text ! It's really weird. 3) I've declared <html lang="el"> and <meta charset="windows-1253"> in the header of all pages and when i check the encoding in Mozilla browser it looks that Mozilla clearly understands that -Mozilla shows as encoding Greek (Windows) in all of my pages. But in the pages the Greek text is shown up as little boxes with hex code. 4) If i enter directly the address of a page e.g. http://www.visvikisbarlou.gr/news.asp then the page shows Greek characters correctly without any issue. I really can't figure out why this is happening. Any help on resolving this problem will be much appreciated !! Thanks everyone in advance. Kind regards, George

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • 1,2,1,2044
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • 6.0.12.46
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 23.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.40416.0
  • VLC media player Web Plugin
  • Vizzed Retro Game Room Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.2; rv:49.0) Gecko/20100101 Firefox/49.0

Eminye Imininingwane

Umnikazi wombuzo

Hi all,

I'm attaching 2 screenshots of the same web page, one not showing the Greek characters when i follow a link in website, and one showing properly Greek characters when i refresh the page or if enter directly the URL address of the page.

I would like to thank you in advance for your help.

Kind regards, George

Hi all, I'm attaching 2 screenshots of the same web page, one not showing the Greek characters when i follow a link in website, and one showing properly Greek characters when i refresh the page or if enter directly the URL address of the page. I would like to thank you in advance for your help. Kind regards, George
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 ----------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems? Then restart.

Umnikazi wombuzo

Hi !

Thank you for the provided detailed help. I followed carefully step by step all your hints but unfortunately the problem remains !  :(

It's so weird taking into consideration the following facts i've mentioned:

1) This problem exists only with Mozilla. In Chrome and IE the Greek font characters are rendered perfectly in all pages.

2) If i reload any of the pages in Mozilla, then suddenly the page works and shows up the Greek font text ! It's really weird.

3) I've declared and <meta charset="windows-1253"> in the header of all pages and when i check the encoding in Mozilla browser it looks that Mozilla clearly understands that -Mozilla shows as encoding Greek (Windows) in all of my pages. But in the pages the Greek text is shown up as little boxes with hex code.

4) If i enter directly the address of a page e.g. http://www.visvikisbarlou.gr/news.asp then the page shows Greek characters correctly without any issue.

It's so crazy, when you enter directly the URL or you refresh the pages the Greek characters are shown but when you click-follow a link in the website then all Greek characters are shown as little boxes with hex code !!

Any other tips or advice would be much appreciated !!

Kind regards, George

Hi ! Thank you for the provided detailed help. I followed carefully step by step all your hints but unfortunately the problem remains ! :( It's so weird taking into consideration the following facts i've mentioned: 1) This problem exists only with Mozilla. In Chrome and IE the Greek font characters are rendered perfectly in all pages. 2) If i reload any of the pages in Mozilla, then suddenly the page works and shows up the Greek font text ! It's really weird. 3) I've declared and <meta charset="windows-1253"> in the header of all pages and when i check the encoding in Mozilla browser it looks that Mozilla clearly understands that -Mozilla shows as encoding Greek (Windows) in all of my pages. But in the pages the Greek text is shown up as little boxes with hex code. 4) If i enter directly the address of a page e.g. http://www.visvikisbarlou.gr/news.asp then the page shows Greek characters correctly without any issue. It's so crazy, when you enter directly the URL or you refresh the pages the Greek characters are shown but when you click-follow a link in the website then all Greek characters are shown as little boxes with hex code !! Any other tips or advice would be much appreciated !! Kind regards, George

Okulungisiwe ngu georgei13

FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

I checked out http://www.visvikisbarlou.gr/news.asp and it works fine for me.

Have you tried to Start In Safe Mode?

I checked out http://www.visvikisbarlou.gr/news.asp and it works fine for me. Have you tried to Start In Safe Mode?
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

Found it. When I open http://www.visvikisbarlou.gr/index.asp the problem shows up in the linked pages.

Are you using direct links to your pages, or are they redirected? I called for more help.

Found it. When I open http://www.visvikisbarlou.gr/index.asp the problem shows up in the linked pages. Are you using direct links to your pages, or are they redirected? I called for more help.

Umnikazi wombuzo

Hi ,

Yes, i've tried starting in Safe Mode and i've tried clearing cache, cookies as you advised me.

Please visit first http://www.visvikisbarlou.gr/index.asp and click at the 5th top menu which will lead you to the News page http://www.visvikisbarlou.gr/news.asp and you'll see that all Greek characters are shown as little boxes with hex code !! Do not enter directly http://www.visvikisbarlou.gr/news.asp , because the page in this case is showing the Greek characters !

As i've mentioned when you enter directly the URL or you refresh any page in the web page everything is properly presented - all Greek charcters are shown. But when you are browsing, going from link to link inside the website all Greek characters are transformed to little boxes with hex code. This problem is driving me crazy since i've spend over 45 hours on this issue so far  :(

Thank you so much for trying to help me resolve this very weird issue.

Kind regards, George

Hi , Yes, i've tried starting in Safe Mode and i've tried clearing cache, cookies as you advised me. Please visit first [http://www.visvikisbarlou.gr/index.asp] and click at the 5th top menu which will lead you to the News page [http://www.visvikisbarlou.gr/news.asp] and you'll see that all Greek characters are shown as little boxes with hex code !! Do not enter directly [http://www.visvikisbarlou.gr/news.asp] , because the page in this case is showing the Greek characters ! As i've mentioned when you enter directly the URL or you refresh any page in the web page everything is properly presented - all Greek charcters are shown. But when you are browsing, going from link to link inside the website all Greek characters are transformed to little boxes with hex code. This problem is driving me crazy since i've spend over 45 hours on this issue so far :( Thank you so much for trying to help me resolve this very weird issue. Kind regards, George

Okulungisiwe ngu georgei13

Umnikazi wombuzo

Hi ,

I'm using direct links - no redirection at all.

Thanks again, i really appreciate your assistance !

Kind regards, George

Hi , I'm using direct links - no redirection at all. Thanks again, i really appreciate your assistance ! Kind regards, George
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

I called for more help. To me, it would seem a website issue. But I don't know enough to say for sure.

Something is preventing the font codes when called from the main page.

I called for more help. To me, it would seem a website issue. But I don't know enough to say for sure. Something is preventing the font codes when called from the main page.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59390 izimpendulo
Kuphostiwe

I just tried Firefox in Same Mode. Problem still there.

I just tried Firefox in Same Mode. Problem still there.

Umnikazi wombuzo

Hi,

I can't understand what's the problem, since if you load directly pages works fine. Again no problem when you refresh pages. I think this is an internal Firefox problem, that can't render properly the fonts when browsing from page to page. Take into consideration that there is no problem to Chrome, IE, Safari browsers...

I appreciate that you are trying to help me mate ! Thank you so much.

Any assistance from anybody would be great !

Kind regards, George

Hi, I can't understand what's the problem, since if you load directly pages works fine. Again no problem when you refresh pages. I think this is an internal Firefox problem, that can't render properly the fonts when browsing from page to page. Take into consideration that there is no problem to Chrome, IE, Safari browsers... I appreciate that you are trying to help me mate ! Thank you so much. Any assistance from anybody would be great ! Kind regards, George