Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

No fullscreen option in firefox browser only

  • 17 uphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu TimmvG

more options

When I want to play a video on southpark.cc.com there is no full screen option. I tried to play the video in other browsers but the problem does not occur. It's only in the firefox browser. I have the latest update of firefox and flashplayer and even updated my graphics card (intel graphics) but none of it seemed te help. Also the videoplayer has another form than the videoplayers in other browsers. Look for screenshot below. Please help me?

Kind regards, TimmvG

Ama-screenshot ananyekiwe

Okulungisiwe ngu TimmvG

All Replies (17)

more options

deleted message

Okulungisiwe ngu TimmvG

more options

Hi   !

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Hello!

Thank you for your quick reply. I tried all of the Troubleshoot above but unfortunately none of them did the trick. The best chance I had was to update VLC Web Plugin. Compared to my desktop (where te problem doesn't occur) this plugin wasn't up to date but after updating it still happen.

Are there any other options I can try?

more options

For me, it uses Flash and the player looks totally different (screen shot attached). I wonder why yours is using VLC or whatever that is? (Usually a right-click on the player can help you identify a specific plugin or that it's Firefox built-in HTML5 player.)

more options

Hi again   !
Would you consider this add-on:
https://addons.mozilla.org/en-US/firefox/addon/mfull/

And you probably already know this, but just in case:
'How to make Firefox and websites go full screen':   http://mzl.la/1xKsUrA

more options

I tried to disable plugins to troubleshoot the problem. It seemed that without the VLC Web Plugin and Shockwave Flash combined the video wouldn't play. That doesn't mean that the VLC plugin is the issue here. A right click showed that Adobe Flash Player 23.0.0.205 is running the video.

more options

TimmvG said

Hello! Thank you for your quick reply. I tried all of the Troubleshoot above but unfortunately none of them did the trick. The best chance I had was to update VLC Web Plugin. Compared to my desktop (where te problem doesn't occur) this plugin wasn't up to date but after updating it still happen. Are there any other options I can try?

It might even be a good idea to disable the   VLC Web Player plugin   (set it to   'never activate')   and exit/restart Firefox.

more options

TimmvG said

I tried to disable plugins to troubleshoot the problem. It seemed that without the VLC Web Plugin and Shockwave Flash combined the video wouldn't play. That doesn't mean that the VLC plugin is the issue here. A right click showed that Adobe Flash Player 23.0.0.205 is running the video.

The erroneous permission linkage between Flash and VLC should be fixed in Firefox 51; until then, I'm keeping them on Ask to Activate.

From time to time, we see different control bars on Flash for reasons I couldn't explain. Maybe someone else will recognize the issue.

more options

Happy112 said

Hi again   !
Would you consider this add-on:
https://addons.mozilla.org/en-US/firefox/addon/mfull/
And you probably already know this, but just in case:
'How to make Firefox and websites go full screen':   http://mzl.la/1xKsUrA

I tried that earlier but that doesn't work either. It'll only make the adress bar disapear

more options

I tried to disable the VLC plugin but they (flash and VLC) are shutting each other out. For example when I deactivate the vlc plugin and only activate the flash plugin the video plays. But when I look at the plugins the vlc plugin is activated again even though I deactivated it. So I think they really need to work together in order to play the video in the first place.

more options

TimmvG said

I tried that earlier but that doesn't work either. It'll only make the adress bar disapear

Sure wish I had known that you do not want the address bar to disappear,   for then I would have told you right away when I tried that
southpark.cc.com :    I used the zoom feature and that worked like a charm,   but it didn't make the address bar disappear.
So, I thought:  "Nah;   can't tell him to use the zoom feature   ....   "
Go ahead and try it   !

more options

My bad, I played a random video and not the one shown in your screenshot. For that one, I get a link out to Hulu because it's not available through the site. (Screen shot attached.) So that's even more puzzling... I'm in California, in case it matters.

more options

Happy112 said

TimmvG said
I tried that earlier but that doesn't work either. It'll only make the adress bar disapear

Sure wish I had known that you do not want the address bar to disappear,   for then I would have told you right away when I tried that
southpark.cc.com :    I used the zoom feature and that worked like a charm,   but it didn't make the address bar disappear.
So, I thought:  "Nah;   can't tell him to use the zoom feature   ....   "
Go ahead and try it   !

Well thanks for you solution. I'm sorry but that's not the solution I'm looking for. I just can't understand why the control bar of the flashplayer is different from all the other flashplayers. I just want to get the right control bar with the fullscreen option.

more options

jscher2000 said

My bad, I played a random video and not the one shown in your screenshot. For that one, I get a link out to Hulu because it's not available through the site. (Screen shot attached.) So that's even more puzzling... I'm in California, in case it matters.

The problem occurs on every episode. It's not just the one I posted. But yes there are some episodes that are banned depending on the continent/country.

more options

I was already in bed, thinking how I don't even like  Southpark,   and then thinking:   "this control bar problem is not a Firefox issue,  but should be fixed by the owners of the site."
And here's how you can contact them at their email-address:
info@southpark.cc.com
Good idea   ?

more options

Just took another good look at that marked screenshot you provided and I now realize that my previous remark about the control bar problem was a very, very dumb remark   !   Must have been half asleep, but that's no excuse; I appologize   !

more options

No need to apologize. We are all trying to help here which I very much appreciate. I will contact southpark. Thank you very much!