X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I activate the option "ask to activate" for other add-ons than Flash?

Kuphostiwe

I would like to have the possebility for all add-ons to select "ask to activate". But, except for Flash, it is greyed out for all add-ons.

I would like to have the possebility for all add-ons to select "ask to activate". But, except for Flash, it is greyed out for all add-ons.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 23.0 r0

Isisebenziso

  • Firefox 49.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Izandiso

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Radeon HD 4300/4500 Series
  • adapterDescription2:
  • adapterDeviceID: 0x954f
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 0e13174b
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 4-29-2013
  • driverDate2:
  • driverVersion: 8.970.100.1100
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; D3D9 blacklisted with DLL atiumd64.dll (7.14.10.911)
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Hi   !
Type in the address bar   about:config (promise to be careful) Type   plugins Search for the the preference named: plugins.click_to_play and set it's value to   true

Hi &nbsp; !<BR> Type in the address bar &nbsp; '''about:config''' (promise to be careful) Type &nbsp; '''plugins''' Search for the the preference named: '''plugins.click_to_play''' and set it's value to &nbsp; '''true'''

Umnikazi wombuzo

Hi,

Thanks, but this option only works for Flash and is already active by default. With the 3 add-ons that come with Firefox "ask to activate" does not get active.

Hi, Thanks, but this option only works for Flash and is already active by default. With the 3 add-ons that come with Firefox "ask to activate" does not get active.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Even though you may already have tried this and for some reason it hasn't worked:
3-bar menu > Add-ons > Plugins > on the right side:   click on those little black arrows and a little dropdown will show up, that will give you the opportunity to set it to   'ask to activate'

Even though you may already have tried this and for some reason it hasn't worked:<BR> 3-bar menu > Add-ons > Plugins > on the right side: &nbsp; click on those little black arrows and a little dropdown will show up, that will give you the opportunity to set it to &nbsp; 'ask to activate' <BR>
Scribe 725 izisombululo 3456 izimpendulo
Kuphostiwe

Hi, have a look at the Applications panel in Options: Applications panel - Set how Firefox handles different types of files.

Extensions (add-ons) should have a disable option.

If that doesn't help, please be specific about which ones are greyed out.

Hi, have a look at the Applications panel in Options: [[Applications panel - Set how Firefox handles different types of files]]. Extensions (add-ons) should have a disable option. If that doesn't help, please be specific about which ones are greyed out.

Umnikazi wombuzo

@Happy112 As I said: except for Flash, it is greyed out for all add-ons.

@Scribe I don't want to disabel add-ons. I want to have the option 'ask to activate' for all add-ons.

@Happy112 As I said: except for Flash, it is greyed out for all add-ons. @Scribe I don't want to disabel add-ons. I want to have the option 'ask to activate' for all add-ons.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

Hi again,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Good luck and keep us posted   !

Hi again,<BR> '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' Good luck and keep us posted &nbsp; !
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Impendulo Ewusizo

PrinsB said

With the 3 add-ons that come with Firefox "ask to activate" does not get active.

Obviously you are referring to the OpenH264 video codec, Primetime Content Decryption Module and Widevine Content Decryption Module under Plugins.

These 3 “add-ons” come bundled with Firefox, work in a different way and can’t be set to Ask to Activate - it’s either Always or Never activate, and the other options are grayed out.

There are ways to uninstall them entirely (see this article for instance), but that’s not what you want.

Also see Watch DRM content on Firefox for regular ways to disable them.

''PrinsB [[#answer-932333|said]]'' <blockquote> With the 3 add-ons that come with Firefox "ask to activate" does not get active. </blockquote> Obviously you are referring to the OpenH264 video codec, Primetime Content Decryption Module and Widevine Content Decryption Module under Plugins. These 3 “add-ons” come bundled with Firefox, work in a different way and can’t be set to Ask to Activate - it’s either Always or Never activate, and the other options are grayed out. There are ways to uninstall them entirely (see [http://techdows.com/2015/04/how-to-uninstall-or-remove-adobe-primetime-decryption-module-plugin-from-firefox-38.html this article] for instance), but that’s not what you want. Also see [[Watch DRM content on Firefox]] for regular ways to disable them.

Umnikazi wombuzo

@ Happy112 See reply from Tonnes.

@Tonnes Okay, that's clear. But I still what to have the possibility to activate them only when I choose. No matter what way they work. So, although my question is answered, the problem is not solved. I urge the developpers to change this.

@ Happy112 See reply from Tonnes. @Tonnes Okay, that's clear. But I still what to have the possibility to activate them only when I choose. No matter what way they work. So, although my question is answered, the problem is not solved. I urge the developpers to change this.

Okulungisiwe ngu PrinsB

Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

PrinsB said

@ Happy112 See reply from Tonnes.

I have seen it and it's brilliant.
'Thought you might have other add-ons as well   .....

''PrinsB [[#answer-932621|said]]'' <blockquote> @ Happy112 See reply from Tonnes. </blockquote> I have seen it and it's brilliant.<BR> 'Thought you might have other add-ons as well &nbsp; .....

Umnikazi wombuzo

Happy112 said

'Thought you might have other add-ons as well   .....

Not yet.

''Happy112 [[#answer-932662|said]]'' <blockquote> 'Thought you might have other add-ons as well &nbsp; ..... </blockquote> Not yet.
Happy112 561 izisombululo 5694 izimpendulo
Kuphostiwe

PrinsB said

So, although my question is answered, the problem is not solved. I urge the developpers to change this.

You could submit your wishes/suggestions here:
https://input.mozilla.org/feedback/firefox

''PrinsB [[#answer-932621|said]]'' <blockquote> So, although my question is answered, the problem is not solved. I urge the developpers to change this. </blockquote> You could submit your wishes/suggestions here:<BR> https://input.mozilla.org/feedback/firefox
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 izisombululo 40084 izimpendulo
Kuphostiwe

Impendulo Ewusizo

PrinsB said

.. But I still what to have the possibility to activate them only when I choose. No matter what way they work. ...

OpenH264 video codec, Primetime Content Decryption Module, and Widevine Content Decryption Module under Plugins are different type of Plugins than Flash; they don't work directly with the video/audio files on the webpage to play the files as with Flash. Those 3 Plugins work in conjunction with the HTML5 Video / Audio features which are built into Firefox.

The Flash Control extension can be used to "control" when both Flash and HTML5 Video/Audio runs in Firefox. You need to "click-to-run" each Video or Audio file that is on a webpage. https://addons.mozilla.org/en-US/firefox/addon/flash-control/

''PrinsB [[#answer-932621|said]]'' <blockquote> .. But I still what to have the possibility to activate them only when I choose. No matter what way they work. ... </blockquote> OpenH264 video codec, Primetime Content Decryption Module, and Widevine Content Decryption Module under Plugins are different type of Plugins than Flash; they don't work directly with the video/audio files on the webpage to play the files as with Flash. Those 3 Plugins work in conjunction with the HTML5 Video / Audio features which are built into Firefox. The Flash Control extension can be used to "control" when both Flash and HTML5 Video/Audio runs in Firefox. You need to "click-to-run" each Video or Audio file that is on a webpage. https://addons.mozilla.org/en-US/firefox/addon/flash-control/