Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how do I stop firefox from opening a new tab for each link I click on

  • 9 uphendule
  • 1 inale nkinga
  • 6992 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Each time I click a link then Firefox opens a new tab. I am spending to much time closing tabs and this is extremely annoying. I want to work in the same tab/window regardless of how many links I click on. How can I configure Firefox to do this?

Thanks,

Ian

Isisombululo esikhethiwe

Yahoo actually has a similar setting (new window, not new window) but if you prefer Google, you're all set.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options

Hi, that is not the default behaviour. If you have any add-ons, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


You can also check your tab settings: Startup, home page, tabs, and download settings

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

more options

Thanks for your suggestion but the problem continues to occur even when add-on's are disabled in Firefox.

Here is an example that illustrates the problem. Start Firefox and Google search for 'Firefox'. One of the first sites listed in the results should be Mozilla Firefox - Official Site. If you click on Mozilla Firefox - Official Site then FireFox opens a new tab shows the Firefox download page in this new tab. The behavior I want is for Firefox not to open a new tab but instead simply to show the Firefox download page in the same tab that listed the results of the Google search. This occurs even when I run Firefox add-ons disabled, as you suggested.

Each time I do any research in Firefox, I spend to much time closing tabs because Firefox

more options

Could you check whether you have the "new window" setting turned on for Google results? It's under "Where results open" on this page:

https://www.google.com/preferences

(Enabling that codes the result links to open in a new window by adding target="_blank" to the links. By default, Firefox diverts those new windows to a new tab -- Google doesn't have a separate setting for opening results in a new tab.)

more options

The Google setting 'new window' is turned off (i.e. it is not checked).

more options

Hmm, odd. Is it really Google, or some other search results page using Google results? Could you copy/paste the URL from the address bar into a reply?

more options

Here is the URL I get when clicking on the link you provided:

  https://www.google.com/preferences

I provided an example above for the 'Mozilla Firefox - Official Site' which illustrates the problem. If you perform the steps described in that example then does Firefox open a new tab for you?

more options

IanBell said

Here is the URL I get when clicking on the link you provided: https://www.google.com/preferences

Actually, I meant the URL of the results page that isn't working the way you want.

For example, when i search for firefox using Firefox's search bar, or the search bars in Firefox's built-in home page or new tab page, the address of the results page is:

https://www.google.com/search?q=firefox&ie=utf-8&oe=utf-8&client=firefox-b

If I use the main address bar, it's a bit different, -ab is added to the end:

https://www.google.com/search?q=firefox&ie=utf-8&oe=utf-8&client=firefox-b-ab

What address are you ending up on?

I provided an example above for the 'Mozilla Firefox - Official Site' which illustrates the problem. If you perform the steps described in that example then does Firefox open a new tab for you?

I actually do not get that ad, I just get the organic result "Download Firefox — Free Web Browser — Mozilla" as the top hit. Do you get a new tab for organic results, too, or only for ads? Note: it may be difficult to tell which are the ads. Sometimes they have a little "Ad" badge and sometimes the ad section just has a slightly shaded background.

more options

I believe you have just solved the problem. I installed Firefox a few days ago and by default, it seems it was using the Yahoo search engine . I just went to the Firefox search options settings and changed the default search engine to Google. Many thanks for resolving this problem.

Cheers,

Ian

more options

Isisombululo Esikhethiwe

Yahoo actually has a similar setting (new window, not new window) but if you prefer Google, you're all set.