Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is Firefox 49 lagging so much?

  • 20 uphendule
  • 4 zinale nkinga
  • 91 views
  • Igcine ukuphendulwa ngu luis.de.sousa

more options

Hi there,

This issue reports to a desktop computer with 8 CPUs and 24 Gb of RAM, which pretty much puts aside any resource constraints. Ever since Firefox was updated to version 49 the browsing experience has become increasingly difficult with a relevant lag on pretty much every task: . opening a new tab . loading/reloading a web page . scrolling down a web page . entering text (takes almost 1 second for a character to appear) . deleting text . using menus (e.g. takes about 1 second for the context menu highlight to move up/down to the next item) . great reduction in frame rate when playing videos (actually, I no longer play video on Firefox 49)

I have tried various things to stop the lagging: . restart Firefox . disable/uninstall extensions (now down to just 4) . disable/uninstall plugins (now down to just 3) . update plugins

But the lagging prevails.

I use pretty much the same web pages as I did with previous Firefox versions, but only with version 49 am I experience this lagging.

Thank you.

All Replies (20)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


I've called for more help. I don't know Linux.

more options

If I start Firefox in safe mode it is so slow it is unusable.

more options

Hmm. That is very odd. Please try downloading a new Firefox. Remove the current before running the new.

more options

Hi again.

I install software from package archives, manual installation quickly leads to unmet dependencies. This is the version I have presently on my system:

$ sudo apt policy firefox firefox:

 Installed: 49.0+build4-0ubuntu0.16.04.1
 Candidate: 49.0+build4-0ubuntu0.16.04.1
 Version table:
*** 49.0+build4-0ubuntu0.16.04.1 500
       500 http://ch.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
       500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
       100 /var/lib/dpkg/status
    45.0.2+build1-0ubuntu1 500
       500 http://ch.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

If I visit firefox.com I get this message: "Congrats! You’re using the latest version of Firefox."

Thank you.

more options

I've called for more help.

more options

Any news on this issue? Right now I need to work on some files with GoogleDocs and it is pretty much impossible with Firefox 49.

Thank you.

more options

Just to be sure, have your ISP check your service.

http://www.speedtest.net/ Speedtest.net by Ookla - The Global Broadband Speed Test

more options

Hi again Fred. This is not a bandwidth issue, pages take longer than they should to load, but only on Firefox. With Chromium the same web pages load swiftly.

Also, keep in mind that the lagging is there when pages are fully loaded, e.g. scrolling down, entering text, etc. It feels like the whole Firefox system is overloaded.

Thank you.

more options

Hi Luis,

I am right now using a Canonical Build Fx49.0.2 on Xenial. Firefox is certainly not fast but that more down to a low end laptop with dual core CPU and 2GB RAM. It is however apparently orders of magnitude faster than yours, it can easily keep up with my text typing.

If you start Firefox in its own safemode it should normally be likely to be faster not slower. The only reason I can think of that may cause a slight slowdown is that safemode disables hardware acceleration.

Please try a new additional Firefox profile. Note once you have multiple profiles the profile manager allows you to choose the profile each time you use it.

Have you updated Firefox since your initial post, you should now be on Canonical 49.0.2

I often have Mozilla builds installed on Ubuntu & Debian & have not had problems with unmet dependencies, after all by default they have Firefox or IceWeasel installed already. There are repositories if you want to use them https://help.ubuntu.com/community/FirefoxNewVersion/MozillaBuilds

more options
more options

Hello again,

I have made a number of tests from which I could not identify any definitive cause. However, I observed relevant points:

  • - The first time I start Firefox after booting or restarting the system there is no lag. The lag starts after some minutes (hours?) of use.
  • - If I kill the Firefox process (kill -15) and restart it the lagging usually goes away temporarily (in Safe mode this does not work).
  • - When lagging is most acute, there is usually one of the CPUs taken at 100%.

Cheers.


edit format - asterisk on new line is a bullet para - leading spaces make pre-format = no text wrap -J99

Okulungisiwe ngu John99

more options

Lagging not getting worse in safe mode could indicate it is an extension that is involved, or it could be graphics related because hardware acceleration is disabled and although that could cause a slight overall slowdown it may prevent other more serious hangs and slowdowns.

Problems with sessionstore files may get worse as a session gets older.Depending what occurs on a restart the restart may work ok or cause hangs depending rather on which files end uop being used - a new profile would help troubleshoot that - and other potential causes of hangs such as issues with the places.sqlite database.

Please have a look at this article, does any of this or the solutions in it seem appropriate

Did you try creating an additional profile and testing in that. In the new profile trial with Firefox iin safemode and all plugins set as ask to activate.

more options

Hello again,

I have now upgraded to Firefox 50 in all systems and the lagging, if anything, got worse. It is especially critical playing videos and working on GDrive/GDocs. Safe mode, alternative profiles, etc, prevent the lagging for a while, but it always returns at some point.

Again, I suspect of an higher than usual CPU load, but in these modern chipsets with multiple cores I can not be sure.

Any advice or hints on how I can recover Firefox from this would be very welcome.

Thank you.

more options

See if this makes a difference,

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.

more options

You say this is getting worse. You said in your first post: luis.de.sousa #question-1142940

...
  • using menus (e.g. takes about 1 second for the context menu highlight to move up/down to the next item)
  • great reduction in frame rate when playing videos (actually, I no longer play video on Firefox 49)
...

Is that still what happens ? What happens if you have only the one document open and no other Firefox tabs open ? If you still see that problem, maybe we have methods of gathering more information about that. (If we get a profile recording of a few seconds maybe someone will be able to determine what the problem is.)

more options

John99 said

Is that still what happens ?

Yes. There are no big changes from Firefox 49 to 50. Video speed seems now down to 2 or 3 frames per second.

John99 said

What happens if you have only the one document open and no other Firefox tabs open ?

Opening a single tab with a GDocs document improves things, writing and commenting becomes definitely more fluid. Opening a different document or navigating within the current is still laggy, though.

But what is the point of using Firefox if I can only have one tab open at a time?

more options

I usually have tens of tabs open without problems, and I see people talking about hundreds of tabs. It may partly depend on what those tabs are.

I could see that something like an online Google doc may be particularly problematic as it is going to need to interactively process your input, and change and possibly reformat a large document over what may be a slow internet connection. Tryng in Firefox with just one tab open

  • What sort of typing speeds can you achieve in
    words per minute ?
    and characters per minute ?
    When using Google docs. No need for a stopwatch ballpark figures will suffice.
  • How does that compare with the speeds again using a single tab open when you type in to the reply box on this forum ?
  • Possibly I would expect on this forum the typing speed to be limited by your own speed rather than by Firefox. Does that appear to be the case ?
  • How does that compare if you try an alternative browser ? (Please say what browser you used)
more options

Happy new year everyone.

Here is a video comparing Firefox with Chromium, showing how the difficult it has become to use the former:

https://youtu.be/REXvkK1Rabc

I still use Firefox because of the reader view feature. But for anything else beyond reading I am now obliged to use a different browser.

Cheers.

more options

What is Firefox memory usage when the lagging starts?

See also the about:memory page via the location/address bar.


Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Hi there cor-el, please read the comments above. The things I have tried so far, that either do not work or solve the issue only temporarily:

  • restart Firefox
  • disable extensions and plug-ins
  • create a new profile
  • disable asynchronous drawing
  • restart Firefox in safe mode

The only way to avoid this slow down is to restart Firefox in safe mode and keep only one tab open at a time.

Cheers.