X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

In both Firefox 49 and 49.0.1, aol.com is unviewable due to lag and crashing

Kuphostiwe

I find that using Firefox 49 and 49.0.1 versions do not handle aol.com well. The browsing is extremely slow and choppy. This is on both of my MacBook Pros, an early 2011 17" and mid 2012 13" running macOS Sierra, and even on Firefox for Android on my both of my Nexus 6's running Nougat. I can browse aol.com in both Safari and Opera with no problem on my Macs and aol.com runs better on Naked Browser Pro than mobile Firefox.

I find that using Firefox 49 and 49.0.1 versions do not handle aol.com well. The browsing is extremely slow and choppy. This is on both of my MacBook Pros, an early 2011 17" and mid 2012 13" running macOS Sierra, and even on Firefox for Android on my both of my Nexus 6's running Nougat. I can browse aol.com in both Safari and Opera with no problem on my Macs and aol.com runs better on Naked Browser Pro than mobile Firefox.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • DISH Anywhere Player 2.29.3
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 23.0 r0
  • doubleTwist Web Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0

Eminye Imininingwane

Umnikazi wombuzo

I started up my Parallels 12 Windows 10 VM tonight and tried Firefox version 49.0.1 and it handled aol.com okay. The problem must be the interaction somehow between macOS Sierra, Firefox, and aol.com but I have no idea what it could be.

I started up my Parallels 12 Windows 10 VM tonight and tried Firefox version 49.0.1 and it handled aol.com okay. The problem must be the interaction somehow between macOS Sierra, Firefox, and aol.com but I have no idea what it could be.

Umnikazi wombuzo

After successfully using Firefox in my VM, I went back to Firefox on Sierra and messed with it some more. I had already disabled several extensions and deleted two others with no luck so I disabled the three active ones and had no problem. I enabled each one and tried aol.com and thought I could narrow down one problematic one but it kept working. I have six and they are enabled and aol.com was working just before I came here. The six are, 1 Password, Adguard, Click to Play per-element, Open With, Turn Off the Lights, and Zoom Page. Still a mystery to me.

After successfully using Firefox in my VM, I went back to Firefox on Sierra and messed with it some more. I had already disabled several extensions and deleted two others with no luck so I disabled the three active ones and had no problem. I enabled each one and tried aol.com and thought I could narrow down one problematic one but it kept working. I have six and they are enabled and aol.com was working just before I came here. The six are, 1 Password, Adguard, Click to Play per-element, Open With, Turn Off the Lights, and Zoom Page. Still a mystery to me.

Umnikazi wombuzo

Any success was short lived, Firefox this morning back to unuseable on aol.com - have to force quit then it restarts back to same tabs causing same problems, what a pain. I have reverted to 48.0.1 and all is well.

Any success was short lived, Firefox this morning back to unuseable on aol.com - have to force quit then it restarts back to same tabs causing same problems, what a pain. I have reverted to 48.0.1 and all is well.

Umnikazi wombuzo

48.0.1 not a solution either, wonky this morning after a few minutes. It is strange to me it is only a problem on one domain like this and only with Firefox, was hoping for some help.

48.0.1 not a solution either, wonky this morning after a few minutes. It is strange to me it is only a problem on one domain like this and only with Firefox, was hoping for some help.

Umnikazi wombuzo

I have finally came up with the situation that causes the hang. It happens whenever I open a link in either a new tab or window. I don't have a clue how to fix it yet though. I have not found a setting to open links in same window.

I have finally came up with the situation that causes the hang. It happens whenever I open a link in either a new tab or window. I don't have a clue how to fix it yet though. I have not found a setting to open links in same window.

Umnikazi wombuzo

Entering into state of desperation I downloaded and installed Firefox 50 beta. This version does handle aol.com a little better but not good. Using activity monitor Firefox on aol.com with one tab open uses 2 to 10% CPU but it soars to 100% + as soon as another tab or window is opened from aol.com. I don't think this is, or should be, normal.

Entering into state of desperation I downloaded and installed Firefox 50 beta. This version does handle aol.com a little better but not good. Using activity monitor Firefox on aol.com with one tab open uses 2 to 10% CPU but it soars to 100% + as soon as another tab or window is opened from aol.com. I don't think this is, or should be, normal.

Umnikazi wombuzo

Trying to come up with a solution led me to start up using Snow Leopard and Firefox 48.0.2. I found I still had the same problem soon after opening another tab on aol.com; lag, erratic scrolling behavior, spinning beach ball, leading to force quitting Firefox. I restarted in Sierra, went to Firefox to begin more trial and error troubleshooting. I had already tried safe mode, disabling each extension one at a time, disabling them all, pretty much everything I could think of or Google before I even posted here hoping for help. This morning I turned off add-ons in selective sync and began to actually remove extensions instead of disable them. When I removed Turn Off the Lights and tried aol.com Firefox handled it well enough to be usable although the CPU % spikes to 100%, it does flucuate between 45% and 100% but I was able to actually continue to browse with no hangs or erratic behavior, at least for the 30 seconds or so I tried which was much further than I have been able to before.

My conclusion is an update to Turn Off the Lights does not react well to the coding of aol.com as I have used this extension without issues for some time; will look for previous version now and try again.

Trying to come up with a solution led me to start up using Snow Leopard and Firefox 48.0.2. I found I still had the same problem soon after opening another tab on aol.com; lag, erratic scrolling behavior, spinning beach ball, leading to force quitting Firefox. I restarted in Sierra, went to Firefox to begin more trial and error troubleshooting. I had already tried safe mode, disabling each extension one at a time, disabling them all, pretty much everything I could think of or Google before I even posted here hoping for help. This morning I turned off add-ons in selective sync and began to actually remove extensions instead of disable them. When I removed Turn Off the Lights and tried aol.com Firefox handled it well enough to be usable although the CPU % spikes to 100%, it does flucuate between 45% and 100% but I was able to actually continue to browse with no hangs or erratic behavior, at least for the 30 seconds or so I tried which was much further than I have been able to before. My conclusion is an update to Turn Off the Lights does not react well to the coding of aol.com as I have used this extension without issues for some time; will look for previous version now and try again.

Umnikazi wombuzo

False hope as optimism evaporates upon more testing with older versions and with Turn Off the Lights uninstalled. Wasted too much time on this, Opera here I come.

False hope as optimism evaporates upon more testing with older versions and with Turn Off the Lights uninstalled. Wasted too much time on this, Opera here I come.

Umnikazi wombuzo

Both Opera 40 and Safari 10 handle aol.com without a hitch although Opera sync is a frustrating exercise and there is no way to stop autoplay in Safari. My solution is to use Opera as my browser but keep Firefox solely for sync purposes. If I add a bookmark to Opera I just open it in Firefox so it will sync to my other devices and I will have access to it.

Both Opera 40 and Safari 10 handle aol.com without a hitch although Opera sync is a frustrating exercise and there is no way to stop autoplay in Safari. My solution is to use Opera as my browser but keep Firefox solely for sync purposes. If I add a bookmark to Opera I just open it in Firefox so it will sync to my other devices and I will have access to it.

Umnikazi wombuzo

Tonight I started Firefox to check for an update and began browsing. Since AOL and Yahoo are my two bookmarked "news" sites I naturally started there, Yahoo first. Without thinking I went right on to AOL and was browsing along when I noticed I was having no problems and had three tabs open. I had forgot I was on Firefox and was surprised when I looked that it was Firefox. I opened Processes and checked that Firefox was only at 45 to 85% CPU and working fine. I then checked to see if any extensions had been updated but all updates were from Oct. 8 so an extension update wasn't the cause. Firefox hadn't been updated so then I checked "About this Mac" for recent installations. There were two, both on the 14th, 1. Incompatible Kernel Extension Configuration Data, and 2. XProtectPlistConfigData. One of these must have corrected something but I don't have a clue what.

Tonight I started Firefox to check for an update and began browsing. Since AOL and Yahoo are my two bookmarked "news" sites I naturally started there, Yahoo first. Without thinking I went right on to AOL and was browsing along when I noticed I was having no problems and had three tabs open. I had forgot I was on Firefox and was surprised when I looked that it was Firefox. I opened Processes and checked that Firefox was only at 45 to 85% CPU and working fine. I then checked to see if any extensions had been updated but all updates were from Oct. 8 so an extension update wasn't the cause. Firefox hadn't been updated so then I checked "About this Mac" for recent installations. There were two, both on the 14th, 1. Incompatible Kernel Extension Configuration Data, and 2. XProtectPlistConfigData. One of these must have corrected something but I don't have a clue what.

Umnikazi wombuzo

I went back after my last posting and tried again leading to not working well again, laggy, slow scrolling when a new tab opens. pretty much hate this

I went back after my last posting and tried again leading to not working well again, laggy, slow scrolling when a new tab opens. pretty much hate this
jscher2000
  • Top 10 Contributor
8792 izisombululo 71909 izimpendulo
Kuphostiwe

Bummer, I thought you had it solved.

Do you use an ad blocker? AOL is ad-heavy, so if you don't, that might help. This one has a reputation for being easy to use and lightweight from a performance perspective:

https://addons.mozilla.org/firefox/addon/ublock-origin/

Bummer, I thought you had it solved. Do you use an ad blocker? AOL is ad-heavy, so if you don't, that might help. This one has a reputation for being easy to use and lightweight from a performance perspective: https://addons.mozilla.org/firefox/addon/ublock-origin/
jscher2000
  • Top 10 Contributor
8792 izisombululo 71909 izimpendulo
Kuphostiwe

It seems a bit nuts to me to have Firefox using so much CPU. Could it be struggling to decode videos on those pages?

It seems a bit nuts to me to have Firefox using so much CPU. Could it be struggling to decode videos on those pages?

Umnikazi wombuzo

jscher2000 said

It seems a bit nuts to me to have Firefox using so much CPU. Could it be struggling to decode videos on those pages?

Hello, thanks for your replies. I have seen Firefox jump to 245% and higher when I am watching CPU % on aol.com. It seems to happen when I open a link which aol must have coded to open in a new tab since I seem to have no problems until I click on a link. I do use an adblocker, the full version of Adguard which I highly recommend by the way, however I have "reset" Firefox, started in safe mode, uninstalled and reinstalled Firefox, tried in a different user account on my Mac, just about everything I can think of or can Google. Opera has a built-in adblocker and when I went to aol.com it had a message like, "What is this, an ad factory" which I found humorous. Opera also blocks all those videos in aol which Adguard does not do. I also don't have Flash installed in Opera but I have click to play element in Firefox with ask to activate set on all plugins. This situation really has me stumped. I even started up in Snow Leopard with Firefox 48.0.2, which used to work, and ran into the same problem which seemed strange with nothing seemingly being updated there anymore. I also tried 50 beta and that had problems, although didn't seem as severe but still slow and laggy. Then there are those instances where it works for a while and I think its solved only to find it isn't.

''jscher2000 [[#answer-927214|said]]'' <blockquote> It seems a bit nuts to me to have Firefox using so much CPU. Could it be struggling to decode videos on those pages? </blockquote> Hello, thanks for your replies. I have seen Firefox jump to 245% and higher when I am watching CPU % on aol.com. It seems to happen when I open a link which aol must have coded to open in a new tab since I seem to have no problems until I click on a link. I do use an adblocker, the full version of Adguard which I highly recommend by the way, however I have "reset" Firefox, started in safe mode, uninstalled and reinstalled Firefox, tried in a different user account on my Mac, just about everything I can think of or can Google. Opera has a built-in adblocker and when I went to aol.com it had a message like, "What is this, an ad factory" which I found humorous. Opera also blocks all those videos in aol which Adguard does not do. I also don't have Flash installed in Opera but I have click to play element in Firefox with ask to activate set on all plugins. This situation really has me stumped. I even started up in Snow Leopard with Firefox 48.0.2, which used to work, and ran into the same problem which seemed strange with nothing seemingly being updated there anymore. I also tried 50 beta and that had problems, although didn't seem as severe but still slow and laggy. Then there are those instances where it works for a while and I think its solved only to find it isn't.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71909 izimpendulo
Kuphostiwe

One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily?

One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily?

Umnikazi wombuzo

jscher2000 said

One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily?

Hi again, I have actually been looking for a way to open links in same window via Google but did not find anything. Thanks for the tip, will try that now and get back.

''jscher2000 [[#answer-927351|said]]'' <blockquote> One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily? </blockquote> Hi again, I have actually been looking for a way to open links in same window via Google but did not find anything. Thanks for the tip, will try that now and get back.

Umnikazi wombuzo

SadCrasher said

jscher2000 said
One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily?

Hi again, I have actually been looking for a way to open links in same window via Google but did not find anything. Thanks for the tip, will try that now and get back.

Back again, I did test this by copying link location and pasting, and although the CPU% went all over from 30 to 135% the page reacted properly and I was able to scroll and even enter a comment with no obvious lag.

''SadCrasher [[#answer-927352|said]]'' <blockquote> ''jscher2000 [[#answer-927351|said]]'' <blockquote> One way to open a link in the same tab is to click and drag the link up and drop it on the address bar. Can AOL links be opened that way and, if they can, do you encounter the same performance issue or does it load more easily? </blockquote> Hi again, I have actually been looking for a way to open links in same window via Google but did not find anything. Thanks for the tip, will try that now and get back. </blockquote> Back again, I did test this by copying link location and pasting, and although the CPU% went all over from 30 to 135% the page reacted properly and I was able to scroll and even enter a comment with no obvious lag.

Umnikazi wombuzo

After failing so far to find a solution, only that it happens when links are opened in a new tab, I continue my search. Since I have found that some times aol.com does seem to work, I decided that maybe it had to do with certain of their "sections." I tried this morning on a "sports" story and everything seemed well. Then I tried a "lifestyle" story and, once again, no noticeable problem. Then I tried a "news" story and after the new tab opened Firefox began to slow, eventually getting to that pretty beach ball to look at.

After failing so far to find a solution, only that it happens when links are opened in a new tab, I continue my search. Since I have found that some times aol.com does seem to work, I decided that maybe it had to do with certain of their "sections." I tried this morning on a "sports" story and everything seemed well. Then I tried a "lifestyle" story and, once again, no noticeable problem. Then I tried a "news" story and after the new tab opened Firefox began to slow, eventually getting to that pretty beach ball to look at.

Umnikazi wombuzo

After trying again with the main aol.com open and another aol news link opened in a "new" tab Firefox slowed to a crawl and both CPU and memory were high, 150+ % and around 1G showing under the memory tab. I then clicked on this sites bookmark and eventually it opened with the main aol.com tab still loaded. CPU % dropped to almost nothing actually disappearing from the viewable list at times, bouncing around between almost nothing and 10 to 13%, memory stayed near 1G.

After trying again with the main aol.com open and another aol news link opened in a "new" tab Firefox slowed to a crawl and both CPU and memory were high, 150+ % and around 1G showing under the memory tab. I then clicked on this sites bookmark and eventually it opened with the main aol.com tab still loaded. CPU % dropped to almost nothing actually disappearing from the viewable list at times, bouncing around between almost nothing and 10 to 13%, memory stayed near 1G.
jscher2000
  • Top 10 Contributor
8792 izisombululo 71909 izimpendulo
Kuphostiwe

Do you want to try temporarily turning off Flash for aol.com to see whether that is the culprit? While viewing any page on aol.com:

Open the Permissions panel of the Page Info dialog using any of these:

  • right-click (Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find a row for "Adobe Flash" and you can select "Always Ask" to switch AOL to "click-to-play" permission for Flash. This will delay Flash from starting on a page until you approve it, so you can see whether the problem still occurs.

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

If you want finer control: This extension addresses the issue of only wanting some videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tested it recently)

Do you want to try temporarily turning off Flash for aol.com to see whether that is the culprit? While viewing any page on aol.com: Open the Permissions panel of the Page Info dialog using any of these: * right-click (Ctrl+click) a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Near the top, you'll find a row for "Adobe Flash" and you can select "Always Ask" to switch AOL to "click-to-play" permission for Flash. This will delay Flash from starting on a page until you approve it, so you can see whether the problem still occurs. With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. ''If you want finer control:'' This extension addresses the issue of only wanting ''some'' videos on a page to play: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ (I haven't tested it recently)