Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I roll back to a previous version of Firefox - I am on 49.0.1

  • 8 uphendule
  • 9 zinale nkinga
  • 6081 views
  • Igcine ukuphendulwa ngu HenryELenz

more options

I thought the last version was locking up too much but now that I have the "updated" version, I long for the lockups I was having.

Now I can't even scroll down a page smoothly most of the time [or up the page] - I sometimes have to refresh the page just to get further down the screen. And often just WAIT for the browser to catch up to the last dozen keys that were hit -- if it actually catches up.

What is going on? Why are you turning Firefox into the patchy mess that Explorer devolved into? Firefox Update after update after update - within days of each other, and all that seems to be happening, is that there are an increasing amount of slow-downs, lockups, and crashes. If it gets degraded much more, then it will be more difficult and cumbersome to use than Explorer. It is actually really close to that point now.

Plugincontainer is getting more intrusive and resource hogging than ever before. It usually runs in the neighborhood of 50% of the CPU time --50%!!!!

These attached images show the scrolling issue -- and please note that unless I hit F5 [refresh], the display will remain like this - I hit print screen,, pasted that into a paint file and posted here - and that page is STILL like that!!

How do I revert to a working version of Firefox? Something is massively wrong with this one.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

hi henry, please try the following (not in order to roll-back, but to solve the problem): enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layers.allow-d3d9-fallback. double-click it and change its value to false and then restart the browser once...

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (8)

more options

Hi,

We are currently aware of this bug. Please see bug 1304360 for more information about the situation.

This issue can currently be solved by disabling hardware acceleration on Firefox.

The developers need your help to solve this issue. If possible, can you please enter about:support in the Firefox address bar. This page contains information about your system and Firefox. Please click the Copy text to clipboard button and paste the information into this thread. This will help the developers to discover the cause of the issue and create a potential patch.

Thanks in advance for your assistance with this bug. Sorry for any inconvenience.

more options

One thing I am concerned with, is that by applying patch after patch after patch, Firefox may be headed down the road that caused Microsoft so many issues with Explorer. Eventually you will have 'overlapping' patches and they will start causing issues beyond the reason they were initially installed. And yes, I know that 'overlapping' isn't really appropriate for a description of software but it is the closest analogy I could think of at the moment. To many patches might wind up having unintended consequences that will render Firefox less efficient than Explorer. That has been patched to death and is now something most people want to stay away from.

BTW, the scrolling issue even showed up in this window when I scrolled down the information I posted into this text block.

Here is the information you requested from the about:support page for my PC. I hope it helps:

Application Basics


Name: Firefox Version: 49.0.1 Build ID: 20160922113459 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0 OS: Windows_NT 6.1 Multiprocess Windows: 4/4 (Enabled by default) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports (including 4 pending crashes in the given time range)

Extensions


Name: Multi-process staged rollout Version: 1.3 Enabled: true ID: e10srollout@mozilla.org

Name: Pocket Version: 1.0.4 Enabled: true ID: firefox@getpocket.com

Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org

Graphics


Features Compositing: Direct3D 9 Asynchronous Pan/Zoom: wheel input enabled WebGL Renderer: Google Inc. -- ANGLE (Radeon X1300/X1550 Series (Microsoft Corporation - WDDM) Direct3D9Ex vs_3_0 ps_3_0) Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted DirectWrite: false (6.1.7600.16385) GPU #1 Active: Yes Description: Radeon X1300/X1550 Series (Microsoft Corporation - WDDM) Vendor ID: 0x1002 Device ID: 0x7183 Driver Version: 8.56.1.15 Driver Date: 4-24-2009 Drivers: atiumdag atiumdva atitmmxx Subsys ID: 03021028 RAM: Unknown

Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo failures: [GFX1-]: [D3D11] create component blender failed: 0x80070057, 0 Decision Log DIRECT2D: unavailable by runtime: Failed to acquire a Direct2D 1.1 factory D3D11_HW_ANGLE: broken by runtime: RenderTargetViews need recreating


Failure Log (#0) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5421) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5422) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5423) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5424) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5425) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5426) LogFailure: CompositorD3D9::CreateRenderTargetFromSource: Failed to update texture Error code: 2289436780 (#5427) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5428) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5429) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5430) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5431) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5432) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5433) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5434) Error: [D3D11] create component blender failed: 0x80070057, 0 (#5435) Error: [D3D11] create component blender failed: 0x80070057, 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 8 browser.search.update: false browser.sessionstore.upgradeBackup.latestBuildID: 20160922113459 browser.startup.homepage: www.startpage.com/ browser.startup.homepage_override.buildID: 20160922113459 browser.startup.homepage_override.mstone: 49.0.1 browser.tabs.remote.autostart.2: true browser.urlbar.daysBeforeHidingSuggestionsPrompt: 2 browser.urlbar.lastSuggestionsPromptDate: 20160928 dom.apps.lastUpdate.buildID: 20160922113459 dom.apps.lastUpdate.mstone: 49.0.1 dom.apps.reset-permissions: true extensions.lastAppVersion: 49.0.1 general.autoScroll: false gfx.crash-guard.d3d11layers.appVersion: 49.0.1 gfx.crash-guard.d3d11layers.deviceID: 0x7183 gfx.crash-guard.d3d11layers.driverVersion: 8.56.1.15 gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 2 media.eme.enabled: false media.gmp-gmpopenh264.abi: x86-msvc-x86 media.gmp-gmpopenh264.enabled: true media.gmp-gmpopenh264.lastUpdate: 1474956406 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20160922113459 media.gmp-manager.lastCheck: 1475064670 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: false media.webrtc.debug.log_file: C:\Users\HOME_PC\AppData\Local\Temp\WebRTC.log network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1474957629 places.history.expiration.transient_current_max_pages: 53634 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 1 services.sync.declinedEngines: storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1474957626

Important Locked Preferences


Places Database


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.12 Version in use: 4.12

NSS Expected minimum version: 3.25 Version in use: 3.25

NSSSMIME Expected minimum version: 3.25 Version in use: 3.25

NSSSSL Expected minimum version: 3.25 Version in use: 3.25

NSSUTIL Expected minimum version: 3.25 Version in use: 3.25

Experimental Features


more options

Thank you very much sharing this information.

As I understand it, the issue has been caused by a change that was made in order to improve graphics rendering in Firefox. It appears to have caused some issues with older hardware and the developers are working hard to find a fix for it.

Thanks for expressing your concerns. The developers are constantly at work to provide users with the best browsing experience, while also creating the cutting edge technology for the browser. Unfortunately, the road is not always smooth and there are a few bumps.

more options

Bumps are one thing, but patch after patch after patch after patch is doing nothing to make Firefox more reliable. In fact, lately it seems that every patch is bring MORE problems.

I had to hit refresh 5 times just to get to the bottom of this page to read your response, and then four more to get to the reply block here.

How do I roll back to an earlier version of Firefox?

Okulungisiwe ngu HenryELenz

more options

We don't recommend using older versions because some of our patches are for security purposes, but we archive every Firefox version on our FTP server.

Mozilla cares about what our users have to say about the browser and we value our users' feedback. Sharing your thoughts can help to shape Firefox. Please feel free to share some feedback with us using this link.

Thanks.

Warning: Older versions may be vulnerable to security threats. Use caution when using old versions of Firefox.
Note: The Windows installers marked as stub may not work.
more options

Can the most recent patch(es) be rolled back since the scrolling problem only happened after they were installed.?

Just now on ebay, I had to refresh over a dozen dozen times to go down one page. Other sites also have the scrolling issue, including this one, but for some reason, ebay seems to have more problems than most of the other sites I have visited.

Thanks for your assistance.

Henry

more options

Isisombululo Esikhethiwe

hi henry, please try the following (not in order to roll-back, but to solve the problem): enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layers.allow-d3d9-fallback. double-click it and change its value to false and then restart the browser once...

more options

Thanks, Philipp, that does seem to work - there had been some pages that I was unable to view at all because refresh put me back near the top of the page and no matter how far I tried to scroll down before the scroll problem appeared, the refresh put me so far up the page again that even in a couple of dozen attempts, I was unable to go any further down the page.

Now those same pages are viewable all the way down.