Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Youtube HTML5 videos not playing (some)

  • 3 uphendule
  • 4 zinale nkinga
  • 49368 views
  • Igcine ukuphendulwa ngu acegeek

more options

So I'm getting a error "Your browser does not currently recognize any of the video formats available" and when clicking the link, it says H.264 and MSE & H.264 are not supported. I used to get the black error screen for a split second before the video would blink and (I'm guessing) select another player and just play normally. Today is the first day that I've had this screen permanently displayed and it only shows up for a few videos. I can watch other videos on the same channel, just one or two that have the error.

It's the same if I try it in Safe Mode or with a new profile. I updated Firefox to 49.0, updated java, updated windows media component, and tried it with "media.windows-media-foundation.enabled" true and on false. No changes

I'm at my wits end with this one! I can watch the videos just fine in Chrome, but would much rather prefer to continue to use firefox as my default browser. Any help is appreciated. Thanks!

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I don't know whether YouTube has changed, or possibly you lost an add-on you used to use that tricked YouTube into using Flash -- because Firefox has never, as far as I know, been able to decode H.264 video on Windows XP.

Example of extension to trick the site into using Flash: https://addons.mozilla.org/firefox/addon/youtube-flash-player/

But actually, your plugins list doesn't show Shockwave Flash at all. Could it have become severely out-of-date and therefore been disabled?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

more options

Isisombululo Esikhethiwe

I don't know whether YouTube has changed, or possibly you lost an add-on you used to use that tricked YouTube into using Flash -- because Firefox has never, as far as I know, been able to decode H.264 video on Windows XP.

Example of extension to trick the site into using Flash: https://addons.mozilla.org/firefox/addon/youtube-flash-player/

But actually, your plugins list doesn't show Shockwave Flash at all. Could it have become severely out-of-date and therefore been disabled?

more options

jscher2000 said

I don't know whether YouTube has changed, or possibly you lost an add-on you used to use that tricked YouTube into using Flash -- because Firefox has never, as far as I know, been able to decode H.264 video on Windows XP. Example of extension to trick the site into using Flash: https://addons.mozilla.org/firefox/addon/youtube-flash-player/ But actually, your plugins list doesn't show Shockwave Flash at all. Could it have become severely out-of-date and therefore been disabled?

Thanks! Updating Flash did the trick! I'm not sure why it wasn't automatically updating, as that's usually what I have it set on. But I didn't notice it wasn't even in my plugin list anymore, so a second set of eyes definitely helped.

Thanks again :)