Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I disable "Plugin Container for Firefox"

  • 6 uphendule
  • 7 zinale nkinga
  • 4705 views
  • Igcine ukuphendulwa ngu Mozilla5855

more options

Plugin Container for Firefox is using loads of memory so I want to disable it. My operating system is Windows Vista Home Basic, 32-bit operating system.

Isisombululo esikhethiwe

Or perhaps a site-specific permission might be overriding the general setting? While on Yahoo finance, you can call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Plugin permissions should be listed at the top. Although, if all plugins are disabled, maybe not. Hmm...

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

How much is "loads"?

Anyway, the short answer is that Firefox hasn't had a way to disable plugin-container.exe for many years, it is too integral to the program.

If you find that plugins are using too much memory, you can disable those plugins on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, set the global permission any unnecessary plugins to "Never Activate". For those you want used as little as possible, select the "Ask to Activate" permission.

With "Ask to Activate", when you visit a site that wants to use a plugin, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

If you see a good reason to use the plugin(s) listed in the notification drop-down, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow it/them. You can trust the site for the time being or permanently.

But some pages use plugins only for tracking or for playing ads, so if you don't see an immediate need, feel free to ignore the notification! It will just sit there in case you want to use it later.

more options

All my plugins are set to NEVER ACTIVATE, but the Plugin Container for Firefox comes up in the Task Manager when I go to http://finance.yahoo.com/

more options

Hmm, perhaps one of your extensions is causing that. Do you have any from Yahoo? On the Add-ons page -- either

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

-- in the left column, click Extensions. Anything related to Yahoo on the right side that you could try disabling? Sometimes a link will appear above a disabled extension to restart Firefox; the disablement isn't effect in that case until after the restart, but the link will stay there in case you need to complete other work, so you can come back to it.

Otherwise, you could test in Firefox's Safe Mode. In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Isisombululo Esikhethiwe

Or perhaps a site-specific permission might be overriding the general setting? While on Yahoo finance, you can call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Plugin permissions should be listed at the top. Although, if all plugins are disabled, maybe not. Hmm...

more options

"Loads" is 280,000K. As for extensions what I have is Firefox Hotfix and Microsoft.NET Framework Assistant, and they are both disabled.

more options

"Loads" is 280,000K. As for extensions what I have is Firefox Hotfix and Microsoft.NET Framework Assistant, and they are both disabled. I used Yahoo as an example. The Plugin Container comes up whenever I go into a page that has any kind of video.