X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox wont download Widevine due to connection failure

Kuphostiwe

Netflix and other various videos will not work when I try to play them in firefox due to the browser saying firefox is installing components needed to play. I have tried to wait but now it have been a few weeks and nothing has changed. I have gone into the settings and plugins, all it says is Widevine will be installed shortly. I have it set to always update and always activate. I then figured out how to find a manual download of Widevine on the internet and try to download. It gives me a safety warning giving me the choice to allow or to block and I click allow. Then it begins its download and once it gets to the end a message pops up " Unable to download due to connection failure. I am not sure what to do. I need to be able to watch some of the videos for school.

Netflix and other various videos will not work when I try to play them in firefox due to the browser saying firefox is installing components needed to play. I have tried to wait but now it have been a few weeks and nothing has changed. I have gone into the settings and plugins, all it says is Widevine will be installed shortly. I have it set to always update and always activate. I then figured out how to find a manual download of Widevine on the internet and try to download. It gives me a safety warning giving me the choice to allow or to block and I click allow. Then it begins its download and once it gets to the end a message pops up " Unable to download due to connection failure. I am not sure what to do. I need to be able to watch some of the videos for school.

Isisombululo esikhethiwe

ok, please try to disable the scanning of ssl connections in bitdefender like it is described in https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bitdefender (at least temporarily until the drm module is getting installed).

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • GEPlugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • Shockwave Flash 22.0 r0
  • 5.1.50428.0
  • iTunes Detector Plug-in

Isisebenziso

  • Firefox 48.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/48.0.2/WINNT/en-US/

Izandiso

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello 1.4.4 (loop@mozilla.org)
  • Firefox Hotfix 20160826.01 (firefox-hotfix@mozilla.org)
  • Grammarly for Firefox 8.689.572 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)
  • Multi-process staged rollout 1.1 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Bitdefender Wallet 2.1 (bdwteffv19@bitdefender.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.494
  • driverDate: 8-17-2015
  • driverDate2:
  • driverVersion: 10.18.10.4276
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; D3D11 blacklisted with DLL igd10iumd32.dll (10.18.10.4276); Using D3D9 API
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
philipp
  • Top 25 Contributor
  • Moderator
5330 izisombululo 23534 izimpendulo
Kuphostiwe

Impendulo Ewusizo

hi AustinTamplin, what security software are you using? and is your firefox set to automatically update under menu ≡ > options > advanced > update?

hi AustinTamplin, what security software are you using? and is your firefox set to automatically update under ''menu ≡ > options > advanced > update''?

Umnikazi wombuzo

Hello Phillip,

Currently, I have Bitdefender installed on my computer but firefox worked just fine with Bitdefender for over a year. This problem just started about two weeks ago. Also, I just checked and yes, firefox is set to automatically update.

Hello Phillip, Currently, I have Bitdefender installed on my computer but firefox worked just fine with Bitdefender for over a year. This problem just started about two weeks ago. Also, I just checked and yes, firefox is set to automatically update.
philipp
  • Top 25 Contributor
  • Moderator
5330 izisombululo 23534 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

ok, please try to disable the scanning of ssl connections in bitdefender like it is described in https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bitdefender (at least temporarily until the drm module is getting installed).

ok, please try to disable the scanning of ssl connections in bitdefender like it is described in https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_bitdefender (at least temporarily until the drm module is getting installed).

Umnikazi wombuzo

Okay, that somewhat worked. It changed the message, instead of saying Cannot download due to connection failure now it says "Add on downloaded could not be installed because plugin appears to be corrupt." It seems like we got a little closer.

Okay, that somewhat worked. It changed the message, instead of saying Cannot download due to connection failure now it says "Add on downloaded could not be installed because plugin appears to be corrupt." It seems like we got a little closer.
AliceWyman
  • Moderator
240 izisombululo 2607 izimpendulo
Kuphostiwe

Are you still trying a manual download of Widevine, as you wrote in your original post? That may be the problem.

Firefox automatically downloads and installs the Widevine Content Decryption Module (CDM) by default. See Watch DRM content on Firefox.

If you already turned off the Scan SSL setting in Bitdefender, go to your Firefox (menu) Add-ons --> Plugins list and make sure Widevine Content Decryption Module provided by Google Inc. is set to "Always Activate".

Are you still trying a manual download of Widevine, as you wrote in your original post? That may be the problem. Firefox automatically downloads and installs the Widevine Content Decryption Module (CDM) by default. See [[Watch DRM content on Firefox]]. If you already turned off the Scan SSL setting in Bitdefender, go to your Firefox (menu) Add-ons --> Plugins list and make sure ''Widevine Content Decryption Module provided by Google Inc.'' is set to "Always Activate".

Okulungisiwe ngu AliceWyman

Umnikazi wombuzo

I had left it off for a two days while using my computer. I use it a lot for college and such. I also read on another form that said "Those steps are:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) Double-click the xpinstall.signatures.required preference to switch it from true to false -- note that this is for Firefox 43 only

Unfortunately, this is a global setting; there's currently no way to make an exception only for this extension. " So I had followed these instructions it still didnt download manually so I left the SSL and the Signature off for a few hours and then firefox fixed its self. Now I turn them back on and widevine is working again. Thanks

I had left it off for a two days while using my computer. I use it a lot for college and such. I also read on another form that said "Those steps are: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste xpin and pause while the list is filtered (3) Double-click the xpinstall.signatures.required preference to switch it from true to false -- note that this is for Firefox 43 only Unfortunately, this is a global setting; there's currently no way to make an exception only for this extension. " So I had followed these instructions it still didnt download manually so I left the SSL and the Signature off for a few hours and then firefox fixed its self. Now I turn them back on and widevine is working again. Thanks
AliceWyman
  • Moderator
240 izisombululo 2607 izimpendulo
Kuphostiwe

AustinTamplin said

I left the SSL and the Signature off for a few hours and then firefox fixed its self. Now I turn them back on and widevine is working again. Thanks

Thanks for letting us know the the problem is now fixed. Turning off the Scan SSL setting in Bitdefender is the likely reason that Widevine is working now so I'll mark philipp's answer as the solution.

''AustinTamplin [[#answer-917183|said]]'' <blockquote> I left the SSL and the Signature off for a few hours and then firefox fixed its self. Now I turn them back on and widevine is working again. Thanks </blockquote> Thanks for letting us know the the problem is now fixed. Turning off the Scan SSL setting in Bitdefender is the likely reason that Widevine is working now so I'll mark philipp's answer as the solution.