X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox won't accept https pages - constant error messages - can't log in anywhere.

Kuphostiwe

Running Windows 10 on HP Pavilion Desktop, Firefox stopped allowing any access to https pages 5 days ago. Constant immediate error messages, sometimes "Secure Connection Failed", sometimes "Connection timed out".

(I am posting this from an old Windows 7 Computer ( I can't from the Windows 10 one as I can't log in on it - no chance of syncing it).

I have Kapersky and contacted them and not Kapersky problem. Did clean resintalls of Firefox. No Joy. Tried old versions of Firefox. No Joy.

Hired a techie geek, they spent 8 hours trying to get it to work. We tried everything in this link plus more https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems


Really don't want to try a System Restore. Am I doomed to Chrome?

Running Windows 10 on HP Pavilion Desktop, Firefox stopped allowing any access to https pages 5 days ago. Constant immediate error messages, sometimes "Secure Connection Failed", sometimes "Connection timed out". (I am posting this from an old Windows 7 Computer ( I can't from the Windows 10 one as I can't log in on it - no chance of syncing it). I have Kapersky and contacted them and not Kapersky problem. Did clean resintalls of Firefox. No Joy. Tried old versions of Firefox. No Joy. Hired a techie geek, they spent 8 hours trying to get it to work. We tried everything in this link plus more https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Really don't want to try a System Restore. Am I doomed to Chrome?

Eminye Imininingwane Yohlelo

Fakela amapulagi

This is from the Windows 7 computer (Not the one with the problem). One the Windows 10 computer Firefox is clean.


  • Adobe PDF Plug-In For Firefox and Netscape 11.0.17
  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Office Live Update v1.5
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • BlackBerry WebSL Browser Plug-In
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • 5.1.50428.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4224 izisombululo 58941 izimpendulo
Kuphostiwe

Impendulo Ewusizo

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

https://www.bing.com/search?q=web+site+access+denied

https://support.mozilla.org/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe PDF Plug-In For Firefox and Netscape 11.0.17 Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Adobe PDF Plug-In For Firefox and Netscape: Adobe Reader Version Version 2015.017.20050 Note: Other Software is offered in the download.

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' https://www.bing.com/search?q=web+site+access+denied https://support.mozilla.org/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings. --------------- Separate Issue; Your System Details shows; Installed Plug-ins Adobe PDF Plug-In For Firefox and Netscape 11.0.17 Adobe PDF Plug-In For Firefox and Netscape 15.17.20050 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Adobe PDF Plug-In For Firefox and Netscape: '''[http://get.adobe.com/reader/ Adobe Reader Version Version 2015.017.20050]''' '''Note: Other Software''' is offered in the download.

Umnikazi wombuzo

Hi Fred, thanks for getting back to me.

I did to a complete unistall of Kapersky and Clean install of Mozilla (renaming folders in the app data area to "Old Mozilla" and allowing new ones to be created). Still no joy.

Right now I am trying this. https://support.mozilla.org/en-US/kb/unable-access-secure-https-sites-firefox-43

Hi Fred, thanks for getting back to me. I did to a complete unistall of Kapersky and Clean install of Mozilla (renaming folders in the app data area to "Old Mozilla" and allowing new ones to be created). Still no joy. Right now I am trying this. https://support.mozilla.org/en-US/kb/unable-access-secure-https-sites-firefox-43

Umnikazi wombuzo

Checked all of the date stuff as well. Deleted cert8 and pref files. I think we pretty much tried everything.

Checked all of the date stuff as well. Deleted cert8 and pref files. I think we pretty much tried everything.

Umnikazi wombuzo

As I mentioned, I am communicating to you using an old Windows 7 computer which also has Kapersky and Firefox 48.02 and have no issues with it.

As I mentioned, I am communicating to you using an old Windows 7 computer which also has Kapersky and Firefox 48.02 and have no issues with it.

Umnikazi wombuzo

https://support.mozilla.org/en-US/kb/unable-access-secure-https-sites-firefox-43 This didn't work.
FredMcD
  • Top 10 Contributor
4224 izisombululo 58941 izimpendulo
Kuphostiwe

I've called for more help. Good luck.

I've called for more help. Good luck.

Umnikazi wombuzo

Thanks so much. I've gone through all of your links and tried everything. No problems with Explorer or Chrome - just Firefox.

Thanks so much. I've gone through all of your links and tried everything. No problems with Explorer or Chrome - just Firefox.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Did you make sure to remove your profile data, or at least start with a fresh profile? There's no use reinstalling any version if you leave the Firefox profile data untouched, which may contain the error and cause issues. An easy way to create and test with a new profile is adding -p to the Firefox startup link (as explained in Profile Manager - Create, remove, or switch Firefox profiles). Starting in Firefox 48, you could also type about:profiles in the location bar, create a profile and open a separate instance using it, so that would be even easier.

Also make sure to set Firefox to use a direct connection (depending on the network) - sometimes "Use system proxy settings" (selected by default) can spoil things.

In case you do need to use (or are using) a proxy, this support question may be interesting to read. Keep in mind its solution is profile related, since the certificate issue mentioned there affects the certificate archive stored in your profile. If applicable, of course you can check for redirects to http pages after entering https beforehand.

I also found this support question mentioning resetting the TCP stack could solve similar issues, including links to instructions.

Another topic on TenForums mentions BitDefender enabling a Block Internet Connection Sharing setting to be a possible cause, especially after upgrading from Windows 7. (This is not similar to the SSL scanning option as mentioned here). In case you are using some other security software, I would completey remove it temporarily to find some "exotic" setting (undocumented in the KB) causing the issue.

Finally, there would be no harm in deleting (or moving) cached files related to profiles residing in C:\Users\<username>\AppData\Local\Mozilla\Firefox\Profiles\ for the profile(s) involved. Caution: not the path containing Roaming on the bolded position, since that's the profile itself. (More info)

Did you make sure to remove your profile data, or at least start with a fresh profile? There's no use reinstalling any version if you leave the Firefox profile data untouched, which may contain the error and cause issues. An easy way to create and test with a new profile is adding -p to the Firefox startup link (as explained in [[Use the Profile Manager to create and remove Firefox profiles]]). Starting in Firefox 48, you could also type ''about:profiles'' in the location bar, create a profile and open a separate instance using it, so that would be even easier. Also make sure to set Firefox to use a direct connection (depending on the network) - sometimes "Use system proxy settings" (selected by default) can spoil things. In case you ''do'' need to use (or are using) a proxy, [https://support.mozilla.org/questions/1025403 this support question] may be interesting to read. Keep in mind its solution is profile related, since the certificate issue mentioned there affects the certificate archive stored in your profile. If applicable, of course you can check for redirects to http pages after entering https beforehand. I also found [https://support.mozilla.org/questions/1075112 this support question] mentioning resetting the TCP stack could solve similar issues, including links to instructions. Another [http://www.tenforums.com/network-sharing/11009-just-upgraded-windows-10-no-internet-connection-2.html topic] on TenForums mentions BitDefender enabling a Block Internet Connection Sharing setting to be a possible cause, especially after upgrading from Windows 7. (This is not similar to the SSL scanning option as mentioned [https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER here]). In case you are using some other security software, I would completey remove it temporarily to find some "exotic" setting (undocumented in the KB) causing the issue. Finally, there would be no harm in deleting (or moving) cached files related to profiles residing in C:\Users\<username>\AppData\'''Local'''\Mozilla\Firefox\Profiles\ for the profile(s) involved. Caution: not the path containing ''Roaming'' on the bolded position, since that's the profile itself. ([/questions/1130154 More info])

Umnikazi wombuzo

So very much appreciate your input.

Did you make sure to remove your profile data,

Followed instructions, deleted old user and added new one. No joy.

Also make sure to set Firefox to use a direct connection (depending on the network) - sometimes "Use system proxy settings" (selected by default) can spoil things.

I have no idea how to do this I also found this support question mentioning resetting the TCP stack could solve similar issues, including links to instructions

This seems to all deal with wifi connections and no browsers working. I only have the problem with firefox.

In case you are using some other security software, I would completey remove it temporarily to find some "exotic" setting (undocumented in the KB) causing the issue. I did extensive work with Kapersky support and have completely uninstalled it and Firefox still had the same problems. Kapersky determined it wasn't at their end. I have the same setup on this Windows 7 computer I am currently using and there are no issues.

Finally, there would be no harm in deleting (or moving) cached files related to profiles residing in C:\Users\<username>\AppData\Local\Mozilla\Firefox\Profiles\ for the profile(s) involved. Caution: not the path containing Roaming on the bolded position, since that's the profile itself. (More info)

Did try this before, but just tried it again after uninstalling Firefox, went into app data roaming and local, deleted the Mozilla folders. Restarted computer. Disabled Kapersky, reinstalled Mozilla, and still no access to HTTPS sites. (no extensions or addons)

I am completely befuddled. It was working fine a few days ago. Was there some update done?

So very much appreciate your input. ''Did you make sure to remove your profile data, '' Followed instructions, deleted old user and added new one. No joy. ''Also make sure to set Firefox to use a direct connection (depending on the network) - sometimes "Use system proxy settings" (selected by default) can spoil things.'' I have no idea how to do this '' I also found this support question mentioning resetting the TCP stack could solve similar issues, including links to instructions'' This seems to all deal with wifi connections and no browsers working. I only have the problem with firefox. ''In case you are using some other security software, I would completey remove it temporarily to find some "exotic" setting (undocumented in the KB) causing the issue.'' I did extensive work with Kapersky support and have completely uninstalled it and Firefox still had the same problems. Kapersky determined it wasn't at their end. I have the same setup on this Windows 7 computer I am currently using and there are no issues. ''Finally, there would be no harm in deleting (or moving) cached files related to profiles residing in C:\Users\<username>\AppData\Local\Mozilla\Firefox\Profiles\ for the profile(s) involved. Caution: not the path containing Roaming on the bolded position, since that's the profile itself. (More info)'' Did try this before, but just tried it again after uninstalling Firefox, went into app data roaming and local, deleted the Mozilla folders. Restarted computer. Disabled Kapersky, reinstalled Mozilla, and still no access to HTTPS sites. (no extensions or addons) I am completely befuddled. It was working fine a few days ago. Was there some update done?

Umnikazi wombuzo

I forgot to mention on Kapersky firefox is listed as a trusted site. I did try removing it and adding it back, and that didn't work. I don't think it is a Kapersky and I have the same problem when it is disabled.

I forgot to mention on Kapersky firefox is listed as a trusted site. I did try removing it and adding it back, and that didn't work. I don't think it is a Kapersky and I have the same problem when it is disabled.

Umnikazi wombuzo

We also tried creating a new user account on Windows 10 and trying to get firefox to work with that, no joy.

We also tried creating a new user account on Windows 10 and trying to get firefox to work with that, no joy.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

You can change the connection method by going to Options > Advanced > Network > Settings.

After uninstalling (all) security software to no avail, it's obvious to assume that no internet security software is interfering anywhere. I assume you are familiar with the fact that 2 pieces of firewall software may cause issues too, i.e. Windows Firewall would need to be disabled in any case when using some other software.

My suspicion is in some certificate issue at this point, since a) the issue is related to https only (so you can connect to http, right?) and b) Firefox has a different way of using certificates compared to other browsers (its own certificate store - cert8.db). I know resetting the Windows TCP stack was referred to as a solution to general networking issues, but I just keep thinking part of it may be the culprit - i.e. the part not used by other browsers even though it sounds funny - making sure the Windows networking gets fixed even knowing other browsers don't suffer the issue might be worth after all if it isn't too much trouble, especially since upgrading to Windows 10 seems to be able to cause it. And apart from resetting the TCP stack for wi-fi, this may not be limited to wi-fi adapters, so I would try to be sure to check the general methods for ethernet adapters as well. Just some thoughts.

Because of upcoming changes to Firefox's way of handling certificates (see here) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup (32-bit or 64-bit), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental. When doing so, it may be best to create a separate profile for this version to test with and leave the original one as is. Come to think of it, you never mentioned running a 32 or 64-bit version, which may be interesting to know too, or rather: if the issue occurs in both versions.

Last thing I could think of: does this happen on all networks? I mean, could it be related to the home router for instance, while things work properly elsewhere? Even using IPv6 and/or a router setting or automatic firmware upgrade may affect the networking. And, did you try booting Windows in safe mode with networking enabled?

I'm out of other ideas right now and may need to recharge a bit in some bar or other place. ;)

You can change the connection method by going to Options > Advanced > Network > Settings. After uninstalling (all) security software to no avail, it's obvious to assume that no internet security software is interfering anywhere. I assume you are familiar with the fact that 2 pieces of firewall software may cause issues too, i.e. Windows Firewall would need to be disabled in any case when using some other software. My suspicion is in some certificate issue at this point, since a) the issue is related to https only (so you can connect to http, right?) and b) Firefox has a different way of using certificates compared to other browsers (its own certificate store - cert8.db). I know resetting the Windows TCP stack was referred to as a solution to general networking issues, but I just keep thinking ''part of it'' may be the culprit - i.e. the part not used by other browsers even though it sounds funny - making sure the Windows networking gets fixed even knowing other browsers don't suffer the issue might be worth after all if it isn't too much trouble, especially since upgrading to Windows 10 seems to be able to cause it. And apart from resetting the TCP stack for wi-fi, this may not be limited to wi-fi adapters, so I would try to be sure to check the general methods for ethernet adapters as well. Just some thoughts. Because of upcoming changes to Firefox's way of handling certificates (see [https://wiki.mozilla.org/CA:AddRootToFirefox here]) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup ([http://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora/firefox-50.0a2.en-US.win32.zip 32-bit] or [http://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-aurora/firefox-50.0a2.en-US.win64.zip 64-bit]), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental. When doing so, it may be best to create a separate profile for this version to test with and leave the original one as is. Come to think of it, you never mentioned running a 32 or 64-bit version, which may be interesting to know too, or rather: if the issue occurs in both versions. Last thing I could think of: does this happen on all networks? I mean, could it be related to the home router for instance, while things work properly elsewhere? Even using IPv6 and/or a router setting or automatic firmware upgrade may affect the networking. And, did you try booting Windows in safe mode with networking enabled? I'm out of other ideas right now and may need to recharge a bit in some bar or other place. ;)

Umnikazi wombuzo

Yes, I can access all http sites, immediate error message, connection timed out or secure connection failed when I try a https page.


i.e. Windows Firewall would need to be disabled in any case when using some other software. I checked, it is only a Kapersky firewall at this time.

My suspicion is in some certificate issue at this point, since a) the issue is related to https only (so you can connect to http, right?) and b) Firefox has a different way of using certificates compared to other browsers (its own certificate store - cert8.db

I have gone in and deleted the cert8.db several times before a fresh firefox install, after an install as well. Also refreshed the Kapersky certificate.

Because of upcoming changes to Firefox's way of handling certificates (see here) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup (32-bit or 64-bit), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental. When doing so, it may be best to create a separate profile for this version to test with and leave the original one as is. Come to think of it, you never mentioned running a 32 or 64-bit version, which may be interesting to know too, or rather: if the issue occurs in both versions.


I will download the beta and Dve versions and see what happens. I'll get back on it tomorrow. I have been on this for days.

Problem computer specs: 64 bit Windows 10 - Brand new Windows 10 computer, just installed 6 weeks ago. No problems when I initially installed Firefox and synced my account from the 64 bit Windows 7 computer I am currently on.

Last thing I could think of: does this happen on all networks? I mean, could it be related to the home router for instance, while things work properly elsewhere? Even using IPv6 and/or a router setting or automatic firmware upgrade may affect the networking. And, did you try booting Windows in safe mode with networking enabled?

I have tried the uplugging and refreshing the router several. There are 3 other computers on the network without any problems.

Windows 7 - 64 bit computer - no problem (has Kapersky)

Windows 7 - upgraded to windows 10 old rickety HP laptop - just checked no problem. (has Kapersky)

There is another Windows 8 computer (that I upgraded to windows 10) that is my sister's and I don't have access to at this time.

It seems to be the Widows 10 one only at this time.

Yes we tried the reboot in safe mode on new computer - no joy.

I really appreciate your help. Eternally grateful! I can't imagine having to go back to Chrome or Explorer.

Yes, I can access all http sites, immediate error message, connection timed out or secure connection failed when I try a https page. ''i.e. Windows Firewall would need to be disabled in any case when using some other software.'' I checked, it is only a Kapersky firewall at this time. ''My suspicion is in some certificate issue at this point, since a) the issue is related to https only (so you can connect to http, right?) and b) Firefox has a different way of using certificates compared to other browsers (its own certificate store - cert8.db'' I have gone in and deleted the cert8.db several times before a fresh firefox install, after an install as well. Also refreshed the Kapersky certificate. ''Because of upcoming changes to Firefox's way of handling certificates (see here) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup (32-bit or 64-bit), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental. When doing so, it may be best to create a separate profile for this version to test with and leave the original one as is. Come to think of it, you never mentioned running a 32 or 64-bit version, which may be interesting to know too, or rather: if the issue occurs in both versions.'' I will download the beta and Dve versions and see what happens. I'll get back on it tomorrow. I have been on this for days. Problem computer specs: 64 bit Windows 10 - Brand new Windows 10 computer, just installed 6 weeks ago. No problems when I initially installed Firefox and synced my account from the 64 bit Windows 7 computer I am currently on. ''Last thing I could think of: does this happen on all networks? I mean, could it be related to the home router for instance, while things work properly elsewhere? Even using IPv6 and/or a router setting or automatic firmware upgrade may affect the networking. And, did you try booting Windows in safe mode with networking enabled?'' I have tried the uplugging and refreshing the router several. There are 3 other computers on the network without any problems. Windows 7 - 64 bit computer - no problem (has Kapersky) Windows 7 - upgraded to windows 10 old rickety HP laptop - just checked no problem. (has Kapersky) There is another Windows 8 computer (that I upgraded to windows 10) that is my sister's and I don't have access to at this time. It seems to be the Widows 10 one only at this time. Yes we tried the reboot in safe mode on new computer - no joy. I really appreciate your help. Eternally grateful! I can't imagine having to go back to Chrome or Explorer.

Umnikazi wombuzo

Hi my wonderful Tonnes:

Today's recap:

This issue comes when the Proxy server creates a dummy certificate for all HTTPS connection. By doing this, the proxy server will be able to look into the encrypted SSL/TLS traffic by impersonating the target server.

Solution: 1. In windows, Run-> certmgr.msc 2. Go to the node, "Trusted Root CertificationAuthorities" 3. Find your Organizations/ Proxy Server certificate 4. Export it. Right Click on the certificate-> All Tasks-> Export ...


Now import it to Firefox. 1. From Firefox, Options-> Advanced-> Certificates-> View Certificates 2. Navigate to "Authorities" tab 3. Click on "Import..." and import the certificate

Now, firefox will work for ALL https connections.

I tried doing this, but when I checked on whatismyip.com, there was no proxy detected. I didn't see anything remotely related to firefox in the folder. There was a Kapersky certificate, that was it.


And apart from resetting the TCP stack for wi-fi, this may not be limited to wi-fi adapters, so I would try to be sure to check the general methods for ethernet adapters as well. Just some thoughts.

The stuff regarding this is WAY above my pay grade (I'm just an average user, getting up there in years) and not sure what to try. Again, this is a new Windows 10 computer. No upgrade performed on it.

Because of upcoming changes to Firefox's way of handling certificates (see here) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup (32-bit or 64-bit), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental

This again, looks a little beyond me. I'm not sure how to "toggle the required preference in the article".


Again, thanks so much for your help.

Hi my wonderful Tonnes: Today's recap: ''This issue comes when the Proxy server creates a dummy certificate for all HTTPS connection. By doing this, the proxy server will be able to look into the encrypted SSL/TLS traffic by impersonating the target server. Solution: 1. In windows, Run-> certmgr.msc 2. Go to the node, "Trusted Root CertificationAuthorities" 3. Find your Organizations/ Proxy Server certificate 4. Export it. Right Click on the certificate-> All Tasks-> Export ... Now import it to Firefox. 1. From Firefox, Options-> Advanced-> Certificates-> View Certificates 2. Navigate to "Authorities" tab 3. Click on "Import..." and import the certificate Now, firefox will work for ALL https connections.'' I tried doing this, but when I checked on whatismyip.com, there was no proxy detected. I didn't see anything remotely related to firefox in the folder. There was a Kapersky certificate, that was it. ''And apart from resetting the TCP stack for wi-fi, this may not be limited to wi-fi adapters, so I would try to be sure to check the general methods for ethernet adapters as well. Just some thoughts.'' The stuff regarding this is WAY above my pay grade (I'm just an average user, getting up there in years) and not sure what to try. Again, this is a new Windows 10 computer. No upgrade performed on it. ''Because of upcoming changes to Firefox's way of handling certificates (see here) you could try installing 49 beta, or easier, a FF Dev edition using a zip file that doesn't require a full setup (32-bit or 64-bit), toggle the required preference mentioned in the article linked by "here" and see if you have https connectivity, albeit experimental'' This again, looks a little beyond me. I'm not sure how to "toggle the required preference in the article". Again, thanks so much for your help.

Okulungisiwe ngu Zirka

FredMcD
  • Top 10 Contributor
4224 izisombululo 58941 izimpendulo
Kuphostiwe

FredMcD said

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.
''FredMcD [[#answer-912985|said]]'' <blockquote> There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate. </blockquote>

Umnikazi wombuzo

Hi Fred, thanks for responding again. If you read the thread you'll see that it has been determined that it isn't a Kapersky (security software) problem.

There is something strange going on. It just came out of the blue earlier this week. All other browsers function fine. I would really like my Mozilla back.

We have tried everything. Tonnes got back to me with some ideas, and if there is anyone else out there, I would be eternally grateful.

Thanks again Fred.

Hi Fred, thanks for responding again. If you read the thread you'll see that it has been determined that it isn't a Kapersky (security software) problem. There is something strange going on. It just came out of the blue earlier this week. All other browsers function fine. I would really like my Mozilla back. We have tried everything. Tonnes got back to me with some ideas, and if there is anyone else out there, I would be eternally grateful. Thanks again Fred.

Umnikazi wombuzo

Well, believe it or not, I finally got it working with the help of Microsoft support.

They tried all sorts of stuff, until at the very last minute we changed the properties to run Mozilla in Administrator Mode.

That actually worked. Is this strange?

I've never actually had to do that before to get a browser to function properly.

Thanks to everyone for their help.

Well, believe it or not, I finally got it working with the help of Microsoft support. They tried all sorts of stuff, until at the very last minute we changed the properties to run Mozilla in Administrator Mode. That actually worked. Is this strange? I've never actually had to do that before to get a browser to function properly. Thanks to everyone for their help.
Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

A few new thoughts (maybe it’s best to start with the one at the bottom):

The proxy steps would only have helped if you are really using a proxy so if No proxy was selected instead of Use system proxy settings in Options as described above, this would have no success. (Some people use a "system proxy" setting, i.e. what is set in Control Panel or IE/Edge, so issues may come up when the system's setting doesn’t work even when never used for other browsers.)

When you said you found the Kaspersky certificate, you referred to browsing for certificates in the proxy steps, right? I mean, I hope you did not find a Kaspersky certificate in Firefox's certifcate settings at the time Kaspersky was uninstalled? (I don’t think so since that would be an internal certificate store issue.)

As for resetting the TCP stack, I'm not sure but thought the steps in this article would do the trick - there should be only 3 commands to enter. (Note that some people on that page report some apps to have broken connectivity after upgrading to Windows 10 while e.g. Edge still worked.)

For toggling the preference and trying the 32 or 64 bit versions, I was referring to a new preference as described in the linked article by using the Config Editor. But since it is not available by default and you need to create a new profile to test with, let’s just keep this in mind in case anyone will ask you to try this when the issue is not solved in another way soon. It’s not that hard though (just unpack a zip archive and start the .exe file using a command line parameter - you could create a profile using the existing Firefox version.)

Since the issue started about a week ago, could you see if any Windows updates have been installed around that time, either using Windows Update logs or the regular Windows Event logs?

Does the affected system have all Windows updates installed anyway, or perhaps NOT installed a recent update that was installed on another system? (Thinking of some required combination - this will take some searching and comparing.)

Sorry for asking once again, but are you absolutely sure there is no other security related software involved, even if it’s just a tiny piece of it, like Defender?

And, does the system happen to have Microsoft Family Safety set up? If so, try switching it off. (Found this here).

A few new thoughts (maybe it’s best to start with the one at the bottom): The proxy steps would only have helped if you are really using a proxy so if ''No proxy'' was selected instead of ''Use system proxy settings'' in Options as described above, this would have no success. (Some people use a "system proxy" setting, i.e. what is set in Control Panel or IE/Edge, so issues may come up when the system's setting doesn’t work even when never used for other browsers.) When you said you found the Kaspersky certificate, you referred to browsing for certificates in the proxy steps, right? I mean, I hope you did not find a Kaspersky certificate in Firefox's certifcate settings at the time Kaspersky was uninstalled? (I don’t think so since that would be an internal certificate store issue.) As for resetting the TCP stack, I'm not sure but thought the steps in [https://www.geeksinphoenix.com/blog/post/2015/06/16/how-to-reset-your-network-adapter-in-windows-10.aspx this article] would do the trick - there should be only 3 commands to enter. (Note that some people on that page report ''some'' apps to have broken connectivity after upgrading to Windows 10 while e.g. Edge still worked.) For toggling the preference and trying the 32 or 64 bit versions, I was referring to a new preference as described in the linked article by using the [[Configuration Editor for Firefox|Config Editor]]. But since it is not available by default and you need to create a new profile to test with, let’s just keep this in mind in case anyone will ask you to try this when the issue is not solved in another way soon. It’s not that hard though (just unpack a zip archive and start the .exe file using a command line parameter - you could create a profile using the existing Firefox version.) Since the issue started about a week ago, could you see if any Windows updates have been installed around that time, either using Windows Update logs or the regular Windows Event logs? Does the affected system have all Windows updates installed anyway, or perhaps NOT installed a recent update that was installed on another system? (Thinking of some required combination - this will take some searching and comparing.) Sorry for asking once again, but are you absolutely sure there is no ''other'' security related software involved, even if it’s just a tiny piece of it, like Defender? And, does the system happen to have Microsoft Family Safety set up? If so, try switching it off. (Found this [/questions/1074967 here]).

Umnikazi wombuzo

Hi Tonnes, not sure if you saw my message I posted just before you posted this response. (we must have been posting it at the same time or very close to it.).

Well, believe it or not, I finally got it working with the help of Microsoft support.

They tried all sorts of stuff, until at the very last minute we changed the properties to run Mozilla in Administrator Mode.

That actually worked. Is this strange?

I've never actually had to do that before to get a browser to function properly.

Thanks to everyone for their help.

This seems strange to me, but it seems to be working now running Firefox in administrator mode.

Hi Tonnes, not sure if you saw my message I posted just before you posted this response. (we must have been posting it at the same time or very close to it.). ''Well, believe it or not, I finally got it working with the help of Microsoft support. They tried all sorts of stuff, until at the very last minute we changed the properties to run Mozilla in Administrator Mode. That actually worked. Is this strange? I've never actually had to do that before to get a browser to function properly. Thanks to everyone for their help.'' This seems strange to me, but it seems to be working now running Firefox in administrator mode.

Okulungisiwe ngu Zirka

Tonnes
  • Locale Leader
246 izisombululo 1454 izimpendulo
Kuphostiwe

Hi Zirka,

Yes I just saw a notification of your answer right after I posted my reply. :-/

Nevertheless, what it tells me is that you were not given a solution but rather a workaround. You should be able to run Firefox as a regular user after all, so either there is something wrong with some policies (that I'd been thinking of but did not know how to cope with it), or something like Family Safety may be the culprit, which is likely to be overruled in Administrator mode. Therefore I would advise to look a bit further in order to prevent running into other troubles.

Hi Zirka, Yes I just saw a notification of your answer right after I posted my reply. :-/ Nevertheless, what it tells me is that you were not given a solution but rather a workaround. You should be able to run Firefox as a regular user after all, so either there is something wrong with some policies (that I'd been thinking of but did not know how to cope with it), or something like Family Safety may be the culprit, which is likely to be overruled in Administrator mode. Therefore I would advise to look a bit further in order to prevent running into other troubles.