X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Text not rendering properly on some websites

Kuphostiwe

I know this question has been asked multiple times and it usually ends in the solution: Some font rendering issues are caused by graphics driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration?

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"


However my hardware acceleration has been disabled for a long time. I've had this problem for many months and every now and then it annoys me enough to search for solutions. I've tried increasing and changing the fonts in my Content Settings. I've uninstalled and reinstalled firefox. I've checked multiple websites fonts to see where it happens since it seems to pick and choose what sites it happens on. I've even cross checked sites on Google Chrome as well to verify that this only happens with Firefox.

This leads me to think there is a bigger problem/bug in play within Firefox's Rendering Engine, Gecko.

I know this question has been asked multiple times and it usually ends in the solution: Some font rendering issues are caused by graphics driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration? orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" However my hardware acceleration has been disabled for a long time. I've had this problem for many months and every now and then it annoys me enough to search for solutions. I've tried increasing and changing the fonts in my Content Settings. I've uninstalled and reinstalled firefox. I've checked multiple websites fonts to see where it happens since it seems to pick and choose what sites it happens on. I've even cross checked sites on Google Chrome as well to verify that this only happens with Firefox. This leads me to think there is a bigger problem/bug in play within Firefox's Rendering Engine, Gecko.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • PlayNow Plugin
  • Blue Jeans Installation Plugin
  • Blue Jeans Video Plugin
  • Citrix Online App Detector Plugin
  • Version 5.41.3.0
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 22.0 r0
  • 5.1.50428.0
  • Unity Player 4.7.1f1
  • VLC media player Web Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4246 izisombululo 59406 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! ----------------- Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Umnikazi wombuzo

Thanks for the reply FredMcD. I forgot to mention I have tried safe mode before and it didn't work, just tried it again and it still doesn't work.

I guess my screenshot didn't upload the first time but it's here now.

I also have turned on Allow Websites To Choose Their Own previously, I just checked and it's still on.

Thanks for the reply FredMcD. I forgot to mention I have tried safe mode before and it didn't work, just tried it again and it still doesn't work. I guess my screenshot didn't upload the first time but it's here now. I also have turned on '''Allow Websites To Choose Their Own''' previously, I just checked and it's still on.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59406 izimpendulo
Kuphostiwe

I've called for more help.

Hold down the <Shift> key, and reload the page.

I've called for more help. Hold down the <Shift> key, and reload the page.

Umnikazi wombuzo

Nope that didn't work either.

Nope that didn't work either.

Umnikazi wombuzo

Is there any more information I can provide? And sort of Firefox log or diagnostic I should upload?

Is there any more information I can provide? And sort of Firefox log or diagnostic I should upload?
FredMcD
  • Top 10 Contributor
4246 izisombululo 59406 izimpendulo
Kuphostiwe

Was this with one website, or several?

Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Was this with one website, or several? '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Umnikazi wombuzo

This has been multiple sites. A familiar site that I assume a lot of people frequent is: https://play.google.com/store https://www.udacity.com/

I did a little more digging and these two sites use the Roboto or Open-Sans font. If I remove that then everything else renders fine. More specifically these fonts are placed in "" instead of just named and separated by commas like other fonts.

Ex: font-family: "Roboto", "Open-Sans", UILanguageFont, Arial, sans-serif;

Changing font weight or size doesn't stop the clipping either.

This has been multiple sites. A familiar site that I assume a lot of people frequent is: https://play.google.com/store https://www.udacity.com/ I did a little more digging and these two sites use the Roboto or Open-Sans font. If I remove that then everything else renders fine. More specifically these fonts are placed in "" instead of just named and separated by commas like other fonts. Ex: font-family: "Roboto", "Open-Sans", UILanguageFont, Arial, sans-serif; Changing font weight or size doesn't stop the clipping either.
FredMcD
  • Top 10 Contributor
4246 izisombululo 59406 izimpendulo
Kuphostiwe

I don't know fonts. But check these links; https://www.bing.com/search?q=font+repair&pc=MOZI&form=MOZSBR

I don't know fonts. But check these links; https://www.bing.com/search?q=font+repair&pc=MOZI&form=MOZSBR
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It's normal to use quotation marks around multi-word font names, like "Comic Sans MS" (heaven forbid), and while it is not needed around one-word font names, it shouldn't do any harm.

Firefox does a much better job smoothing downloadable fonts if hardware acceleration is enabled than if it is disabled. Can you use hardware acceleration on your system or does Firefox not allow it with your graphics driver software? If HA is being applied, then the troubleshooting information page will have entries like:

Direct2D => true DirectWrite => true

in the Graphics section. You can open that using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
It's normal to use quotation marks around multi-word font names, like "Comic Sans MS" (heaven forbid), and while it is not needed around one-word font names, it shouldn't do any harm. Firefox does a much better job smoothing downloadable fonts if hardware acceleration is ''enabled'' than if it is disabled. Can you use hardware acceleration on your system or does Firefox not allow it with your graphics driver software? If HA is being applied, then the troubleshooting information page will have entries like: Direct2D => true DirectWrite => true in the Graphics section. You can open that using either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter
jscher2000
  • Top 10 Contributor
8695 izisombululo 71066 izimpendulo
Kuphostiwe

You also might take a look at a particular setting related to ClearType to see whether it has a non-default value: Fixing font rendering for Firefox 45.

You also might take a look at a particular setting related to ClearType to see whether it has a non-default value: [https://support.mozilla.org/questions/1115938 Fixing font rendering for Firefox 45].

Umnikazi wombuzo

Alright I turned on Hardware acceleration and both Direct2d and DirectWrite are true.

My font looks better on Google Play but not Udacity. It still has a problem on their very small Featured banner at the top.

In general though I think you have helped me solve it for now jscher2000

Thanks a lot!!

Alright I turned on Hardware acceleration and both Direct2d and DirectWrite are true. My font looks better on Google Play but not Udacity. It still has a problem on their very small Featured banner at the top. In general though I think you have helped me solve it for now jscher2000 Thanks a lot!!