X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Context/drop-down menus no longer abort, "close" by clicking off-menu like they used to.

Kuphostiwe

My context/drop-down menus will no longer abort "close" as they used to with a simple off-menu click. The only way I can force them to close now is by hitting the ESC key. For example, if I click on Help in the Menu Bar but decide to abort the action, I used to be able to click anywhere off-menu and it would close. Same thing happens when right-clicking on a webpage to bring up the context or spell-checker menus but then decide not to click on a menu item. In all cases the only way they will close now is to actually select an item in the open menu or by hitting the ESC key.

This issue is exclusive to Firefox. It does not present in IE, Chrome, my OS (Windows 8.1), or any other apps. I first noticed the anomaly sometime after updating to Firefox 48. I have no viruses, hijacks, adware, etc. Restarting with Add-ons disabled had no effect, not could I find relevant info searching support topics here or via general search engine queries.

Anyone have any ideas besides doing a refresh and re-configuring everything?

My context/drop-down menus will no longer abort "close" as they used to with a simple off-menu click. The only way I can force them to close now is by hitting the ESC key. For example, if I click on Help in the Menu Bar but decide to abort the action, I used to be able to click anywhere off-menu and it would close. Same thing happens when right-clicking on a webpage to bring up the context or spell-checker menus but then decide not to click on a menu item. In all cases the only way they will close now is to actually select an item in the open menu or by hitting the ESC key. This issue is exclusive to Firefox. It does not present in IE, Chrome, my OS (Windows 8.1), or any other apps. I first noticed the anomaly sometime after updating to Firefox 48. I have no viruses, hijacks, adware, etc. Restarting with Add-ons disabled had no effect, not could I find relevant info searching support topics here or via general search engine queries. Anyone have any ideas besides doing a refresh and re-configuring everything?

Isisombululo esikhethiwe

I think I found it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste popup and pause while the list is filtered

(3) If the ui.popup.disable_autohide preference is bolded and "user set" to true, double-click it to restore the default value of false

Funda le mpendulo ngokuhambisana nalesi sihloko 8

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.17
  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • VLC media player Web Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8963 izisombululo 73452 izimpendulo
Kuphostiwe

Just as a note, you can use the Alt key to clear a Firefox menu, which may have a lower risk of odd side effects than the Esc key.

As for why it sticks, I don't know, and if Firefox's "Safe Mode" didn't help, then perhaps Firefox's program files got corrupted during the last update? Our standard recommendation in such cases is:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

It only takes a few minutes.

(A) Download a fresh installer for Firefox 48.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) Choose the "Windows" version (32-bit) rather than the 64-bit version for maximum plugin compatibility.

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Any improvement?

Just as a note, you can use the Alt key to clear a Firefox menu, which may have a lower risk of odd side effects than the Esc key. As for why it sticks, I don't know, and if Firefox's "Safe Mode" didn't help, then perhaps Firefox's program files got corrupted during the last update? Our standard recommendation in such cases is: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. It only takes a few minutes. (A) Download a fresh installer for Firefox 48.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) '''Choose the "Windows" version (32-bit) rather than the 64-bit version for maximum plugin compatibility.''' (B) Exit out of Firefox (if applicable). (C) Using Windows Explorer/My Computer, rename the program folder as follows: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins Any improvement?

Umnikazi wombuzo

Thanks, tried it, but no joy, the condition persists. BTW, the Alt key has no effect on my open menus either...

Thanks, tried it, but no joy, the condition persists. BTW, the Alt key has no effect on my open menus either...

Okulungisiwe ngu TechSpin

jscher2000
  • Top 10 Contributor
8963 izisombululo 73452 izimpendulo
Kuphostiwe

As a test to see whether this could be a settings issue, you could test in a fresh Firefox profile.

New Profile Test

This takes about 3 minutes, plus the time to test sites where this problem occurs.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Sept2016, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button.

Firefox should exit and then start up using the new profile, which will just look brand new.

Do right-click context menus work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

As a test to see whether this could be a settings issue, you could test in a fresh Firefox profile. '''New Profile Test''' This takes about 3 minutes, plus the time to test sites where this problem occurs. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. Click the Create a New Profile button, then click Next. Assign a name like Sept2016, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. Firefox should exit and then start up using the new profile, which will just look brand new. ''Do right-click context menus work any better in the new profile?'' When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.

Umnikazi wombuzo

Thanks again for the reply. I created the test profile and all the right-click actions and context menus function normally when I switched to it. They began misbehaving as soon as I reverted back to my original profile.

So, if Settings is the culprit, are there some usual suspects I could check, or am I back to blowing away the install?

Thanks again for the reply. I created the test profile and all the right-click actions and context menus function normally when I switched to it. They began misbehaving as soon as I reverted back to my original profile. So, if Settings is the culprit, are there some usual suspects I could check, or am I back to blowing away the install?
jscher2000
  • Top 10 Contributor
8963 izisombululo 73452 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I think I found it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste popup and pause while the list is filtered

(3) If the ui.popup.disable_autohide preference is bolded and "user set" to true, double-click it to restore the default value of false

I think I found it: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''popup''' and pause while the list is filtered (3) If the '''ui.popup.disable_autohide''' preference is bolded and "user set" to true, double-click it to restore the default value of false

Impendulo Ewusizo

Well done, sir. That was indeed the culprit. Not sure why or how it got toggled to True, and that open question will no doubt bug the voices in my head until I end up doing a fresh install anyway, but for now, reverting it back to the default value did the trick.

Thanks! I appreciate the help and tenacity.

Well done, sir. That was indeed the culprit. Not sure why or how it got toggled to True, and that open question will no doubt bug the voices in my head until I end up doing a fresh install anyway, but for now, reverting it back to the default value did the trick. Thanks! I appreciate the help and tenacity.