Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Secure Connection Failed - Advanced Button

  • 20 uphendule
  • 1 inale nkinga
  • 50 views
  • Igcine ukuphendulwa ngu jpalomo

more options

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified....

How can I add an exception if the "Advanced Button" is no longer available in most recent versions of firefox. I am only trying to get to my VoIP ATA by typing its ip on firefox URL line, and it gets blocked. Do I need a particular add-on or plugin to be able to see the Advanced Button when a Secure Connection like this (safe because it's my device in my own LAN)....

Thanks, jp

All Replies (20)

more options

Not every kind of connection error gives you an Advanced button.

Is this the normal way you access the device and it suddenly stopped working correctly?

What happens when you try the same address in other browsers?

more options

It is the normal way, but I have not accessed it for about a year. Other browsers behave the same way. However, when I try the ip address from my router, there is no problem, it does take me to the router login page to its config utility.

more options

Do your other browsers provide any more detailed information about the problem making a secure connection?

more options

chrome says "This site can't be reached - 192.xx.x.x unexpectedly closed the connection"

more options

Can you check with your vendor on whether there are known issues with modern browsers accessing its device? It's beginning to sound like a protocol or cipher problem rather than a certificate issue per se.

more options

The Cisco SPA112 (the ATA which I am trying to log into) does not come with a security certificate. I believe it is a matter of fooling the system to bypass the security warning. Older versions of firefox used to have the "Advanced" button that allowed you to bypass this. However, I am sure there are other ways to do this via settings somewhere in the browser or windows 7

more options

Any ideas on how to do that?

more options

It must have a certificate, or you can't use HTTPS at all.

Could you check your Firefox settings to make sure you are allowing enough types of connections.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

(3) If you have any non-default settings (typically bolded and having a status of "user set"), you can make a note of the values in case they turn out to be important for some other reason, then right-click > Reset each prefer to its default value.

If you have any locked preferences (typically italicized), you might not be able to modify those and should check with your IT.

(4) In the search box above the list, type or paste security.ss and pause while the list is filtered

(3) If you have any non-default settings (typically bolded and having a status of "user set"), you can make a note of the values in case they turn out to be important for some other reason, then right-click > Reset each prefer to its default value.

It's okay to leave these set to false (this works around any servers that have not yet been fixed for the Logjam vulnerability):

  • security.ssl3.dhe_rsa_aes_128_sha => false
  • security.ssl3.dhe_rsa_aes_256_sha => false

If any of these preferences are locked, again, check with your IT.

more options

Both search lists (SSL, and security.ss) show default status The only one that seems a bit off (shows the url rather than true of false) is the following:

security.ssl.errorReporting.url default, string, https://data.mozilla.com/submit/sslreports

more options

jpalomo said

The only one that seems a bit off (shows the url rather than true of false) is the following:
security.ssl.errorReporting.url default, string, https://data.mozilla.com/submit/sslreports

I have that, too. I think all of the preferences ending with .url are string type preferences that list a url (or list nothing).


I'm not sure what the issue is. Cisco's release notes for its July 2015 firmware update make it sound up-to-date (support for TLS 1.2) without mentioning any problems. ???

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/csbpvga/spa100-200/release/spa100-rn-1-3-5.html


Do you want to try using an old version of Firefox to see the device's firmware level? That may enable obsolete protocols and ciphers that have been deleted from Firefox 45.

Obviously not safe for the wilds of the web, but for this device, hopefully okay. You can download a "portable" build which runs out of a folder or from a USB flash drive without interfering with your regular Firefox settings.

For example:

more options

So I was fine with firefox 43.0.1....I was able to display the cisco sap112 config web page. However, I forgot to disable the firefox automatic updates...Next thing I know it updated overnight to 48.1, the latest version. I reverted back to 43.0.1 and it no longer displayed the "Advanced" button, that allows you to bypass the security cert warning. I then tried other versions, and now I am on ver 47.1....they all have the same issue.

more options

Okay, please try the portable anyway. Since it doesn't share your settings folder, it may be free of some newer setting(s) that also affect how older versions run.

more options

the portable?, can you please explain...is that any of the 2 links you sent me?

more options

Yes, I posted links to two different "portable" versions of Firefox ESR. When you download that and run it, it will put a self-contained version of Firefox in a folder. You can try that instead of your regular Firefox to see whether it can connect to your device.

more options

Will it update firefox or install it somewhere else without causing problems between the 2?

more options

Portable is separate. You can install it into a temporary folder i your Downloads, and it runs from there. You probably cannot run the regular Firefox and the portable simultaneously; I think you have to close one to run the other.

more options

I will try that this evening

more options

Tried it....no change bty what is the best way to uninstall the portable version. I did not find it in control panel

more options

jpalomo said

Tried it....no change bty what is the best way to uninstall the portable version. I did not find it in control panel

Time to check with the vendor?

To uninstall, just delete whatever folder the portable version is in.

more options

jscher2000 - Thanks for your suggestions