X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Stumped/ Firefox latest crashes every 32 minutes, reboots shortly after by itself

Kuphostiwe

Windows 10, all drivers up to date, latest version Firefox, only compatible addons running up to date, plugins all latest up to date Doesn't matter, 1 tab open or my usual 25+, after 32 or so minutes Firefox crashes quietly, closes slowly (I monitor memory and clean cache), then reboots itself after another 10+ seconds. I configged it to default hold extra cache (20) to try to help, no luck. Most sites operate fine on my tabs although like always memory usage creeps up slightly. But just now, to crash with only ONE tab open and sometimes linking and opening just 1 more from my email, STILL crashed. Strange. Never happened before WIN 10 and the update from maybe Firefox 44 to 48.

Windows 10, all drivers up to date, latest version Firefox, only compatible addons running up to date, plugins all latest up to date Doesn't matter, 1 tab open or my usual 25+, after 32 or so minutes Firefox crashes quietly, closes slowly (I monitor memory and clean cache), then reboots itself after another 10+ seconds. I configged it to default hold extra cache (20) to try to help, no luck. Most sites operate fine on my tabs although like always memory usage creeps up slightly. But just now, to crash with only ONE tab open and sometimes linking and opening just 1 more from my email, STILL crashed. Strange. Never happened before WIN 10 and the update from maybe Firefox 44 to 48.

Isisombululo esikhethiwe

To those who have helped , PROBLEM SOLVED. I may never know exactly what it was. I pretty much saved everything important to me, made a list of only essential addons (I did have way too many, 50+ with many disabled though), saved and gave the profile a distinct name, and started over. At this point I now have about 14 old familiar addons and plugins, and I'll experiment now and then. I configed the cache, and uninstalled completely/reinstalled the session manager. I looked up some old info sites (this one is cool- http://www.hongkiat.com/blog/hidden-firefox-settings/ ) and will move on. Maybe something changed a default setting along the line. My Win 10 upgrade only worked after the original upgrade was over, meaning my install was through the customers needing 'assistive technology', which went surprisingly smooth compared to my efforts prior the traditional way. Something to do with my issue??? Doubt it. Thanks to all who helped.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Epic Privacy Browser Installer
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • 5.1.41212.0
  • VLC media player Web Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4230 izisombululo 59038 izimpendulo
Kuphostiwe

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

aboutcrashesFx29

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data.''' '''We need the report numbers to see the whole report.''' Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in. ;[[Image:aboutcrashesFx29|width=500]] ------------------ Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Umnikazi wombuzo

This is even more strange...the 2 available links below are 08/10 & 08/08... I have had at least 8 crashes today, in fact just now at 06:23 my time, and on reboot the 3 tabs I have opened when clicked, and my dialog here was still intact. I'm thinking this is a Windows thing, its almost like clockwork. anyhow https://crash-stats.mozilla.com/report/index/bp-fc92eb81-d2e0-4cf5-8bab-026bd2160810 https://crash-stats.mozilla.com/report/index/bp-6f8d801a-7d64-4e40-bb40-569a52160808 ADDED after 06:23...And now a new one shows up after the crash, today's date 08/16 https://crash-stats.mozilla.com/report/index/bp-4a7af3f6-f184-4645-a516-180782160817

This is even more strange...the 2 available links below are 08/10 & 08/08... I have had at least 8 crashes today, in fact just now at 06:23 my time, and on reboot the 3 tabs I have opened when clicked, and my dialog here was still intact. I'm thinking this is a Windows thing, its almost like clockwork. anyhow https://crash-stats.mozilla.com/report/index/bp-fc92eb81-d2e0-4cf5-8bab-026bd2160810 https://crash-stats.mozilla.com/report/index/bp-6f8d801a-7d64-4e40-bb40-569a52160808 ADDED after 06:23...And now a new one shows up after the crash, today's date 08/16 https://crash-stats.mozilla.com/report/index/bp-4a7af3f6-f184-4645-a516-180782160817

Umnikazi wombuzo

Also, I'll try the safe mode but remember its about 33 minutes for anything to happen and I may not be active for that time.

Also, I'll try the safe mode but remember its about 33 minutes for anything to happen and I may not be active for that time.

Umnikazi wombuzo

On the clock, 06:34 in safe mode, 3 tabs open, fluctuating slightly around 143 MB memory use, may link another tab open while I wait tic toc tic toc tic toc  ;)

On the clock, 06:34 in safe mode, 3 tabs open, fluctuating slightly around 143 MB memory use, may link another tab open while I wait tic toc tic toc tic toc ;)

Umnikazi wombuzo

So around 7:06 is the key. I didn't send more reports because the few crashes before were prior to my Win 10 update and on an older, I think 44.? Firefox.

So around 7:06 is the key. I didn't send more reports because the few crashes before were prior to my Win 10 update and on an older, I think 44.? Firefox.

Umnikazi wombuzo

6:45, just cleared cache and cleaned memory, using about 80MB resources memory as I basically do nothing except update this,.. I'll be back just after 07:00 my time

6:45, just cleared cache and cleaned memory, using about 80MB resources memory as I basically do nothing except update this,.. I'll be back just after 07:00 my time

Umnikazi wombuzo

Just opened a tab with a complicated site and memory usage jumped to near 200MB so4 tabs now until the time allotted

Just opened a tab with a complicated site and memory usage jumped to near 200MB so4 tabs now until the time allotted

Umnikazi wombuzo

07:07... 07:08...07:10, no crash, opened another tab and still in safe mode so I beat my longest open session. Guess I have to reevaluate my addons. But again, it was and still may be like clockwork in non-safe mode. 32 0r 33 minutes and the quiet bye-bye

07:07... 07:08...07:10, no crash, opened another tab and still in safe mode so I beat my longest open session. Guess I have to reevaluate my addons. '''But again,''' it was and still may be like clockwork in non-safe mode. 32 0r 33 minutes and the quiet bye-bye
FredMcD
  • Top 10 Contributor
4230 izisombululo 59038 izimpendulo
Kuphostiwe

Product Firefox Release Channel release Version 44.0.2 Build ID 20160210153822 OS Windows 10 OS Version 10.0.14393

bp-fc92eb81-d2e0-4cf5-8bab-026bd2160810 Date Processed 2016-08-10 17:30:25

bp-6f8d801a-7d64-4e40-bb40-569a52160808 Date Processed 2016-08-08 20:20:17

Signature: shutdownhang | js::NukeCrossCompartmentWrappers

Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation

mswsock.dll = Microsoft

winmm.dll = Windows Multimedia

Kernel32.dll = Microsoft

ws2_32.dll = Windows Sockets

KERNELBASE.dll = Microsoft

user32.dll = Windows User API

win32u.dll = Microsoft

WMVCORE.DLL = Microsoft Windows Media Player

This is for Sumo's Related Bugs 1219586 RESOLVED DUPLICATE FireFox 42 repeatedly crashes during exit that takes forever

816784 NEW --- Lots of time spent in WindowDestroyedEvent::Run/js::NukeCrossCompartmentWrappers when closing tabs/windows ++++++++++++++++++++++++++++++++++++++++++++++++++ bp-4a7af3f6-f184-4645-a516-180782160817 Date Processed 2016-08-17 01:27:55

Signature: hang | WaitForSingleObjectEx | WaitForSingleObject | F_121813594

Process Type plugin Shockwave Flash Version: 22.0.0.209

Product Firefox Release Channel release Version 44.0.2 Build ID 20160210153822 OS Windows 10 OS Version 10.0.14393 bp-fc92eb81-d2e0-4cf5-8bab-026bd2160810 Date Processed 2016-08-10 17:30:25 bp-6f8d801a-7d64-4e40-bb40-569a52160808 Date Processed 2016-08-08 20:20:17 Signature: shutdownhang | js::NukeCrossCompartmentWrappers Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation mswsock.dll = Microsoft winmm.dll = Windows Multimedia Kernel32.dll = Microsoft ws2_32.dll = Windows Sockets KERNELBASE.dll = Microsoft user32.dll = Windows User API win32u.dll = Microsoft WMVCORE.DLL = Microsoft Windows Media Player This is for Sumo's Related Bugs 1219586 RESOLVED DUPLICATE FireFox 42 repeatedly crashes during exit that takes forever 816784 NEW --- Lots of time spent in WindowDestroyedEvent::Run/js::NukeCrossCompartmentWrappers when closing tabs/windows ++++++++++++++++++++++++++++++++++++++++++++++++++ bp-4a7af3f6-f184-4645-a516-180782160817 Date Processed 2016-08-17 01:27:55 Signature: hang | WaitForSingleObjectEx | WaitForSingleObject | F_121813594 Process Type plugin Shockwave Flash Version: 22.0.0.209
FredMcD
  • Top 10 Contributor
4230 izisombululo 59038 izimpendulo
Kuphostiwe

Did you just update Firefox? The crash reports say Version 44.0.2 But the System Details says; Windows 10, Firefox 48.0


The first two reports;

Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista: https://support.microsoft.com/en-us/kb/929833 Win XP: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


The last report;

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Did you just update Firefox? The crash reports say Version 44.0.2 But the System Details says; Windows 10, Firefox 48.0 --------------- The first two reports; Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista: https://support.microsoft.com/en-us/kb/929833 Win XP: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ------------------ The last report; If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Umnikazi wombuzo

I saw those 2 suggestions earlier and checked that my Nvidia GeForce is up to date. I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. That most recent crash report is strange as I'm clearly (including yesterday) running version 48

I saw those 2 suggestions earlier and checked that my Nvidia GeForce is up to date. I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. That most recent crash report is strange as I'm clearly (including yesterday) running version 48
FredMcD
  • Top 10 Contributor
4230 izisombululo 59038 izimpendulo
Kuphostiwe

I'm going to ask about this.

I'm going to ask about this.

Umnikazi wombuzo

Kind of interesting just now, I purposely left the browser alone around the 30 minute mark and simply checked some email on Thunderbird. Again around 32 or so minutes I saw the Firefox icon disappear from the toolbar and reappear a minute or so later. On a lighter note, its almost like a reminder to get up and stretch ;) At some point I'm going to see if I can move my favorite sessions over to Pale Moon, Airfox, Waterfox and K-Meleon and use them for a day to see if it persists.

Kind of interesting just now, I purposely left the browser alone around the 30 minute mark and simply checked some email on Thunderbird. Again around 32 or so minutes I saw the Firefox icon disappear from the toolbar and reappear a minute or so later. On a lighter note, its almost like a reminder to get up and stretch ;) At some point I'm going to see if I can move my favorite sessions over to Pale Moon, Airfox, Waterfox and K-Meleon and use them for a day to see if it persists.
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

If you are getting Crashes every 1/2 hour it is not much good as a browser. Try getting back to basics, create a new additional profile for test purposes, disable all plugins in the new profile and run it in safemode, instead of with dozens of extensions. Any improvement ? It may at least give more helpful Crash IDs . Please can you post a couple of the Crash IDs from that configuration if it still crashes

Also have you ruled out overheating ? And do you need Shockwave Director ? is it used for anything ? as you do have an ordinary FlashPlayer

See also

If you are getting Crashes every 1/2 hour it is not much good as a browser. Try getting back to basics, create a new additional profile for test purposes, disable all plugins in the new profile and run it in safemode, instead of with dozens of extensions. Any improvement ? It may at least give more helpful Crash IDs . Please can you post a couple of the Crash IDs from that configuration if it still crashes Also have you ruled out overheating ? And do you need Shockwave Director ? is it used for anything ? as you do have an ordinary FlashPlayer See also * [[Use the Profile Manager to create and remove Firefox profiles]] * [[Disable or remove Add-ons]] *[[Troubleshoot Firefox issues using Safe Mode]]
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

lepiane said

... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. ....

I guess you were tying to follow the Mozillazine article. See now

You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens.

''lepiane [[#answer-907615|said]]'' <blockquote> ... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. .... </blockquote> I guess you were tying to follow the Mozillazine article. See now * [[Adobe Flash protected mode in Firefox]] You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens.

Umnikazi wombuzo

John99 said

If you are getting Crashes every 1/2 hour it is not much good as a browser. Try getting back to basics, create a new additional profile for test purposes, disable all plugins in the new profile and run it in safemode, instead of with dozens of extensions. Any improvement ? It may at least give more helpful Crash IDs . Please can you post a couple of the Crash IDs from that configuration if it still crashes Also have you ruled out overheating ? And do you need Shockwave Director ? is it used for anything ? as you do have an ordinary FlashPlayer See also

So even though it's crashed & rebooted on its own a few times today, no new crash reports have been generated (odd?). I just disabled SW director. Yes, as above in safe mode I was fine for over at least 40 minutes ( i had to leave) . Also, overheating isn't an issue as everything else is fine. Anyhow good advice and I'll reboot the PC sometime later and open up to see if I get any new crash reports. Not enough time for a new profile yet today, but soon and this thread will keep active. Prior with Win 7 and Firefox 44 10 days ago or so no issues like this.

''John99 [[#answer-907654|said]]'' <blockquote> If you are getting Crashes every 1/2 hour it is not much good as a browser. Try getting back to basics, create a new additional profile for test purposes, disable all plugins in the new profile and run it in safemode, instead of with dozens of extensions. Any improvement ? It may at least give more helpful Crash IDs . Please can you post a couple of the Crash IDs from that configuration if it still crashes Also have you ruled out overheating ? And do you need Shockwave Director ? is it used for anything ? as you do have an ordinary FlashPlayer See also * [[Use the Profile Manager to create and remove Firefox profiles]] * [[Disable or remove Add-ons]] *[[Troubleshoot Firefox issues using Safe Mode]] </blockquote> So even though it's crashed & rebooted on its own a few times today, no new crash reports have been generated (odd?). I just disabled SW director. Yes, as above in safe mode I was fine for over at least 40 minutes ( i had to leave) . Also, overheating isn't an issue as everything else is fine. Anyhow good advice and I'll reboot the PC sometime later and open up to see if I get any new crash reports. Not enough time for a new profile yet today, but soon and this thread will keep active. Prior with Win 7 and Firefox 44 10 days ago or so no issues like this.

Umnikazi wombuzo

John99 said

lepiane said
... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. ....

I am disabling this in Flash now and rebooting Firefox to enable this. I guess you were tying to follow the Mozillazine article. See now

You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens.

''John99 [[#answer-907655|said]]'' <blockquote> ''lepiane [[#answer-907615|said]]'' <blockquote> ... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. .... </blockquote> I am disabling this in Flash now and rebooting Firefox to enable this. I guess you were tying to follow the Mozillazine article. See now * [[Adobe Flash protected mode in Firefox]] You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens. </blockquote>

Umnikazi wombuzo

John99 said

lepiane said
... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. ....

I guess you were tying to follow the Mozillazine article. See now

You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens.

I am disabling this in Flash now and rebooting Firefox to enable this

''John99 [[#answer-907655|said]]'' <blockquote> ''lepiane [[#answer-907615|said]]'' <blockquote> ... I don't reallly understand how to write the line ProtectedMode=0 in the mms.cfg file but I'll explore it. Since it doesn't seem safe though, it seems like just a temporary fix, not a solution. .... </blockquote> I guess you were tying to follow the Mozillazine article. See now * [[Adobe Flash protected mode in Firefox]] You can now test that our by using a Firefox menu option to temporarily turn off protected mode. However a better test initially is to disable all the plugins to see what happens. </blockquote> I am disabling this in Flash now and rebooting Firefox to enable this

Umnikazi wombuzo

Well, I've done the above as far as flash mode protection disabling. I've double checked that crash reports are enabled. I've run Malwarebytes and Spybot to look for anything strange (none). I use Bitedefender constantly. On my 2 favorite sessions ( yes a lot of tabs but never mattered before) I open no 2 tabs are the same. I've restarted my PC after closing my session. After all this at about 31 minutes of opening FF is silently crashed and rebooted itself. Looks like I'll try the process of elimination when I have time as far as my beloved addons and few plugins. I'm happy with my 10 or so days on Windows 10. I'll also open a session with no tabs and simply link to new ones through my emails. Stay tuned, and thanks

Well, I've done the above as far as flash mode protection disabling. I've double checked that crash reports are enabled. I've run Malwarebytes and Spybot to look for anything strange (none). I use Bitedefender constantly. On my 2 favorite sessions ( yes a lot of tabs but never mattered before) I open no 2 tabs are the same. I've restarted my PC after closing my session. '''After all this at about 31 minutes of opening FF is silently crashed and rebooted itself. ''' Looks like I'll try the process of elimination when I have time as far as my beloved addons and few plugins. I'm happy with my 10 or so days on Windows 10. I'll also open a session with no tabs and simply link to new ones through my emails. '''Stay tuned, and thanks'''
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

It is probably better to troubleshoot bottom up than a slow top down process of elimination. By you use a new additional profile you have no need to interfere unecessarily with your day to day profile. There could be multiple contributory factors involved in your Crashes.

It is probably better to troubleshoot bottom up than a slow top down process of elimination. By you use a new additional profile you have no need to interfere unecessarily with your day to day profile. There could be multiple contributory factors involved in your Crashes.