X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

attempts to save vieos and photos as .jfif. How do I change this?

Kuphostiwe

When I attempt to save photos and videos from the internet, my "save as" has recently started adding .jfif on the end, behind .jpg or .mp4. This just started in the last couple of days, and I have to manually remove the .jfif before I can save it. It only does this with Firefox, but not with IE or Chrome. How do I change it back?

When I attempt to save photos and videos from the internet, my "save as" has recently started adding .jfif on the end, behind .jpg or .mp4. This just started in the last couple of days, and I have to manually remove the .jfif before I can save it. It only does this with Firefox, but not with IE or Chrome. How do I change it back?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Coupons, Inc. Coupon Printer 5.0.2.3
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • Shockwave Flash 22.0 r0
  • 5.1.50428.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8757 izisombululo 71650 izimpendulo
Kuphostiwe

This reminds me of users reporting that sometimes all the files want .jpe at the end instead of .jpg.

It's possible that the file which stores application handler preferences and associates file extensions with content types has become corrupted. The file has a somewhat inscrutable XML format so it's often easiest simply to hide it from Firefox and have those settings return to their defaults. Here's how you do that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again, and Firefox should rebuild the file with default settings.

Any improvement?

This reminds me of users reporting that sometimes all the files want .jpe at the end instead of .jpg. It's possible that the file which stores application handler preferences and associates file extensions with content types has become corrupted. The file has a somewhat inscrutable XML format so it's often easiest simply to hide it from Firefox and have those settings return to their defaults. Here's how you do that: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to mimeTypes.old. Start Firefox back up again, and Firefox should rebuild the file with default settings. Any improvement?

Umnikazi wombuzo

Followed the instructions but it didn't reset to default. Still tries to save to .jfif

Followed the instructions but it didn't reset to default. Still tries to save to .jfif
jscher2000
  • Top 10 Contributor
8757 izisombululo 71650 izimpendulo
Kuphostiwe

Hmm, the download preferences should have been rebuilt fresh from the Windows registry.

If you have an image saved as a .jfif file, what program does Windows want to use to view/open it, if any?

Hmm, the download preferences should have been rebuilt fresh from the Windows registry. If you have an image saved as a .jfif file, what program does Windows want to use to view/open it, if any?

Umnikazi wombuzo

The program that pops up to view the .jfif files is the photos program that comes with Windows 10

The program that pops up to view the .jfif files is the photos program that comes with Windows 10
jscher2000
  • Top 10 Contributor
8757 izisombululo 71650 izimpendulo
Kuphostiwe

Hmm, since everyone has that program, it doesn't really explain why Firefox is behaving oddly on your system.

If you drag and drop the mimeTypes.rdf file onto a tab in Firefox, it should display with a little bit of formatting, making it slightly more readable. If you use Find (Ctrl+f) for "jfif" what content types does it show up as a file extension for? For example:

<RDF:Description RDF:about="urn:mimetype:image/jpeg" NC:fileExtensions="jpg" NC:description="JPEG Image" NC:value="image/jpeg" NC:editable="true">

Hmm, since everyone has that program, it doesn't really explain why Firefox is behaving oddly on your system. If you drag and drop the mimeTypes.rdf file onto a tab in Firefox, it should display with a little bit of formatting, making it slightly more readable. If you use Find (Ctrl+f) for ''"jfif"'' what content types does it show up as a file extension for? For example: <RDF:Description RDF:about="urn:mimetype:image/jpeg" NC:'''fileExtensions="jpg"''' NC:description="JPEG Image" NC:'''value="image/jpeg"''' NC:editable="true">

Umnikazi wombuzo

I checked the document tree as you suggested. No mimetype:image listed at all. I am tempted to uninstall Firefox and then re-install it. Do you think that might help?

I checked the document tree as you suggested. No mimetype:image listed at all. I am tempted to uninstall Firefox and then re-install it. Do you think that might help?
jscher2000
  • Top 10 Contributor
8757 izisombululo 71650 izimpendulo
Kuphostiwe

If there's no references to jfif in the mimeTypes.rdf file, it's very difficult to figure out where that is coming from.

If you think your Firefox program files might be corrupted, we generally suggest this approach:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

It only takes a few minutes.

(A) Download a fresh installer for Firefox 48.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the "Windows" version (32-bit) rather than the 64-bit version.

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Any improvement?

If there's no references to jfif in the mimeTypes.rdf file, it's very difficult to figure out where that is coming from. If you think your Firefox program files might be corrupted, we generally suggest this approach: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. It only takes a few minutes. (A) Download a fresh installer for Firefox 48.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) '''For maximum plugin compatibility, choose the "Windows" version (32-bit) rather than the 64-bit version.''' (B) Exit out of Firefox (if applicable). (C) Using Windows Explorer/My Computer, rename the program folder as follows: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins Any improvement?