Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

You Tube message: browser does not currently recognise any of the video formats

  • 7 uphendule
  • 31 zinale nkinga
  • 28293 views
  • Igcine ukuphendulwa ngu TomLeigh

more options

I would first like to thank everyone for previous help/support. I am a 68 year old dedicated Firefox user dismayed by this continued issue with You Tube. When I select a video to watch I first get a flashed message saying “Your browser does not currently recognise any of the video formats available, click here to visit our frequently asked questions about HTML5 video”. Normally the flash is so fast it is impossible to read but this time a third party website held it in place of the captioned video so I captured the screen. Clicking as requested does not offer any direct solution and as an every day user I am confused by what happens next. The video begins as per normal when I go to full screen the colours are saturated and the resolution below normal. The video can run for an unlimited time, before it freezes after a random time duration and will not start again or play any other video. To illustrate this as a Firefox issue is easily sampled by comparing the same use of You Tube on 'Chrome'. None of these events take place on Chrome and the Chrome browser video is fine. I am just an ordinary user, can you advise please? Thanks Tom Leigh

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

jscher2000 Disabling the YouTube related add-ons has solved the problem. My very sincere thanks for the education as well as the solution. As to which one? Well at this stage they are all superfluous to needs. Since my Internet speed has increased, eliminating the annoying buffering, downloading a video to watch in comfort has become obsolete. I am so relieved its lifted a depressing weight of my You Tube viewing. Cheers

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 6

All Replies (7)

more options

Could you check this test page:

https://www.youtube.com/html5

Windows 10 usually would show 5 blue boxes and the last box red. How does yours look?

I don't know whether you are in any of the European countries where Microsoft is required to sell Windows "unbundled" from various media technologies but if you are, you will need this feature pack to enable Firefox to decode MPEG files:

https://support.microsoft.com/en-us/kb/3099229

more options

Tahnks for such a quick responce I am actually in Australia and I purchased my windows 10 version a few months ago ahead of buying a NUC 5i7. attached is the screen shot of the test page. I got two red boxes. I then went to the support site which acknowledged my download but there was no install window and no record of the download in my download progress?

more options

Hmm, that's a very unusual combination of red boxes. Possibly one of your video recording/downloading extensions is changing things to try to force a particular format it can capture.

You can view, disable, and often remove or configure extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then review your list on the right side and consider whether anything video-related could be disabled or reconfigured.

Settings Check

Some video capabilities can be blocked by these settings. Given your pattern of boxes, these might all be fine, it's hard to know.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

Media Foundation: necessary to decode H.264/MP4 media

(2) In the search box above the list, type or paste wmf and pause while the list is filtered

(3) If the media.wmf.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

Key H.264/MP4 Preferences

(4) In the search box above the list, type or paste mp4 and pause while the list is filtered

(5) If the media.mediasource.mp4.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(6) If the media.mp4.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

Key WebM Preferences

(7) In the search box above the list, type or paste webm and pause while the list is filtered

(8) The media.mediasource.webm.enabled preference usually is disabled, but yours is enabled, which is fine unless you experience stability problems on YouTube

(9) If the media.webm.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

If you changed anything, please test again. If not, hmm...

more options

jscher2000 This is a prompt pretest thank you once again for your advice before I begin trying your suggestions. Your Hmmm over my problem only adds to my belief this is one of those issues threatened by the article I read, which claimed Microsoft, Google & Yahoo as unlikely bed partners were joining forces determined to target 'add blocker' users & specifically 'Firefox users'. Excuse me but I thought I kept the article URL bookmarked but can't find it right now. I will follow your instructions and report back tomorrow. cheers!

more options

Please excuse my delay. Thank you for the easy to follow guided check of my settings. Attached is what I found & as a result made no changes. The use of YouTube starts quite normally and to all intents and purposes appears to be fine. But after an unknown irregular period of 'play' suddenly the image freezes. This does not happen in 'Chrome', I don't use any other browser. This issue is specific to the YT website or any video on any website which uses YT to display a video. I find it interesting that the blue & red box configuration puzzles you. I am grateful for your knowledge and patience thanks.

more options

Could you try it with your video-related extensions disabled?

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then disable Ant and the three YouTube extensions. Most likely a link will appear to restart Firefox so the disablement becomes effective.

Any difference?

more options

Isisombululo Esikhethiwe

jscher2000 Disabling the YouTube related add-ons has solved the problem. My very sincere thanks for the education as well as the solution. As to which one? Well at this stage they are all superfluous to needs. Since my Internet speed has increased, eliminating the annoying buffering, downloading a video to watch in comfort has become obsolete. I am so relieved its lifted a depressing weight of my You Tube viewing. Cheers