X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Mozilla Firefox Black Screen on https://domain.opendns.com/ads.rubiconproject.com

Ron
Kuphostiwe

While inside the SAFE MODE version of Mozilla Firefox 48.0 on Windows 10-64 bit with hardware acceleration turned off in Firefox the page https://domain.opendns.com/ads.rubiconproject.com displays black. This happens on many other pages I simply picked one randomly to illustrate it. It shouldn't be necessary since I'm in safe mode to say that I also disabled hardware acceleration in flash player and that I also tried turning off protected mode in flash. It also shouldn't be necessary to say that I'm on the latest video driver since I'm using Windows 10 but I will say that I am on version 368.81 of nVidia's latest release as of this posting.

While inside the SAFE MODE version of Mozilla Firefox 48.0 on Windows 10-64 bit with hardware acceleration turned off in Firefox the page https://domain.opendns.com/ads.rubiconproject.com displays black. This happens on many other pages I simply picked one randomly to illustrate it. It shouldn't be necessary since I'm in safe mode to say that I also disabled hardware acceleration in flash player and that I also tried turning off protected mode in flash. It also shouldn't be necessary to say that I'm on the latest video driver since I'm using Windows 10 but I will say that I am on version 368.81 of nVidia's latest release as of this posting.

Isisombululo esikhethiwe

Yes, I have Kaspersky Internet Security which has the Anti-Banner protection module. I added "opendns.com" to the "Websites with allowed banners" list. I did not need to restart my web browser. I then tested and I am now able to see the web page. Attached screen shots to note location of changes needed.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 22.0 r0
  • 5.1.50428.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

Impendulo Ewusizo

Image of the black screen.

Image of the black screen.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

A couple other Nvidia users seem to have encountered this lately (although neither mentioned that site).

Could you try disabling the "off main thread composition" (OMTC) feature introduced in Firefox 33? Please keep hardware acceleration enabled while disabling OMTC. The steps are as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

I can't recall whether that takes effect immediately or only after you exit Firefox and start it up again (since I don't have the symptoms to test with).

A couple other Nvidia users seem to have encountered this lately (although neither mentioned that site). Could you try disabling the "off main thread composition" (OMTC) feature introduced in Firefox 33? Please keep hardware acceleration ''enabled'' while disabling OMTC. The steps are as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''layers''' and pause while the list is filtered (3) Double-click the '''layers.offmainthreadcomposition.enabled''' preference to switch it from true to false I can't recall whether that takes effect immediately or only after you exit Firefox and start it up again (since I don't have the symptoms to test with).

Okulungisiwe ngu jscher2000

Umnikazi wombuzo

That particular config item doesn't appear in my config. I've attached a screen shot of the options closely related that do appear. Please advise.

That particular config item doesn't appear in my config. I've attached a screen shot of the options closely related that do appear. Please advise.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

Things always change... please try it this way:

(0) Select and copy the following new preference name:

layers.offmainthreadcomposition.force-disabled

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers.off and pause while the list is filtered

(3) Right-click a blank area of the page, click New, then Boolean

(4) Paste the preference name, then click OK

(5) Select true, then click OK -- the preference should appear in the list, bolded, and user set to true -- if you need to remove this later, right-click > Reset it

I think you probably need to restart Firefox before that takes effect.

Things always change... please try it this way: (0) Select and copy the following new preference name: layers.offmainthreadcomposition.force-disabled (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''layers.off''' and pause while the list is filtered (3) Right-click a blank area of the page, click New, then Boolean (4) Paste the preference name, then click OK (5) Select true, then click OK -- the preference should appear in the list, bolded, and user set to true -- if you need to remove this later, right-click > Reset it I think you probably need to restart Firefox before that takes effect.

Impendulo Ewusizo

Made that change, restarted, tested and it had no effect. Black page still.

Made that change, restarted, tested and it had no effect. Black page still.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

Could you check that the content loaded? One way is to turn off styles using

View menu > Page Style > No Style

(If you do not normally display the menu bar, you can activate it temporarily by tapping the Alt or F10 key)

(You can use the same part of the menu to reapply the style sheets.)


Do you use a Windows "high contrast" theme?

Could you check that the content loaded? One way is to turn off styles using View menu > Page Style > No Style (If you do not normally display the menu bar, you can activate it temporarily by tapping the Alt or F10 key) (You can use the same part of the menu to reapply the style sheets.) ---- Do you use a Windows "high contrast" theme?

Umnikazi wombuzo

On the black page the option to choose a page style is greyed out. On pages that are not black I do have the available options. I do not use high contract windows theme.

On the black page the option to choose a page style is greyed out. On pages that are not black I do have the available options. I do not use high contract windows theme.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

It sounds as though the page content isn't loading, but it's unusual to get a black background (by default, the empty page background is white).

Was Firefox 47 working normally -- this problem started with Firefox 48?

Sometimes program files become corrupted during an update causing inexplicable glitches. To address that, we usually suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

It only takes a few minutes.

(A) Download a fresh installer for Firefox 48.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Any improvement?

It sounds as though the page content isn't loading, but it's unusual to get a black background (by default, the empty page background is white). Was Firefox 47 working normally -- this problem started with Firefox 48? Sometimes program files become corrupted during an update causing inexplicable glitches. To address that, we usually suggest: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. It only takes a few minutes. (A) Download a fresh installer for Firefox 48.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) '''For maximum plugin compatibility, choose the 32-bit version.''' (B) Exit out of Firefox (if applicable). (C) Using Windows Explorer/My Computer, rename the program folder as follows: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins Any improvement?

Umnikazi wombuzo

Before I go through the trouble can you check that site for me to see if you can see it or if you get the black page as well. I'd rather not go through all the trouble with Firefox you described only to have the same issue. Like to confirm the problem first is only me since you mentioned it may be the actual web site source causing the issue. The site is OpenDNS.org and then you go to community and then domain tagging. You enter the domain ads.rubiconproject.com into the domain search field and the result I get is black page. OpenDNS is a security cloud project (https://www.opendns.com/about/).

Before I go through the trouble can you check that site for me to see if you can see it or if you get the black page as well. I'd rather not go through all the trouble with Firefox you described only to have the same issue. Like to confirm the problem first is only me since you mentioned it may be the actual web site source causing the issue. The site is OpenDNS.org and then you go to community and then domain tagging. You enter the domain ads.rubiconproject.com into the domain search field and the result I get is black page. OpenDNS is a security cloud project (https://www.opendns.com/about/).
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

We use OpenDNS at the office and the original link loads normally for me.

When I try the links on this page: https://community.opendns.com/domaintagging/ (icon at the left of selected rows)

The pages display normally.


A couple other things you might check that are quicker:

If you view source on the page (Ctrl+u or right-click a blank part of the page > View Page Source) is there any source?

If you open the Network Monitor (https://developer.mozilla.org/docs/To.../Network_Monitor) in the lower part of the tab, then reload the page, what response does Firefox get when it requests the page? The HTTP status code in the first column may help.

We use OpenDNS at the office and the original link loads normally for me. When I try the links on this page: https://community.opendns.com/domaintagging/ (icon at the left of selected rows) The pages display normally. ---- A couple other things you might check that are quicker: If you view source on the page (Ctrl+u or right-click a blank part of the page > View Page Source) is there any source? If you open the Network Monitor ([https://developer.mozilla.org/docs/Tools/Network_Monitor]) in the lower part of the tab, then reload the page, what response does Firefox get when it requests the page? The HTTP status code in the first column may help.

Umnikazi wombuzo

Yes, I can also confirm those pages to the left of https://community.opendns.com/domaintagging/ open normally for me as well. It just seems to be certain pages that display black like the one I referred to specifically. When I right click that page for the ads.rubiconproject.com the option for View Page Source is greyed out. However I am able to View Page Information. Screen shot attached. What is interesting is under the Media icon for page information the media preview is also black and the image appears to be coming from Chrome? chrome://global/skin/media/imagedoc-darknoise.png is referenced in Bug 822149 - Image document background is a mostly-transparent PNG against a background color. Interesting?

Yes, I can also confirm those pages to the left of https://community.opendns.com/domaintagging/ open normally for me as well. It just seems to be certain pages that display black like the one I referred to specifically. When I right click that page for the ads.rubiconproject.com the option for View Page Source is greyed out. However I am able to View Page Information. Screen shot attached. What is interesting is under the Media icon for page information the media preview is also black and the image appears to be coming from Chrome? chrome://global/skin/media/imagedoc-darknoise.png is referenced in Bug 822149 - Image document background is a mostly-transparent PNG against a background color. Interesting?

Umnikazi wombuzo

Additional information, the image is a GIF format. See attached.

Additional information, the image is a GIF format. See attached.
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

Oh, I was wondering why there was a white dot in the middle of your screenshot. Had to check whether my screen had lint on it...

A one pixel GIF replacing a page is a reminiscent of a program/feature called Kaspersky Anti-Banner. I don't know how that works, but it basically is designed to replace junk images with a dot. Here whatever is doing that obviously doesn't understand the URL correctly and is overreacting...

Can you find any program/feature like that on your system?

Oh, I was wondering why there was a white dot in the middle of your screenshot. Had to check whether my screen had lint on it... A one pixel GIF replacing a page is a reminiscent of a program/feature called Kaspersky Anti-Banner. I don't know how that works, but it basically is designed to replace junk images with a dot. Here whatever is doing that obviously doesn't understand the URL correctly and is overreacting... Can you find any program/feature like that on your system?

Okulungisiwe ngu jscher2000

Isisombululo Esikhethiwe

Yes, I have Kaspersky Internet Security which has the Anti-Banner protection module. I added "opendns.com" to the "Websites with allowed banners" list. I did not need to restart my web browser. I then tested and I am now able to see the web page. Attached screen shots to note location of changes needed.

Yes, I have Kaspersky Internet Security which has the Anti-Banner protection module. I added "opendns.com" to the "Websites with allowed banners" list. I did not need to restart my web browser. I then tested and I am now able to see the web page. Attached screen shots to note location of changes needed.

Okulungisiwe ngu Ron

jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

Makes sense now. The black background is normal for a stand-alone image, it's just that usually you can see the image and the URL bar would have a more typical image extension...

Makes sense now. The black background is normal for a stand-alone image, it's just that usually you can see the image and the URL bar would have a more typical image extension...
mahttley 0 izisombululo 4 izimpendulo
Kuphostiwe

I have the same problem and can't resolve the problem. I have Windows 10 and Firefox 50.1.0, malwarebytes (no issues), all drivers are updated. This problem only started last week. Every single day the tabs go to a black screen. I have to close Firefox and reopen. Very frustrating when you are trying to work. Does not affect Excel, Word, Outlook, etc..

Does Firefox / Mozilla not have a contact phone number? This chat room format does not work for me. There is a local computer repair store but they charge $149 and I'll be without my computer for at least 3 days!!! There has to be a better way!

I have the same problem and can't resolve the problem. I have Windows 10 and Firefox 50.1.0, malwarebytes (no issues), all drivers are updated. This problem only started last week. Every single day the tabs go to a black screen. I have to close Firefox and reopen. Very frustrating when you are trying to work. Does not affect Excel, Word, Outlook, etc.. Does Firefox / Mozilla not have a contact phone number? This chat room format does not work for me. There is a local computer repair store but they charge $149 and I'll be without my computer for at least 3 days!!! There has to be a better way!
jscher2000
  • Top 10 Contributor
8786 izisombululo 71862 izimpendulo
Kuphostiwe

Hi mahttley, since this thread is very specific to a Kaspersky feature, let me reply in your separate thread over here: https://support.mozilla.org/questions/1148516

Hi mahttley, since this thread is very specific to a Kaspersky feature, let me reply in your separate thread over here: https://support.mozilla.org/questions/1148516