Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

can't open some https websites

  • 10 uphendule
  • 12 zinale nkinga
  • 13828 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi I can't open some https websites like https://openssl.org/ I get this error message:

Secure Connection Failed

The connection to openssl.org was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

This only happens on my default profile and other profiles are OK. I started firefox in safe mode (Add-ons disabled) and the problem still exist. I'm using firefox 39.0.3 on windows 7 and I don't want to update to a newer version.

Okulungisiwe ngu siamaksalimi

Isisombululo esikhethiwe

Could you check your TLS level setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

(3) If the security.tls.version.max preference is bolded and "user set" to some value other than 3, right-click it to restore the default value of 3


Do any other websites where you have problems connecting have more explanatory error messages?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (10)

more options

You may be able to figure that out by comparing profiles then.

I am sure you will be aware there are risks of using unsuported old Firefox builds. Security holes get fixed and the fixes are announced,

Those using old versions may then be targeted by bad guys..

If you are with a secure private LAN that is fine, otherwise mitigation precautions include having well rehearsed bare metal recovery procedures, and/or using VMs.

more options

Since you have a Kaspersky extension, I suggest checking the Kaspersky section of this article: How to troubleshoot security error codes on secure websites.

Why Firefox 39??

more options

@John99 Non of those articles helped me. I'm aware of the risks.

@jscher2000 I followed kaspersky section of that article and disabled Scan encrypted connections and still get that error. Firefox 40 and up have scrolling lag. I tested Firefox 44 and this bug still was there (I'm not sure about Firefox 45+).

more options

To better diagnose the certificate error, could you copy/paste the following to the address bar and press Enter to load it:

chrome://pippki/content/exceptionDialog.xul

On that tab, type or paste

https://openssl.org/

into the Location and try "Get Certificate". If that works, click the View button and compare the Issued by and Certificate Path sections with the attached. Any discrepancy?

more options

Didn't worked

more options

Could you inspect the certificate using one of your other (working) profiles? If there is a proxy or security filter operating, it should show up there too, assuming those are shared across all your profiles.

more options

These pictures are from another profile. I'm not using proxy.

more options

Isisombululo Esikhethiwe

Could you check your TLS level setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

(3) If the security.tls.version.max preference is bolded and "user set" to some value other than 3, right-click it to restore the default value of 3


Do any other websites where you have problems connecting have more explanatory error messages?

more options

Thanks. the problem fixed. security.tls.version.max was set to 1. other websites gave same error and now all of them opening.

more options

Great.

For reference, max=1 means Firefox won't go higher than TLS1.0, while openssl.org only supports TLS1.1 and TLS1.2. It's very unfortunate that the error page doesn't come out and say that's the problem in the first place...