Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Updated to 48, now 95% of RSS feeds say "Live Bookmark feed failed to load"

  • 20 uphendule
  • 21 zinale nkinga
  • Igcine ukuphendulwa ngu db32

more options

I have a few dozen RSS feeds, among which and ghacks tech news. After updating to v48, the vast majority of them won't load. Not after a full reboot either, and deleting them and readding them does not help either.

Running W7 full updates, have tried disabling all addons, no joy.

All Replies (20)

more options

I have just tried the feed. On Windows 10 Fx47 & Fx48 loaded ok for me. I don't really want to try creating a couple dozen RSS feeds. What happens if you try a new additional profile for test purposes. Maybe the places.sqlite file is corrupt.

more options

Thanks, I'll keep this in mind for next time. For now, I backed up my settings and bookmarks and reinstalled v47 and addons. Works now. I'll try upgrading again in a few days.

more options

same problem for me, i have try to verify if places.sqlite file is corrupt but is ok. Big trouble

more options

Hi donatellogiraudo, Did you try a new additional profile, and did that help ?

If you still have problems please post a new question of your own, using /questions/new and then please post back here to let us know you have done that. (I will be able to find and cross link the post)

P.S. See also Live Bookmarks - Subscribe to a web page for news and updates

Okulungisiwe ngu John99

more options

hi, i have reinstalled firefox 47 and all works

sorry but i have no time to make your procedure. wait to the 48.01 ^_^


more options

If you have this problem, check your Noscript settings! Updating to v48 causes some permissions/sites to reset to blocked in Noscript!

more options

Resetting all permissions/sites in Noscript and redoing the lot of them solved this issue for me. Donatello, are you running Noscript too?

more options

it's the noscript plugin i have disinstalled it and all work.

but if i reinstall it i have the same problem. i have tried to reset the setting of no script but noway

more options

Good to know it may not be a Firefox regression. If it is noscript is there some noscript setting, listing, exception or whatever that allows the 5% through ?

more options

i do not found sigh but if i allow the site with the noscript, the rss associated work

more options

NoScript is causing issues allright and version should fix this. Sidenote: there’s also a dev build available for Android because of FF 48 incompatibility issues (see here).

However, the question owner doesn’t seem to use NoScript, but perhaps the Dragon NaturallySpeaking Rich Internet Application Support plugin (which is an accessibility add-on) or other add-on is related. Restarting FF using Safe mode or disabling add-ons one by one may therefore be a way to pinpoint the issue.

Okulungisiwe ngu Tonnes

more options

I did not find answers for the settings that I understood but I did find a question on NoScripts site and one in Dutch (& translation) if they help anyone.

Not sure whether mentions of adding an s at the end of about;feeds may be relevant as the cure or cause. i am not using noscripts at the moment and have not really got time to investigate this myself but links to the questions & information I found are:

Anyone got a good confirmed fix yet ?

  • Is anyone able to confirm the beta version works ?
  • Or say if there are setting changes that unblock a particular site's feeds whilst still blocking the parent site's scripts.
more options

I speak Dutch, read the thread. I am already running NoScript, where about:feeds is allowed and greyed out in the whitelist (you cannot change it). So that's not the issue. Also, some feeds like work. But the majority does not, maybe they all use the same implementation on their website.

In any case, it's the combination of Firefox 48 and the latest NoScript plugin, as in v47 all worked well. Hopefully v48.1 or a new NoScript will solve it.

more options

Woops, forgot to answer John's question. If I allow the full site with the feed in NoScript, the feed will work too. Still working out if I can limit this more.

more options

User1138, Thanks for getting back on this issue. I note you said the Noscript version does not fix this issue.

The Noscript forum recommends ESR and personally I agree that is a better option than downgrading to Fx47. Whilst Mozilla will not recommend ordinary users install ESR it does get important security fixes and is in my personal opinion a sensible temporary solution until Fx or Noscript fix the issue. In fact a quick and relatively convenient option may be installing the Third party Firerfox portable ESR as an additional browser and using that for the RSS.

On a quick look I did not see a Firefox bug filed for this issue. I am not sure it would necessarily be valid to file a bug against Firefox. It would likely just become a placeholder to track the issue and whether Noscript fixes this. Noscript is a very popular addon and I am sure they will be working to keep it compatible with Firefox Releases.

Quite possibly their priority at present could be working to keep compatibility with Firefox's multi process mode. That is now actually being trailed in some Releases, (1% of users ). That could mean problems related to rss take a back seat. Because multi process Firefox (code word used was E10s or Electrolysis) is not in the Release there is not much documentation about it yet.

Another potential temporary workaround may be to install and use Thunderbird as an RSS reader.

more options

I also have this problem.. with FF 48.01

I only understand a third of the mambo jumbo above, I wonder if there's a simple user solution...

also after deleted the RSS folder.. FF doesn't let me subscribe to that page again.. like I'm still subscribed

any other ways to unsubscribe to RSS content?


more options

Consider using Thunderbird to subscribe to RSS Otherwise if you want to keep NoScript and they have not either fixed it or provided a solution by changing settings consider creating a new Firefox profile, then use that to view RSS feed but do not enable NoScript in that profile.

The profile manager lets you choose which Firefox profile to use each time you use it to start Firefox. (There is a new built in Profile Picker about:profiles but it is still Work in Progress. It may not work as intended )

I hope my answer helped instead of just adding to the confusion. For further details and explanations please see & read

more options

Be sure to have installed v released August 8, 2016.

If you still run into troubles, switch off Enable multi-process Firefox in Firefox Options (General), and please report back.

I found no issues here when testing (with e10s enabled), but at this point NoScript seems to have an unknown status when it comes to e10s / multi-process compatibility. That means some people may suffer issues, like not being able to re-add a feed.

more options

OK, let's throw another couple of things into this.

I don't have NoScript installed, and everything was working fine for me with FF48. I updated to 49 a day or two ago, and since then my RSS feeds, with the exception of one, either say they failed to load, or they say they're loading, but never really load. I don't have "Enable multi-process Firefox" on the General page, or on any other page of options.

Okulungisiwe ngu db32

more options

OK, never mind, guys. It's healed itself.