Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to completely disable website translation

  • 3 uphendule
  • 5 zinale nkinga
  • 8673 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

Hi everybody,

I am fluent in 3 languages : french, english and spanish. I have configured Firefox (Preferences > Content > Languages) with all 3 languages, in that order : French, French (France), English, English (US), Spanish, Spanish (Spain)

Still, I can't prevent a lot of english websites to be automatically (and poorly) translated into french. I could switch language preferences and put english first, but then I would have a lot of french websites automatically (and poorly) translated into english.

I don't need any translation when a website is either in french, english or spanish. No translation at all.

hence, I'd like to completely disable all kind of automatic website translation. Everywhere. All the time. If someday I happen to come across a website that I want to translate, I know many other ways of doing so.

I hope this can be achieved somehow, even if I must tweak some Firefox settings.

Thanks in advance for your support !

Isisombululo esikhethiwe

Firefox doesn't do translations. You probably have an add-on > extension installed which added that feature to Firefox. https://addons.mozilla.org/en-US/firefox/extensions/language-support/


(Preferences > Content > Languages) is for language packs that you have installed. https://addons.mozilla.org/en-US/firefox/language-tools/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

This could be a website issue. Check the site settings.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

more options

This is not a website issue, sorry. I was hoping a bit more than an automated reply barely related to my issue. Thanks anyway.

more options

Isisombululo Esikhethiwe

Firefox doesn't do translations. You probably have an add-on > extension installed which added that feature to Firefox. https://addons.mozilla.org/en-US/firefox/extensions/language-support/


(Preferences > Content > Languages) is for language packs that you have installed. https://addons.mozilla.org/en-US/firefox/language-tools/