Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Preview in Firefox" option for PDFs not available in application options

  • 6 uphendule
  • 4 zinale nkinga
  • 6198 views
  • Igcine ukuphendulwa ngu AmieW

more options

I seem to have lost the option to set my FF to open PDFs. Not long ago, I refreshed Firefox, and it's been a nightmare every since. I'm about ready to just wipe it completely and start over.

Before I refreshed it, it used the native viewer to preview PDFs in the browser. Now that option is not even available. I went into about:config and saw the the pdf.js function was disabled, so I enabled it. That didn't work. Nothing works.

Please tell me how to fix this. I work very hard on time sensitive projects and I don't have time to download and open every single PDF outside the browser.

How do I get this option back? And yes, I've tried it in safe mode. It isn't another add-on, the pdf.js file just doesn't seem to be there.

Isisombululo esikhethiwe

Did you save the "Old Firefox Data" folder the Refresh feature creates on your desktop? How poorly was Firefox working when you used Refresh? (Just wonder whether we should poke around for the old prefs.js settings file.)


Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. If you return to Options / Applications, is "Preview in Firefox" selected again?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

ADDITIONAL INFO

I have a pdfjs-1.3.91-dist folder on my desktop somehow. It has a viewer in it, and when I click on it, it looks like the built in FF viewer. I have no idea how it got onto my desktop, but how do I get it back into FF?

more options

Isisombululo Esikhethiwe

Did you save the "Old Firefox Data" folder the Refresh feature creates on your desktop? How poorly was Firefox working when you used Refresh? (Just wonder whether we should poke around for the old prefs.js settings file.)


Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. If you return to Options / Applications, is "Preview in Firefox" selected again?

more options

The System Details list shows the Foxit Reader Plug-In For Firefox and Netscape, so I assume that you would want to use this application to show the PDF files.

See also:

Note that the integrated PDF Viewer only works for files send as MIME type "application/pdf".

more options

Also, I'm not sure what that folder on your desktop is. I don't think it's possible for the pdf.js viewer to have left Firefox for your desktop on its own, or even with prompting. Perhaps it was from an old experiment with the Add-on version??

Firefox's program files do sometimes become corrupted. To address that possibility, we generally suggest the following as the next step:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

It only take a few minutes.

(A) Download a fresh installer for Firefox 47.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Hopefully the new install will be able to preview PDFs! Any improvement?

more options

You can check the value of plugin.disable_full_page_plugin_for_types on the about:config page to check if it includes application/pdf if you want to display PDF documents in Firefox with the built-in PDF Viewer.

more options

Thank you! This fixed it. I knew it was something simple, because I've had to do it before. I'll save your reply to my FF notes folder so I'll know how to fix it next time.

jscher2000 said

Did you save the "Old Firefox Data" folder the Refresh feature creates on your desktop? How poorly was Firefox working when you used Refresh? (Just wonder whether we should poke around for the old prefs.js settings file.)

Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. If you return to Options / Applications, is "Preview in Firefox" selected again?