Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't access Google Scholar when Zotero for Firefox is enabled

  • 1 baphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu the-edmeister

more options

For citation management, I use the Zotero extension within Firefox (on a MacBook), and have for years. I generally add items through Google Scholar (with a proxy connection to my university library). This week, I stopped being able to load Google Scholar at all. The website just loads indefinitely. I can access Google and all other websites without issue. When I disable the Zotero extension in my browser, however, I can access Google Scholar again. This is not an ideal solution.

I have tried resetting Firefox to defaults (cache, cookies, etc.) I have uninstalled and reinstalled the Zotero extension. I have tried disabling my university library proxy. None of this has solved the problem. Any solutions would be much appreciated. I would prefer to not use the Zotero Standalone or the Zotero add-ons for other browsers.

All Replies (1)

more options

Sorry, that doesn't sound like a Firefox support issue.

I did some looking around for both Google Scholar support and Zotero support to try to help you a bit and this is what I found. I couldn't find a Google Group for user to user support, only that web form. - categorized questions fora