X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Toggle default alignment of text for text only page from LTR to RTL (and vice-versa)

Kuphostiwe

On text only pages, Firefox displays text Left-to-Right (LTR) by default, even for plain text in which the language is read Right-to-Left (RTL). Firefox should either,

1) display content LTR or RTL on the basis of script (e.g., UTF-8 Hebrew text should be aligned RIGHT) 2) provide a user option to toggle which way all the text should be aligned on text only pages (perhaps, via the context menu)

Thank you

On text only pages, Firefox displays text Left-to-Right (LTR) by default, even for plain text in which the language is read Right-to-Left (RTL). Firefox should either, 1) display content LTR or RTL on the basis of script (e.g., UTF-8 Hebrew text should be aligned RIGHT) 2) provide a user option to toggle which way all the text should be aligned on text only pages (perhaps, via the context menu) Thank you

Isisombululo esikhethiwe

Try to set bidi.browser.ui to true on the about:config page. This should give a "Switch Page Direction" item in the right-click context menu.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • 5.1.41212.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17538 izisombululo 158577 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Try to set bidi.browser.ui to true on the about:config page. This should give a "Switch Page Direction" item in the right-click context menu.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Try to set <b>bidi.browser.ui</b> to true on the <b>about:config</b> page. This should give a "Switch Page Direction" item in the right-click context menu. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Umnikazi wombuzo

Thank you! I believe this should be enabled by default (or at least have a checkbox in the settings).

Thank you! I believe this should be enabled by default (or at least have a checkbox in the settings).
cor-el
  • Top 10 Contributor
  • Moderator
17538 izisombululo 158577 izimpendulo
Kuphostiwe

You're welcome.

This bidi setting is only enabled by default if you use a RTL Firefox locale like 'he' or 'ar'.

// Setting this pref to |true| forces Bidi UI menu items and keyboard shortcuts
// to be exposed, and enables the directional caret hook. By default, only
// expose it for bidi-associated system locales.
You're welcome. This bidi setting is only enabled by default if you use a RTL Firefox locale like 'he' or 'ar'. *https://dxr.mozilla.org/mozilla-release/source/browser/base/content/utilityOverlay.js#485 *https://dxr.mozilla.org/mozilla-release/source/modules/libpref/init/all.js#2232 <pre><nowiki>// Setting this pref to |true| forces Bidi UI menu items and keyboard shortcuts // to be exposed, and enables the directional caret hook. By default, only // expose it for bidi-associated system locales.</nowiki></pre>

Okulungisiwe ngu cor-el