X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I want the FF popup window in the foreground

Kuphostiwe

Hi, I used to have a FF popup window in the foreground when I clicked on a link in the main window. Then I had a problem with my computer and refreshed FF. Now the popup opens in the background. Any solutions?

Hi, I used to have a FF popup window in the foreground when I clicked on a link in the main window. Then I had a problem with my computer and refreshed FF. Now the popup opens in the background. Any solutions?

Isisombululo esikhethiwe

jscher2000 said

I think the default behavior would be to focus the new window. However, if there are subsequent script commands that might have the effect of returning focus back to the page from which it launched, maybe that would be cause the problem. ?? Could you check this setting: dom.disable_window_flip is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front). By default, this preference is set to true to disable websites from moving windows around in the z-order. You could experiment: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste flip and pause while the list is filtered (3) Double-click the dom.disable_window_flip preference to switch it from true to false Any difference?
Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4334 izisombululo 60929 izimpendulo
Kuphostiwe

What pop-up are you talking about? Or are you talking about the Firefox window?

What pop-up are you talking about? Or are you talking about the Firefox window?

Umnikazi wombuzo

Thank you for taking the time to reply to my question!

Maybe I have to explain a bit more (please bear with me, English is not my native language. It is all in Firefox.

I have an online shop which I update online, using FF47. The main (regular FF) window shows my items, customers etc. When I want to edit a customer's address, I click on the link in the FF main window, and a smaller window pops up. This used to pop up on top of all the other windows, and stayed there until I used another window. As soon as I clicked on the editing link in the shop main window, this popup popped up on top of all others. Now this does not work anymore.

I have read about FF popups, but none of those solutions work for me. It is a FF popup, as it has the (!) symbol in front of the hyperlink.

I know I had the problem once before, and I had to change something in the about:config, but I forgot what it was, it's been years ago.

I have attached screenshots. When I click on the customer's name in the left window, the right window used to pop up on top of all other windows on my desktop (Windows 7 32 bit).

Thank you for taking the time to reply to my question! Maybe I have to explain a bit more (please bear with me, English is not my native language. It is all in Firefox. I have an online shop which I update online, using FF47. The main (regular FF) window shows my items, customers etc. When I want to edit a customer's address, I click on the link in the FF main window, and a smaller window pops up. This used to pop up on top of all the other windows, and stayed there until I used another window. As soon as I clicked on the editing link in the shop main window, this popup popped up on top of all others. Now this does not work anymore. I have read about FF popups, but none of those solutions work for me. It is a FF popup, as it has the (!) symbol in front of the hyperlink. I know I had the problem once before, and I had to change something in the about:config, but I forgot what it was, it's been years ago. I have attached screenshots. When I click on the customer's name in the left window, the right window used to pop up on top of all other windows on my desktop (Windows 7 32 bit).
FredMcD
  • Top 10 Contributor
4334 izisombululo 60929 izimpendulo
Kuphostiwe

Sometimes this could be a problem with your system. First, try this;

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Sometimes this could be a problem with your system. First, try this; Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Umnikazi wombuzo

I did that, and the problem still is there.

I did that, and the problem still is there.
FredMcD
  • Top 10 Contributor
4334 izisombululo 60929 izimpendulo
Kuphostiwe

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
jscher2000
  • Top 10 Contributor
8872 izisombululo 72573 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I think the default behavior would be to focus the new window. However, if there are subsequent script commands that might have the effect of returning focus back to the page from which it launched, maybe that would be cause the problem. ??

Could you check this setting:

dom.disable_window_flip is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front).

By default, this preference is set to true to disable websites from moving windows around in the z-order. You could experiment:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste flip and pause while the list is filtered

(3) Double-click the dom.disable_window_flip preference to switch it from true to false

Any difference?

I think the default behavior would be to focus the new window. However, if there are subsequent script commands that might have the effect of returning focus back to the page from which it launched, maybe that would be cause the problem. ?? Could you check this setting: '''dom.disable_window_flip''' is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front). By default, this preference is set to true to disable websites from moving windows around in the z-order. You could experiment: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''flip''' and pause while the list is filtered (3) Double-click the '''dom.disable_window_flip''' preference to switch it from true to false Any difference?
jscher2000
  • Top 10 Contributor
8872 izisombululo 72573 izimpendulo
Kuphostiwe

Hmm, shouldn't your admin pages use HTTPS?

Hmm, shouldn't your admin pages use HTTPS?

Isisombululo Esikhethiwe

jscher2000 said

I think the default behavior would be to focus the new window. However, if there are subsequent script commands that might have the effect of returning focus back to the page from which it launched, maybe that would be cause the problem. ?? Could you check this setting: dom.disable_window_flip is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front). By default, this preference is set to true to disable websites from moving windows around in the z-order. You could experiment: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste flip and pause while the list is filtered (3) Double-click the dom.disable_window_flip preference to switch it from true to false Any difference?
''jscher2000 [[#answer-887790|said]]'' <blockquote> I think the default behavior would be to focus the new window. However, if there are subsequent script commands that might have the effect of returning focus back to the page from which it launched, maybe that would be cause the problem. ?? Could you check this setting: '''dom.disable_window_flip''' is a true/false preference that determines whether a script in a web page is allowed to change focus between Firefox windows (typically, bring itself to the front, or pop-under by bringing the window from which it was opened to the front). By default, this preference is set to true to disable websites from moving windows around in the z-order. You could experiment: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''flip''' and pause while the list is filtered (3) Double-click the '''dom.disable_window_flip''' preference to switch it from true to false Any difference? </blockquote>

Umnikazi wombuzo

YESSSSSS! That's it! You are the best - thank you very much! And this time, I will save the solution :-D

YESSSSSS! That's it! You are the best - thank you very much! And this time, I will save the solution :-D