X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Sometimes instead opening a page Firefox closes the tab

Kuphostiwe

Sometimes when I type an address in the address bar and click "Enter", the active tab just closes instead of loading the page. I get no error warning. I'm not certain but I think it has also happened at least once when I clicked a link on a page. As far as I can tell, it's not a specific site, or type of sites. It's not a common thing, only happens once in a while.

Sometimes when I type an address in the address bar and click "Enter", the active tab just closes instead of loading the page. I get no error warning. I'm not certain but I think it has also happened at least once when I clicked a link on a page. As far as I can tell, it's not a specific site, or type of sites. It's not a common thing, only happens once in a while.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Bitdefender QuickScan Web Netscape Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin

Isisebenziso

  • Firefox 47.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/47.0/WINNT/lt/

Izandiso

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Bitdefender QuickScan 0.9.9.147.1-signed ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Firefox Hello Beta 1.3.2 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Proxmate 4.3.0 (jid1-QpHD8URtZWJC2A@jetpack)
  • Avast Online Security 10.3.3.39 (wrc@avast.com) (Akusebenzi)
  • Avast SafePrice 10.3.5.39 (sp@avast.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 05971028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 8-17-2015
  • driverDate2:
  • driverVersion: 10.18.10.4276
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4254 izisombululo 59582 izimpendulo
Kuphostiwe

You are using a beta version. Reinstall it. Is the problem still there?


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

You are using a beta version. Reinstall it. Is the problem still there? ---------- Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

I uninstalled and reinstalled Firefox as you recommended, but it just happened again - I clicked a link on a webpage and the tab just closed.

I uninstalled and reinstalled Firefox as you recommended, but it just happened again - I clicked a link on a webpage and the tab just closed.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59582 izimpendulo
Kuphostiwe

And Safe Mode?


Next time, right click the link and use the menu.

And Safe Mode? ----------- Next time, right click the link and use the menu.
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

As I said, it doesn't happen often, like, not even everyday, so working in safe mode for several days only to test whether this bug happens would be a major inconvenience.

As I said, it doesn't happen often, like, not even everyday, so working in safe mode for several days only to test whether this bug happens would be a major inconvenience.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71655 izimpendulo
Kuphostiwe

When this occurs, does "Undo Close Tab" work or does it immediately self-close again? Undo Close Tab is available from either:

  • History menu
  • right-click a different tab

If the entire window closed because it only had the one tab, you'll first need to restore the closed window from the History menu. (That probably won't work in a private window.)

When this occurs, does "Undo Close Tab" work or does it immediately self-close again? Undo Close Tab is available from either: * History menu * right-click a different tab If the ''entire window'' closed because it only had the one tab, you'll first need to restore the closed window from the History menu. (That probably won't work in a private window.)
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

I haven't tried "Undo Close Tab", I'll try the next time it happens and tell you whether it works.

So far it never happened with a single tab (maybe because I rarely work with one).

I haven't tried "Undo Close Tab", I'll try the next time it happens and tell you whether it works. So far it never happened with a single tab (maybe because I rarely work with one).
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

It happened again (as you see, two days passed since last time). The "Undo Close Tab" works.

It happened again (as you see, two days passed since last time). The "Undo Close Tab" works.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71655 izimpendulo
Kuphostiwe

If you check the back history of the tab that got closed, do you notice any pattern?

The reason I ask is: pages are generally not allowed to close themselves unless they were launched from a script. If, hypothetically, a page was designed to close itself when you leave it, and Firefox is not canceling that action when you load the new page in the same tab, perhaps that could explain how it is getting closed. Otherwise, it's very hard to explain since the new page probably wouldn't want to close itself.

If you check the back history of the tab that got closed, do you notice any pattern? The reason I ask is: pages are generally not allowed to close themselves unless they were launched from a script. If, hypothetically, a page was designed to close itself when you leave it, and Firefox is not canceling that action when you load the new page in the same tab, perhaps that could explain how it is getting closed. Otherwise, it's very hard to explain since the new page probably wouldn't want to close itself.
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

No, I did not notice any pattern on what gets closed, and as far as I can tell most of the websites that were closed have no ability to close themselves.

No, I did not notice any pattern on what gets closed, and as far as I can tell most of the websites that were closed have no ability to close themselves.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59582 izimpendulo
Kuphostiwe

This might help; http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Enter dom.disable_window From this list, set everything to True.

This might help; http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Enter '''dom.disable_window''' From this list, set everything to '''True.'''
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

That didn't work, it just happened again.

That didn't work, it just happened again.

Okulungisiwe ngu Vikte

Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

It seems that the problem disappeared by itself. Probably some update fixed it.

It seems that the problem disappeared by itself. Probably some update fixed it.
FredMcD
  • Top 10 Contributor
4254 izisombululo 59582 izimpendulo
Kuphostiwe

Here's hoping. Please flag your last post as Solved Problem so others will know.

Here's hoping. Please flag your last post as '''Solved Problem''' so others will know.
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

...AND it's happening again :-\

...AND it's happening again :-\
jscher2000
  • Top 10 Contributor
8758 izisombululo 71655 izimpendulo
Kuphostiwe

Any new info on the situation, pattern, etc.?

Any new info on the situation, pattern, etc.?
FredMcD
  • Top 10 Contributor
4254 izisombululo 59582 izimpendulo
Kuphostiwe

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. Go to that message, and use the '''Undo''' link to its right.
Vikte
  • Locale Leader
Kuphostiwe

Umnikazi wombuzo

It's only happened a few times again, but it seems as random as it was before.

It's only happened a few times again, but it seems as random as it was before.