Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 46.0.1 - Viewing Facebook pages without logging in

  • 8 uphendule
  • 23 zinale nkinga
  • 5724 views
  • Igcine ukuphendulwa ngu Joopi

more options

RE: Firefox 46.0.1

      Facebook Website - viewing pages

Prior to updating/upgrading to the current FF version I was able to view various Facebook pages and not have the pop-up window asking to either create a Facebook account or login. Now, each time I open a Facebook page this window keeps appearing and partially blocks the page I want to view. I DO NOT want, nor need, a Facebook account! How do I go about removing, stopping, blocking, etc., this pop-up window from appearing? Extremely annoying!

Isisombululo esikhethiwe

I am going to consider this as RESOLVED although there appears to be NO FIX to me problem. I guess I will just have to contend with the SIGN UP/LOG IN popup window until either something changes or, just maybe, switch to a different browser. I don't use Chrome. So I don't how Chrome has anything to do with using Firefox (on Linux).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

I have same problem when I try to view Facebook pages which are public. No trouble viewing them in past. Tried opening FF with add- ons disabled, still showed overlay on screen. This is text on overlay screen. (I removed name of Facebook site)


"See more of************* by logging into Facebook Message this Page, learn about upcoming events and more. If you don't have a Facebook account, you can create one to see more of this Page. Sign Up Log In"

more options

This code in userContent.css seems to work at the moment to hide this message.

Add code to the userContent.css file.


@-moz-document domain(www.facebook.com){div[class="_5hn6"]{display:none!important;}}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

more options

Isisombululo Esikhethiwe

I am going to consider this as RESOLVED although there appears to be NO FIX to me problem. I guess I will just have to contend with the SIGN UP/LOG IN popup window until either something changes or, just maybe, switch to a different browser. I don't use Chrome. So I don't how Chrome has anything to do with using Firefox (on Linux).

more options

The chrome name of that folder that contains userContent.css has nothing to do with Google Chrome. Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no relation with Google Chrome).


You can use the Stylish extension to make it easier to manage custom style rules if you do not want to use userContent.css.

You can use these steps to create the chrome folder and the userContent.css file in it.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
more options

I tried again by following your steps. This time it appears that this fix does work. I am wondering if this problem with Facebook is in Firefox or with Facebook. No matter I guess. I seem to have ... for now ... fixed my problem. Also, I just saw that Mozilla has released Firefox v47.x. I will have to wait for the Linux repository/ies to test and release v47 for updating Linux distros. Maybe this problem is addressed/fixed in v47.

more options

I was able to stop the Facebook overlay by adding a custom filter to the Ad Block Plus FF add on. The filter that I am using is:

facebook.com###pagelet_growth_expanding_cta

I needed to create new backup and save after I added filter so that new filter would not be deleted every time FF closed. There are other filters to try on Ad Block Plus forums.

more options

It is Facebook that is doing this and you should see this in all browser unless you have a content blocking extension that catches this.

more options

For PC users

Replace www.facebook.com/...... by m.facebook.com/....... than you will get the mobile version in your Firefox browser.