X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

page set up is in metric

Kuphostiwe

My page set up just changed from inches to metric. Paper size is Letter. So what happened with the latest Firefox? Been using it for years and never saw this issue before.

My page set up just changed from inches to metric. Paper size is Letter. So what happened with the latest Firefox? Been using it for years and never saw this issue before.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Citrix Online App Detector Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.77.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 21.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin
  • NPWLPG
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • Firefox 43.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/43.0.1/WINNT/en-US/

Izandiso

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: NVIDIA Quadro NVS 135M
  • adapterDescription2:
  • adapterDeviceID: 0x042b
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 01fe1028
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 9-19-2007
  • driverDate2:
  • driverVersion: 6.14.11.5665
  • driverVersion2:
  • failures: [u'[GFX1-]: Setting paper width to bad value -1', u'[GFX1-]: Setting paper height to bad value -1']
  • indices: [0, 1]
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Failed to create H264 decoder
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4193 izisombululo 58539 izimpendulo
Kuphostiwe

Separate Security Issue: Update your Adobe Reader Version 2015.016.20039 Note: Other Software is offered in the download.

https://support.mozilla.org/en-US/kb/update-firefox-latest-version 46.0.1


I don't know if this will help but check your language setting.

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district are selected.

Separate Security Issue: Update your '''[http://get.adobe.com/reader/ Adobe Reader Version 2015.016.20039]''' '''Note: Other Software''' is offered in the download. https://support.mozilla.org/en-US/kb/update-firefox-latest-version '''46.0.1''' ---------- I don't know if this will help but check your language setting. Type '''about:preferences#content'''<enter> in the address bar. On the bottom of the page, find '''Languages.''' To its right, press the '''Choose''' button. Make sure the correct language and district are selected.
cor-el
  • Top 10 Contributor
  • Moderator
17346 izisombululo 156811 izimpendulo
Kuphostiwe

Did you try to reset the print prefs on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

(edited tofix broken link)

Did you try to reset the print prefs on the <b>about:config</b> page? *http://kb.mozillazine.org/Problems_printing_web_pages *https://support.mozilla.org/kb/how-print-websites You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config ''(edited tofix broken link)''

Okulungisiwe ngu cor-el

CharleneTX 2 izisombululo 14 izimpendulo
Kuphostiwe

I'm having the same problem. I can't change the margins from millimeters to inches.

Firefox is updated to 46.0.1. Under printer preferences, I've selected "letter" size paper. I tried changing the paper to A4, then back to letter. I did an about:config print_printer reset.

The suggested URL "https://support.mozilla.org/en-US/kb/how-print-website" returns a page not found error.

I'm having the same problem. I can't change the margins from millimeters to inches. Firefox is updated to 46.0.1. Under printer preferences, I've selected "letter" size paper. I tried changing the paper to A4, then back to letter. I did an about:config print_printer reset. The suggested URL "https://support.mozilla.org/en-US/kb/how-print-website" returns a page not found error.
cor-el
  • Top 10 Contributor
  • Moderator
17346 izisombululo 156811 izimpendulo
Kuphostiwe

That should have been the plural (websites)

That should have been the plural (websites) *https://support.mozilla.org/kb/how-print-websites
CharleneTX 2 izisombululo 14 izimpendulo
Kuphostiwe

Still no joy. There wasn't anything at the corrected URL about changing from millimeters to inches. Right now I'm having to print from Internet Explorer (UGH!).

Still no joy. There wasn't anything at the corrected URL about changing from millimeters to inches. Right now I'm having to print from Internet Explorer (UGH!).
1984WasNotaManual 0 izisombululo 8 izimpendulo
Kuphostiwe

I had this problem with my printer, too: the page size was letter, but the margins were in millimeters.

I tried all the solutions offered here and elsewhere, not just setting print.*.print_paper_size_unit to 0 but I wiped all the preferences for print.MyPrinter.* with no success.

My problem was in the print driver (Win7Ent 64bit). The Printer Properties had all the correct settings displayed, and there was nothing unusual with Print Server. However, in Printer Properties I had an accessories tab that listed printer trays and the associated paper sizes. This all appeared correct, but I found an option to auto-detect the accessories. This was the resolution to my metric vs. inches mismatch: telling the print driver to auto-detect its paper trays reset the corrupt settings within the driver.

The underlying trouble that caused this problem for me was not in Firefox; it was in the print driver.

I hope this saves someone the CWH® (Countless Wasted Hours) that I lost.

I had this problem with my printer, too: the page size was letter, but the margins were in millimeters. I tried all the solutions offered here and elsewhere, not just setting print.*.print_paper_size_unit to 0 but I wiped all the preferences for print.MyPrinter.* with no success. My problem was in the print driver (Win7Ent 64bit). The Printer Properties had all the correct settings displayed, and there was nothing unusual with Print Server. However, in Printer Properties I had an accessories tab that listed printer trays and the associated paper sizes. This all appeared correct, but I found an option to auto-detect the accessories. This was the resolution to my metric vs. inches mismatch: telling the print driver to auto-detect its paper trays reset the corrupt settings within the driver. The underlying trouble that caused this problem for me was not in Firefox; it was in the print driver. I hope this saves someone the CWH® (Countless Wasted Hours) that I lost.
the-edmeister
  • Moderator
5391 izisombululo 40026 izimpendulo
Kuphostiwe

Doug said

I hope this saves someone the CWH® (Countless Wasted Hours) that I lost.

Thanks for that info, but knowing which printer drivers or the 'brand' of printer might help us either file a Bug report or create a KB page.

Also, was that with the Win64 build of Firefox? Or Win32?

''Doug [[#answer-887304|said]]'' <blockquote> I hope this saves someone the CWH® (Countless Wasted Hours) that I lost. </blockquote> Thanks for that info, but knowing which printer drivers or the 'brand' of printer might help us either file a Bug report or create a KB page. Also, was that with the Win64 build of Firefox? Or Win32?
mbout38 0 izisombululo 3 izimpendulo
Kuphostiwe

Same problem. Windows 10, Firefox 47.0.1 about:preferences#content - language correctly set to eng-us about:config print_printer reset Cleared all print-related settings in prefs.js

Same problem happens regardless of printer selected All printers set to US letter, but still display margins in MM Problem only happens in Firefox

And, just noticed that problem also exists on several other computers in the office (as well as my personal computer)

Any other ideas?

Same problem. Windows 10, Firefox 47.0.1 about:preferences#content - language correctly set to eng-us about:config print_printer reset Cleared all print-related settings in prefs.js Same problem happens regardless of printer selected All printers set to US letter, but still display margins in MM Problem only happens in Firefox And, just noticed that problem also exists on several other computers in the office (as well as my personal computer) Any other ideas?

Okulungisiwe ngu mbout38

jscher2000
  • Top 10 Contributor
8583 izisombululo 70205 izimpendulo
Kuphostiwe

Hi mbout38, do you have this discrepancy:

  • Page Setup dialog shows measurements in millimeters
  • about:config shows measurements in inches

For example 12.7 in Page Setup and 0.5 here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste print_margin and pause while the list is filtered

This is a "bug" in the Page Setup dialog not adjusting the unit of measure for regions that use feet and inches. A developer has taken it on with the comment "I know what I need to do to sort this out, I'll get to it soon." Hopefully it will get fixed in Firefox 48 (anticipated mid-July). Until then, keep your metric converter handy, or edit the inch measurements in about:config instead of the Page Setup dialog.

Hi mbout38, do you have this discrepancy: * Page Setup dialog shows measurements in millimeters * about:config shows measurements in inches For example 12.7 in Page Setup and 0.5 here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''print_margin''' and pause while the list is filtered This is a "bug" in the Page Setup dialog not adjusting the unit of measure for regions that use feet and inches. A developer has taken it on with the comment "I know what I need to do to sort this out, I'll get to it soon." Hopefully it will get fixed in Firefox 48 (anticipated mid-July). Until then, keep your metric converter handy, or edit the inch measurements in about:config instead of the Page Setup dialog.
mbout38 0 izisombululo 3 izimpendulo
Kuphostiwe

That's exactly it! Glad to know it's a bug that's being worked on! Meanwhile, I'm changing my and office computers to 6.3mm to match our 0.25 inch preference. Thanks!

That's exactly it! Glad to know it's a bug that's being worked on! Meanwhile, I'm changing my and office computers to 6.3mm to match our 0.25 inch preference. Thanks!
1984WasNotaManual 0 izisombululo 8 izimpendulo
Kuphostiwe

the-edmeister said

Doug said
I hope this saves someone the CWH® (Countless Wasted Hours) that I lost.

Thanks for that info, but knowing which printer drivers or the 'brand' of printer might help us either file a Bug report or create a KB page.

Also, was that with the Win64 build of Firefox? Or Win32?

Alas, I think the omitted information for which you've asked is not going to be helpful. (Well, perhaps it would.)

I had the same issue arise on another system (completely different setup and location). The CWH® efforts that helped before didn't help with the second system.

IIRC, the situation may be similar to what jscher2000 described with the discrepancy between the GUI and about:config. I'm not at that location at the moment.

''the-edmeister [[#answer-887531|said]]'' <blockquote> ''Doug [[#answer-887304|said]]'' <blockquote> I hope this saves someone the CWH® (Countless Wasted Hours) that I lost. </blockquote> Thanks for that info, but knowing which printer drivers or the 'brand' of printer might help us either file a Bug report or create a KB page. Also, was that with the Win64 build of Firefox? Or Win32? </blockquote> Alas, I think the omitted information for which you've asked is not going to be helpful. (Well, perhaps it would.) I had the same issue arise on another system (completely different setup and location). The CWH® efforts that helped before didn't help with the second system. IIRC, the situation may be similar to what jscher2000 described with the discrepancy between the GUI and about:config. I'm not at that location at the moment.