Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have lost my automatic login user names. I keep resetting and it comes back, but it doesn't save it for the next time I try to log in.How do you save setting

  • 6 uphendule
  • 2 zinale nkinga
  • 51 views
  • Igcine ukuphendulwa ngu starhugger

more options

I do not save my passwords, but I do like my user logins to automatically pop up. Up until yesterday, they did. I have found the settings in options and corrected it, but once I logout or go offline, when I come back my settings have been lost. How do I get it to save?

Okulungisiwe ngu James

Isisombululo esikhethiwe

I had (what sounds like) a similar problem very recently where I would lose my history and saved login settings when I closed Firefox. The logins were still saved, but the settings had changed. After tearing my hair out for several days, I discovered that my antivirus (Trend, at the time) had a password manager that was making the changes. Even though I had never used that part of the program, it was still taking action. Even after I uninstalled Trend (and installed another AV I had), the password manager was still left running in the background, even after rebooting. Since uninstalling the password manager, I haven't had this problem. You might check to see if your AV and other security programs might be being a bit overenthusiastic. I hope this helps.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Well, this did not help. I had a Malwarebytes Anti-Exploit program running, but I turned it off and it still went back to those settings.

more options

Isisombululo Esikhethiwe

I had (what sounds like) a similar problem very recently where I would lose my history and saved login settings when I closed Firefox. The logins were still saved, but the settings had changed. After tearing my hair out for several days, I discovered that my antivirus (Trend, at the time) had a password manager that was making the changes. Even though I had never used that part of the program, it was still taking action. Even after I uninstalled Trend (and installed another AV I had), the password manager was still left running in the background, even after rebooting. Since uninstalling the password manager, I haven't had this problem. You might check to see if your AV and other security programs might be being a bit overenthusiastic. I hope this helps.

more options

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • You can create a cookie "Allow" exception to keep specific cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

If you remove the cookies from a website then this makes the website forget about you.

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep
more options

Starhugger got it. I went in and uninstalled only the Trend Micro Password Manager. Problem gone. Thanks for all the help!

more options

I'm glad it helped, jeannen2. :-)