Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I cannot access my teamspeak server control because it needs java.

  • 8 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu BlitzPig

more options

I have been trying to access the server control panel for my Team Speak server, and Firefox has Java blocked. I have "allowed" Java, I think, but to no avail.

How do I get this to work? The example of how to allow java for a specific site looks nothing like what I see in my Firefox browser.

Getting fairly frustrated about this, because I could access my control panel before...

Isisombululo esikhethiwe

Hi BlitzPig, JavaScript is enabled by default, and if it's disabled globally, half the sites on the web will tell you. If this error occurs only on one site, it may be that a particular capability the site tests for is not working, or that something is blocked by one of the following:

  • Tracking Protection
    • Firefox has a built-in tracking protection feature which you can disable on a site as needed. If there is a shield icon at the left end of the address bar, see: What happened to Tracking Protection?
    • Numerous add-ons block third party scripts associated with tracking, including Disconnect, Blur, Ghostery, and Privacy Badger
  • Script blocking
    • If you use the NoScript extension, check its menu for hosts that may be blocked
  • Ad blocking
    • Some ad blockers trigger on file and folder names, even if they don't actually drive advertising, so you may need to make an exception to see whether that helps

Users also have seen that message when a plugin the page wants to use does not start when expected. You can check/modify plugin permissions for the site using the Permissions panel of the Page Info dialog as described in an earlier reply to work around that.


More generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (8)

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Hi BlitzPig, on the page where you have this problem, could you check for a plugin notification icon toward the left end of the address bar (looks like a small gray Lego block). If you click that, you can give the site temporary or ongoing permission to use any plugins the page has informed Firefox it wants to use.

Does that work?

If Firefox is not detecting the request, try setting the permission using the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Activate Plugins" and you can select Allow for the Java plugin(s). This is saved immediately, so you can just close the dialog. Then reload the page and see whether it kicks in.

Any luck?

more options

Thanks for the replys folks. However, when I do try to log into my server control panel I do not have the "lego block" icon in the address bar, all I see is an exclamation point in a circle.

I have Java set to "allow" in my permissions.

Still does not work.

Not really sure what is going on here, as it worked before without issue.

more options

Where do you see an indication that the problem is Java? Can you link to that page or provide a screenshot of the message? This article has tips on screenshots: How do I create a screenshot of my problem? Please cut out or blur any sensitive information in the image before attaching the file to a reply.

more options

Just to be sure: Java and JavaScript are different languages.

To avoid confusion, see:

more options

Well, I am adding a screen shot of the window that comes up when I try to log in.

I have contacted the provider and they say nothing has changed on their end. I have javascript enabled in Firefox and can find no other program that is blocking it.

Next step will be to try another browser I guess. I am not a programmer, just a user who likes Firefox, but if I can't make it work for me it will be time to move on.

more options

Isisombululo Esikhethiwe

Hi BlitzPig, JavaScript is enabled by default, and if it's disabled globally, half the sites on the web will tell you. If this error occurs only on one site, it may be that a particular capability the site tests for is not working, or that something is blocked by one of the following:

  • Tracking Protection
    • Firefox has a built-in tracking protection feature which you can disable on a site as needed. If there is a shield icon at the left end of the address bar, see: What happened to Tracking Protection?
    • Numerous add-ons block third party scripts associated with tracking, including Disconnect, Blur, Ghostery, and Privacy Badger
  • Script blocking
    • If you use the NoScript extension, check its menu for hosts that may be blocked
  • Ad blocking
    • Some ad blockers trigger on file and folder names, even if they don't actually drive advertising, so you may need to make an exception to see whether that helps

Users also have seen that message when a plugin the page wants to use does not start when expected. You can check/modify plugin permissions for the site using the Permissions panel of the Page Info dialog as described in an earlier reply to work around that.


More generally:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

more options

Well, I did the unthinkable and installed Chrome.

No issues anymore.

No mucking about fiddling with the innards of the program and promising not to hurt anything in the secrect settings page.

It just worked straight away.

Thanks for the effort gents. I do appreciate it.