Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox can't connect to Google.com

  • 7 uphendule
  • 3 zinale nkinga
  • 60 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Firefox 46.0.1, Power Mac 3.0, OS X Yosemite It is possible to connect to any other site, but not to google.com

I already followed some tips found in this forum: -Delete recent history -No proxy option -Refresh Firefox -Uninstall/Install

After I delete recent history it can connect to google.com, but once the history entries start to increase (after two or three times I make a search with google.com) the tabs says "Connecting..." and the bottom status bar "Waiting for www.google.com... but nothing happens.

I can search with Yahoo.com or go to any other site, but not google.com (Firefox) I have Google Chrome and Safari installed and I don´t have any connection problems with them I can ping to google.com:

  21 packets transmitted, 21 packets received, 0.0% packet loss
  round-trip min/avg/max/stddev = 17.620/17.834/18.292/0.148 ms

All Replies (7)

more options

What security software do you have?

Did you make sure that your security software isn't blocking access?

You can also check for malware.

more options

I don´t have an antivirus installed. If I restart Firefox I can go to google.com once, just once, after that, the same: "Connecting..." and "Waiting for www.google.com..." and nothing again.

more options

Did you try to search for malware?


Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks for your replies. I tried the creating a new profile suggestion, but nothing worked. I gave up. I'm giving Vivaldi a chance right now.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

The problem still there (

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia