Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can i prevent the scrollbar to jump to the clicked location?

  • 3 uphendule
  • 22 zinale nkinga
  • 4863 views
  • Igcine ukuphendulwa ngu cor-el

more options

In Firefox 46 running under Linux, clicking near the bottom of the scroll bar makes the browser scroll to the bottom of the page, instead of scrolling one page down, as in version 45. Why is this, and how can it be cured?

I know the answer to the latter, but it seems that one has to ask a question to be able to register. Weird!

Isisombululo esikhethiwe

All Replies (3)

more options

I've seen a report that the behavior of Shift clicking has been reversed, so does holding down the Shift key when you click the scroll bar work?

more options

I bet it does, but this behavior should not have changed, because it made Firefox behave inconsistent. Version 46 still scrolls in the usual way on Windows, and all other applications that I use in Linux Mint also still scroll in the usual way, so this just looks like someone enjoys annoying users, as you can read in

https://support.mozilla.org/nl/questions/1120904

where I pasted a cure found on the ask ubuntu site.

The real cause of this is a foolish change in GTK 3, and it's even more foolish to find out that in order to register here, I needed to ask a new question, which pollutes the support site with duplicate information:

http://askubuntu.com/questions/295988/how-to-fix-gtk3-scrollbar-behavior

What's makes this such a rotten thing is that to cure this, there is no other way than editing a hidden file, which is not suited for everyone.

Okulungisiwe ngu ennoborg

more options

Isisombululo Esikhethiwe

You can try this workaround:

See also: