Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why, when using standard google search do images appear at top of page then always disappear in 1 second (e.g. search for 'blenders'

  • 2 uphendule
  • 2 zinale nkinga
  • 3190 views
  • Igcine ukuphendulwa ngu terence99

more options

Why, when using standard google search do images appear at top of page then always disappear in 1 second (e.g. search for 'blenders'.

This does not happen in Chrome and has only been happening in Firefox in recent times.

Isisombululo esikhethiwe

Are they images of blenders? I get a Shopping section with pictures of blenders, but otherwise, I don't notice any unexpected images.

Is there any way you can capture a screenshot or video of the problem?

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

Are they images of blenders? I get a Shopping section with pictures of blenders, but otherwise, I don't notice any unexpected images.

Is there any way you can capture a screenshot or video of the problem?

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thanks - it's solved. It was OK in safe mode and when I disabled adblocker lite it was also OK because the images were all for Google Shopping.