Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

audio doesn't work on all websites

  • 2 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu breignchile

more options

I do not get audio on various websites. The audio on YouTube works fine, but other sites like espn.com and streaming radio sites like CBC and 102.1 the edge do not work. I have tried other web browsers and they work fine, so this is a problem specific to firefox. Any help would be greatly appreciated as I have always used firefox and do not want to stop because I cannot fig8ure out this problem. Thanks.

I do not get audio on various websites. The audio on YouTube works fine, but other sites like espn.com and streaming radio sites like CBC and 102.1 the edge do not work. I have tried other web browsers and they work fine, so this is a problem specific to firefox. Any help would be greatly appreciated as I have always used firefox and do not want to stop because I cannot fig8ure out this problem. Thanks.

All Replies (2)

more options

Hmm, does Firefox think it is playing media on those sites? Firefox should display a speaker icon on the tab when either a plugin or an HTML5 audio/video player is playing. Does the icon appear? (The icon is used to mute and unmute the tab, but it is un-muted by default.)

Next time you see this, could you check the Windows sound mixer? Right-click the speaker icon in the notification area of the task bar (over by the clock) and choose Open Volume Mixer. Then check whether any programs are making sound or might be muted. I'm attaching an older example for reference where the audio is coming from a separate program instead of Firefox (Flash protected mode).

more options

Thank you for your response, unfortunately the mixer isn't the issue. The speaker icon shows up once I click play on videos from the sites that work and does not appear on sites that have audio playing but is not audible. I recently had some issues with a Windows update, so that is likely the source of the problem. I just find it strange that it is just affecting the Firefox and not other browsers.