Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have a mac and when I open Firefox it brings up a blank search screen. I can enter a website but it doesn't connect to it but safari has no problem.

more options

I am running OSx El Capitan version 10.11.3. I have the latest Firefox loaded but when I open it I get a blank search page that can't connect to anything. Safari has no problem. I tried contacting Norton Antivirus but they say everything is fine on their end. Very frustrating. Not sure what to do from here.

Isisombululo esikhethiwe

This is something that you will have to ask Norton. I'm pretty sure that you will still have protection because the core program on your system will still be active, but I would confirm with Norton.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (8)

more options

Try changing your homepage to about:home (the default homepage) and see if that fixes the issue. For more information on changing your homepage, please refer to this Mozilla support article:

more options

This didn't change anything. Still no home page will load. it doesn't give an error message or anything it just doesn't do anything.

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

I can't even put in safe mode. when I click on the three lines on the right it does nothing.

more options

wait - I was able to start in safe mode after I closed firefox. it works fine in safe mode.

more options

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:


Note: Since your menu button doesn't work, you can try to access the options by typing about:preferences in the Firefox location bar.

more options

Okay - I went through all the steps and what finally worked was disabling the Norton Antivirus Extension. Will my computer be unprotected now that I had to disable that for it to work?

more options

Isisombululo Esikhethiwe

This is something that you will have to ask Norton. I'm pretty sure that you will still have protection because the core program on your system will still be active, but I would confirm with Norton.