X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox is defaulting to German , I need English! I cleared cache, cookies, nothing helps!!

Kuphostiwe

Just because I occasionally go to German websites, Firefox decided tochange my browsing to German. So now I can't pay for things I want to buy, because Firefox brings up pay input sites in German, with European zip code fields, which do not match the US fields. I have followed forum advice and cleared cookies and cache, no help. I checked my settings in Google Chrome, that says English. This is unbelievably frustrating. I NEVER asked any program to just mess with my language setting.

Just because I occasionally go to German websites, Firefox decided tochange my browsing to German. So now I can't pay for things I want to buy, because Firefox brings up pay input sites in German, with European zip code fields, which do not match the US fields. I have followed forum advice and cleared cookies and cache, no help. I checked my settings in Google Chrome, that says English. This is unbelievably frustrating. I NEVER asked any program to just mess with my language setting.

Isisombululo esikhethiwe

You can try to remove the Site Preferences via "Clear Recent History" or only remove the content-prefs.sqlite file to keep the permissions stored in permissions.sqlite.

  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data

You can use this button to go to the current Firefox profile folder:

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Amazon MP3 Downloader Plugin 1.0.18
  • Citrix Online App Detector Plugin
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.


Download Firefox For All languages And Systems {web link}


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Type '''about:preferences#content'''<enter> in the address bar. On the bottom of the page, find '''Languages.''' To its right, press the '''Choose''' button. Make sure the correct language and district is selected. ----------- '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} ----------- '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

You can check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check the connection settings. *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can

Umnikazi wombuzo

Thanks for trying, but nothing changed after trying these fixes. I did find German as the top language selected. First I changed it to English US, but after I rebooted the computer it was back to German. Then I deleted German all together and did not reboot, the setting stayed put but it still brings up websites in German. I do have Vaio Care on this computer, it came with the purchase a couple of years ago, but I don't dare uninstall it since it is part of the Sony package. I never installed any other care programs, but who knows if some other software included it without me being aware of it.

Thanks for trying, but nothing changed after trying these fixes. I did find German as the top language selected. First I changed it to English US, but after I rebooted the computer it was back to German. Then I deleted German all together and did not reboot, the setting stayed put but it still brings up websites in German. I do have Vaio Care on this computer, it came with the purchase a couple of years ago, but I don't dare uninstall it since it is part of the Sony package. I never installed any other care programs, but who knows if some other software included it without me being aware of it.

Okulungisiwe ngu gitabvd

FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

Is the problem with Firefox, or just the website display?

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Is the problem with Firefox, or just the website display? Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Umnikazi wombuzo

It is the display of the web pages. For instance, I do a search for Google chrome, the first tier of choices comes up in English. I click on one and now the invitation to download appears in German. Or I am on an English website that is asking for a contribution to a new project, I click on their funding page and it comes up in German (with address fields in the European format, so the zip code does not work). I do speak German (born and raised in Austria) so I occasionally visit web sites in German and write e-mails in German. That may have triggered this strange automatic translation. Obviously, I don't need it and I would never ask for it, since I am fluent in the language. I will now go and try your link for the malware. Thanks

It is the display of the web pages. For instance, I do a search for Google chrome, the first tier of choices comes up in English. I click on one and now the invitation to download appears in German. Or I am on an English website that is asking for a contribution to a new project, I click on their funding page and it comes up in German (with address fields in the European format, so the zip code does not work). I do speak German (born and raised in Austria) so I occasionally visit web sites in German and write e-mails in German. That may have triggered this strange automatic translation. Obviously, I don't need it and I would never ask for it, since I am fluent in the language. I will now go and try your link for the malware. Thanks
FredMcD
  • Top 10 Contributor
4254 izisombululo 59579 izimpendulo
Kuphostiwe

It sounds like you need to tell those web pages to use English.

It sounds like you need to tell those web pages to use English.

Umnikazi wombuzo

How do I do that? I don't see a place where I can??

I did install and run Malwarebytes and it found nothing. Also have Norton and McAffee installed and they never found anything. I am hesitant to install all kinds of more software unless that is absolutely the last thing I can try. With my very marginal experience, I am afraid of causing more problems than solutions.

How do I do that? I don't see a place where I can?? I did install and run Malwarebytes and it found nothing. Also have Norton and McAffee installed and they never found anything. I am hesitant to install all kinds of more software unless that is absolutely the last thing I can try. With my very marginal experience, I am afraid of causing more problems than solutions.
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You can try to remove the Site Preferences via "Clear Recent History" or only remove the content-prefs.sqlite file to keep the permissions stored in permissions.sqlite.

  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data

You can use this button to go to the current Firefox profile folder:

You can try to remove the Site Preferences via "Clear Recent History" or only remove the content-prefs.sqlite file to keep the permissions stored in permissions.sqlite. *clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox