Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

unable to connect connection is not secure

  • 8 uphendule
  • 26 zinale nkinga
  • 708 views
  • Igcine ukuphendulwa ngu Gin.

more options

hello, I have a problem with websites, I can only access google.com, wikipedia.com and support.mozilla.org. everything else will show me a "Unable to connect" message including youtube.com and amazon.com, and there's also a small "connection is not secure" beside website's domain name

things I tried doing: -restarting firefox, mac, internet -trying different browser (all show the same thing) -trying different networks (tried two)

the internet works perfectly with other devices like iphone and tablet I don't have any antivirus programs

and this problem wasn't there before, it started yesterday. although I didn't update or made changes to anything

Isisombululo esikhethiwe

Hello

I just wanted to tell you the problem was solved, partly .. what I did : 1. upgraded my mac from el capitan 10.11.3 to 10.11.4 2. used a VPN >>http://www.vpngate.net/en/ and it worked!

I am now working on how to connect without using VPNs however, I will mark this discussion as solved

thanks!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (8)

more options

Please post a screenshot of the "Unable to connect" message. https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

more options

That's probably a temporary outage or a glitch at your ISP. The site loads just fine from here. Try again later. 'Connection is not secure' just indicates the connection to the server is not encrypted. This isn't an error message.

more options

oh! thanks!

I'll try later and give a feed back

D
more options

interesting thing happened .. http://www.youtube.com doesn't open and show the "unable to connect" message. but https://www.youtube.com opens perfectly fine


I tried doing that with another website -amazon- and it opened.

However, other small websites "websudoku.com" didn't open even when I put the https before it. thought this information might help somehow

Okulungisiwe ngu Gin.

more options
http://www.youtube.com doesn't open and show the "unable to connect" message.

I'd expect the site to automatically redirect to https://www.youtube.com. Try to start Firefox in safe mode and see if that makes any difference. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

other small websites "websudoku.com" didn't open even when I put the https before it.

Then that site isn't available as https version.

Okulungisiwe ngu christ1

more options

I tried safe mood, and the exact same problem happens

I forget to mention tho, I am using some apps on my mac right now that requires internet and it is working i.e. Mail, line, anki

other small websites "websudoku.com" didn't open even when I put the https before it.

Then that site isn't available as https version.

you are right, every website that has a https version opened. I still don't know why youtube didn't open at first but now it is working, although I need to write https in the link or it won't open (see the picture)


so basically, any website with https version opens but http only website doesn't? why? I was able to open http websites just fine before yesterday?

I will continue to look further if I find a solution I will post it here

thanks

Okulungisiwe ngu Gin.

more options

Isisombululo Esikhethiwe

Hello

I just wanted to tell you the problem was solved, partly .. what I did : 1. upgraded my mac from el capitan 10.11.3 to 10.11.4 2. used a VPN >>http://www.vpngate.net/en/ and it worked!

I am now working on how to connect without using VPNs however, I will mark this discussion as solved

thanks!