Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

saved web pages don't display correctly

  • 19 uphendule
  • 2 zinale nkinga
  • 89 views
  • Igcine ukuphendulwa ngu alvinmoneypit

more options

my saved web pages (save complete page) won't display correctly whether I have my add-ons turned on or not, whether I'm connected to the internet or not. All the text is aligned left including links that are not displayed in the original pages that were save. No images are displayed. I don't know how to use the 'developer tools' to fix the problem. Sorry.

All Replies (19)

more options

It sounds like a problem loading an external style sheet. It's possible it wasn't saved, but let's see whether we can track that down.

If you open the page, then open the Network Monitor in the lower part of the tab and reload the page, you should be able to see if Firefox is trying to load a missing file. To open that, use either:

  • menu > Developer > Network
  • Ctrl+Shift+k, then click Network along the top line of the console

Then reload the page to see what loads and what doesn't.

more options

Hi and thanks for answering. I'm running Linux here with Firefox for Linux. I clicked Tools > Web Developer> Network. I'm not sure how to read the result, but everything had a time associated with it except 2 items, inspectlet.js and ns-686.js listing these with a domain "cached". I've posted a screen shot.

When I save a web page into a folder, the program puts the parts of the page into a separate folder and the html file outside that folder.

more options

Hmm, it seems there are no local files on the list, so it doesn't help as much as I expected.

If you view source on your document and use Find to look for .css can you find any <link> tags? If so, were they properly rewritten to point to the local folder? And are those files in the folder?

more options

I hope I interpreted your instructions correctly. I clicked Web Developer > Page Source, this opened a new tab with the page source. From that page I clicked Edit > Find. In the dialog that came up on the bottom, I entered '.css'. It found 4-5 instances, none of them showed any indication that they were connected to anything local on my computer or file tree that I could recognize that shows them pointing to the folder with my page content. However, I briefly reviewed the content of the folder and there are 4 instances of extension '.css'. A couple of examples - 'fonts.css' and 'socialwidget.css'. Is this what you wanted?

more options

The line with the highlight resulted specifies that it is for print media, so that would not be applied to the page when viewed in a tab. But the following match specifies screen media and looks like it is in a local folder. If you click that, does Firefox find CSS rules at that link or is the file missing?

more options

I may not be following. I clicked the next instance as I would any link and the message, "The address wasn't understood" came up.

more options

Just for the record, I've been saving a number of web pages over the years on this installation of Ubuntu and Firefox, I don't know if any of them ever displayed correctly.

more options

The link I clicked read as follows, " <link href="Recipe:%20Pan-Seared%20Steaks%20with%20%22Creamed%22%20Spinach%20&%20Lemon-Butter%20Purple%20Potatoes%20-%20Blue%20Apron_files/app-7bd9547c8e9dc18051cb01e358bfec39.css" media="screen" rel="stylesheet" type="text/css">

more options

No idea how critical it is to have the exact page. Have you considered instead of save using print then the print to file option.

Without needing any add-ons Ububtu should make a pdf copy of the page. Would that be sufficient for your purposes ?

more options

alvinmoneypit said

I clicked the next instance as I would any link and the message, "The address wasn't understood" came up.

Hmm, did the folder name save with recipe: at the beginning of its name? That seems to be blocking Firefox from loading its contents because Firefox misinterprets recipe: as a protocol (like file: or http:) instead of ordinary text.

On Windows, Firefox won't allow that and replaces the : with a space, but Linux may be more flexible with legal characters in file and folder names, so that could have given rise to this glitch.

Could you try editing the paths in the saved page in a text editor? After opening the .htm/.html file, try a global find and replace of

src="Recipe:%20

to

src="./Recipe:%20

Hopefully that will allow Firefox to handle the relative link properly.

Okulungisiwe ngu jscher2000

more options

jscher2000 said

After opening the .htm/.html file, try a global find and replace of

src="Recipe:%20

to

src="./Recipe:%20

Hopefully that will allow Firefox to handle the relative link properly.

Also:

href="Recipe:%20

to

href="./Recipe:%20
more options

alvinmoneypit said

Just for the record, I've been saving a number of web pages over the years on this installation of Ubuntu and Firefox, I don't know if any of them ever displayed correctly.

Many elements of pages are dynamically generated and are difficult to capture in source form. I agree with the suggestion to use PDF or a full-page screenshot for best fidelity.

more options

Yes, Linux is much more flexible with filenames. Yes, the content folder for the page starts "Recipe:"

for clarification, are you asking me to copy the page source into a text editor program and replace all instances as you describe? Should I then save it somewhere? I'm not sure how that is done.

more options

John99, Thanks for replying. I haven't used 'Print to file". I can try it, just wondering why saving web pages doesn't work. This is Ubuntu 12.04, an old install now with many updates. It's getting a little creaky now, but mostly with Firefox, most other stuff works fine. If I recall correctly, this version of Ubuntu will be supported through 2017. I used my last install until about 18 months after expiration of maintenance.

more options

John99, I tried 'print to file'. The result didn't show any images and was similar to the 'saved web page' in regard to formatting. The formatting of the text was distorted where some things were much bigger than the original.

more options

John99 and jsher2000, I downloaded the add-on 'Fireshot' as about 800,000 others have. It correctly saved the entire page in a PDF format I can use. This works even though the description says for Windows only. I figured if it's available to me as a Firefox Linux user, it must work and it does. I won't mark this as 'solved' as the original question was never resolved, but thanks for your input leading to a workaround for me.

more options

alvinmoneypit said

for clarification, are you asking me to copy the page source into a text editor program and replace all instances as you describe? Should I then save it somewhere? I'm not sure how that is done.

Yes, edit the paths and save the edited file either in place of the existing file, or if you prefer, alongside it with a revised name (it needs to be in the same folder as the original).

By the way, I suggest using an editor that doesn't replace "straight" quotation marks with curved ones.

more options

Another workaround probably even better.

It appears the webpage is actually designed to be available as a .pdf download. There is an option shown on your own screen shot.

more options

John99, Huh! I never noticed it. Thanks!