Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo. more option (Google Apps) not working

  • 13 uphendule
  • 9 zinale nkinga
  • Igcine ukuphendulwa ngu KashifSurhio

more options

From couple of weeks I am noticing that option for more apps (the grid icon on google main page) is not working in firefox but it works with internet explorer. This option works very well at my office in the same firefox version. I have also same addons installed at office and home (Add blocker plus, no script, download them all, video download helper). I tried updating firefox on latest version and also create new firefox profile but it does not solve this issue. i want to identify and solve this problem because this also affects for getting option to logout from gmail (that is also not working in my home using firefox). I am attaching the image for the option I am asking about. I will appreciate if anyone can help.

Ama-screenshot ananyekiwe

Okulungisiwe ngu KashifSurhio

All Replies (13)

more options

Any response from FF technical team??

more options

Sorry for the delay!

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Hi jscher2000,

First thanks for your response here.

I tried what you recommend (Help menu > Restart with Add-ons Disabled) and start Firefox in Safe Mode but there is no difference, still the google apps script is not working. I have double check that all my add-ons are disabled.

Any other way to find the problem like to get firefox logs or anything that may help devs identify this issue.

Attaching the image where the apps works fine in IE but not in FF

Regards Kashif

more options

Does your computer have a touchscreen? Occasionally Firefox users report that some interface elements are non-operable with a mouse on Windows 8 but are operable with a touch. Usually we haven't found a way to fix this issue in Firefox, although these past thread mention some changes to try:

more options

Hi jscher2000,

No my laptop is not with touch screen, I am using Lenovo G50-80, Core i5, 4GB RAM standard configuration.

I also refreshed the FF (I have all the add-on backup with me) but issue is not resolved.

PS, I don't have a mouse so I am using touch pad. I've also tried using my Android as mouse but same issue.

Okulungisiwe ngu KashifSurhio

more options

As the next step, could you check two of Firefox's Developer Tools?

On the Google home page, right-click the non-working icon and choose Inspect Element (Q). This should open the Inspector in the lower part of the tab with the active element highlighted. I am attaching a screenshot for comparison. Does yours show that the active element is the link and does it also show the little "EV" indicator at the end of the link showing that scripts are assigned to this link?

Next, click the Console button along the top edge of the developer tools. To remove existing clutter in the console, click the Clear button above the list, and then try the apps/menu button and check for any error messages in the console. I have attached a screenshot for reference (without errors). Anything?

more options

Please check attached images.

more options

Hi KashifSurhio, there definitely is a problem in the first screen shot if the actual menu content is not in the document at all. I really have no idea why that is missing, since in my limited testing it is being sent by the server as part of the page.

Is there anything special about how your home Firefox connects to the network, for example, a proxy server, private VPN, Tor, Hola, or being "filtered" by security software?

You could check your Firefox connection settings here:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, click the "Network" mini-tab and then the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows LAN connection settings, but you could try "No proxy" to see whether that makes a difference.

more options

Hi jscher2000,

I change network proxy to o proxy and check the page but it is same as before. For your question, I am using my mobile internet with wlan sharing (connection from Vodafone Qatar) the thing only in my mind is, if the options are not connected with page then it should also not work with internet explorer. May be my telco filter the data and sends in last that Firefox is not getting successfully or not understanding.

more options

Hi KashifSurhio, is there any reason that scripts might be blocked from running on that page? If I block scripts, I don't get event handlers (makes sense, since those are scripts) but also the menu HTML is in a location much further down the document as shown in the attached screenshot.

more options

Hi jscher2000,

I randomly perform some tests and found something interesting (see attached images) as:

1> With the help of no script add-on I disable all scripts for 2> I open news from google old style menu (with no java script support) 3> Noticed the URL with js=0 (java script disabled) 4> From noScript add-on Temporarily allow all on this page ( 5> Page auto refreshed and "js=0" is removed (Because scripts are temporarily allowed) 6> Google Apps scripts are working now

If something is blocked by FF itself - I don't have any idea. Something blocked by any other app (Antivirus, Firewall, or telco service provider itself) - IE should also not work in this case but this does not seems to be any issue

more options

Nothing else is coming to mind for me. If you think this started with the Firefox 45 update, and since you already tried a new profile, possibly there is some corruption in the program folder. That can be the thing to check after running out of logical explanations...

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 45.0.1 from to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(32-bit Firefox on 64-bit Windows)

C:\Program Files (x86)\Mozilla Firefox


C:\Program Files (x86)\OldFirefox

(Other systems)

C:\Program Files\Mozilla Firefox


C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Also, has your NoScript updated to version There were some bug fixes recently, although I don't think they relate to Google sites.

more options

Hi jscher2000,

First "YES" I have updated version of NoScript i-e

Now, I did what you mention in Clean Install, along with Mozilla Firefox I also renamed Mozilla Maintenance Service and then perform clean install of version 45.0.1 but no luck, issue is same. Second today I tried with my old backup of Tor Browser 24.4.0 and it is working fine. Then I download latest TOR Bundle (it shows based on FF 38.7.1) and google is working fine. To my normal FF (45.0.1) I enable global scripts from NoScript and open but the issue is not resolved.