Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Clearing parent filters

  • 1 baphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Im on a Mac 10.11 - When searching for specifics (men's web belts, ex) I might get a listing of sites to search but when I hit one of the files I get blocked by "adult" content filter. I dont see that option in my Foxfire preferences or my Mac preferences. How do I get rid of that.

All Replies (1)

more options

Check your add-ons and your protection programs.