Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I get a video to run fullscreen (44.0.2), as I'm getting permission denied?

  • 7 uphendule
  • 4 zinale nkinga
  • 185 views
  • Igcine ukuphendulwa ngu cor-el

more options

I'm on 44.0.2 and tried all of the suggested fixes, such as using:

 1) about:permissions and setting Fullscreen on either for all sites or a specific on.
     NOTE:  The Fullscreen setting no longer exists on 44.0.2 for about:permissions
 2) Using the Page Info -> Permission and again setting Fullscreen to always allow.
     NOTE:  The Fullscreen setting no longer exists on 44.0.2 for Permissions with Page Info

The specific failing URL with a video is:

http://www.gq.com/story/damn-daniel-vans-ellen-lifetime-supply

When you press the Fullscreen button on the video it brings up the help page at:

https://support.google.com/youtube/answer/6276924

Those instructions do NOT work for Firefox 44.0.2 nor do any of the currently available via search helps using Firefox search or forums.

I'm looking for another solution, I guess based upon the recent changes. SIGH!

Why push out code faster than the help file and/or documentation?????????

All Replies (7)

more options

This happens because the outermost containing iframe is missing the allowfullscreen="true" attribute. This attribute is required when the HTML5 media player is used in a frame to play media file. YouTube uses the HTML5 media player to serve videos to current Firefox releases. The website would have to modify its code and add this allowfullscreen="true" attribute to all iframes that play video content embedded to be able to switch to Full Screen mode.

more options

Daaaamn Bertram, if I grab that iframe tag --

<iframe src="https://www.youtube.com/embed/_LUX70mXcEE" height="" width=""></iframe>

-- and inject it into other pages, I see the same behavior. I wonder whether it's a option used by Ellen when the video was uploaded??

To see a framed embed full screen, you can pop it out into its own tab. In order to do this with YouTube videos, you need to first set Firefox to always show the built-in right-click context menu even when the site tries to replace it. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste menu and pause while the list is filtered

(3) Double-click the dom.event.contextmenu.enabled preference to flip it from true to false

Now when you right click, Firefox will show the built-in menu in front or or on top of YouTube's menu. Use This Frame > Open Frame in New Tab to open the embed in its own tab.

With this setting, Firefox's menu may occasionally block the site's menu. In that case, press and release the Alt key to gain access to the site's menu.

more options

Note that the Full Screen permissions are no longer available in "Tools > Page Info > Permissions" as a choice.

Possible code that you can use in the Web Console (3-bar Menu button or Tools > Web Developer) to add this missing attribute for embedded YouTube videos.

elm=document.querySelectorAll("iframe[src*=\"youtube\"]:not([allowfullscreen])");
for(i=0;oE=elm[i];i++){
nE = oE.cloneNode(true);
nE.setAttribute("allowfullscreen","true");
oE.parentNode.replaceChild(nE,oE);
}

This version can be used in the location field of a bookmarklet.

javascript:(function(){elm=document.querySelectorAll("iframe[src*=\"youtube\"]:not([allowfullscreen])");
for(i=0;oE=elm[i];i++){
nE = oE.cloneNode(true);
nE.setAttribute("allowfullscreen","true");
oE.parentNode.replaceChild(nE,oE);
}})()
more options

cor-el said

This happens because the outermost containing iframe is missing the allowfullscreen="true" attribute. This attribute is required when the HTML5 media player is used in a frame to play media file. YouTube uses the HTML5 media player to serve videos to current Firefox releases. The website would have to modify its code and add this allowfullscreen="true" attribute to all iframes that play video content embedded to be able to switch to Full Screen mode.

Hello,

Ah, I'm not the author of the website nor am I in a position to get them to change their code (as I expect many people are able to do).

How do I get it to work on my system?

What good is the current system if the user can't get it to work on his or her side? Why not allow us to force the addition of the allowfullscreen? After all it is our system (tablet / phone / computer), is it not?!

more options

jscher2000 said

Daaaamn Bertram, if I grab that iframe tag -- <iframe src="https://www.youtube.com/embed/_LUX70mXcEE" height="" width=""></iframe> -- and inject it into other pages, I see the same behavior. I wonder whether it's a option used by Ellen when the video was uploaded?? To see a framed embed full screen, you can pop it out into its own tab. In order to do this with YouTube videos, you need to first set Firefox to always show the built-in right-click context menu even when the site tries to replace it. Here's how: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste menu and pause while the list is filtered (3) Double-click the dom.event.contextmenu.enabled preference to flip it from true to false Now when you right click, Firefox will show the built-in menu in front or or on top of YouTube's menu. Use This Frame > Open Frame in New Tab to open the embed in its own tab. With this setting, Firefox's menu may occasionally block the site's menu. In that case, press and release the Alt key to gain access to the site's menu.

Thank you so very much! This worked for me without having to get the webmaster of every website with this issue to fix the problem!

Still Firefox should allow us to force it into fullscreen without so many hoops, but what matter is your suggestion works!

Thank you!

more options

cor-el said

Note that the Full Screen permissions are no longer available in "Tools > Page Info > Permissions" as a choice. Possible code that you can use in the Web Console (3-bar Menu button or Tools > Web Developer) to add this missing attribute for embedded YouTube videos.
elm=document.querySelectorAll("iframe[src*=\"youtube\"]:not([allowfullscreen])");
for(i=0;oE=elm[i];i++){
nE = oE.cloneNode(true);
nE.setAttribute("allowfullscreen","true");
oE.parentNode.replaceChild(nE,oE);
}

This version can be used in the location field of a bookmarklet.

javascript:(function(){elm=document.querySelectorAll("iframe[src*=\"youtube\"]:not([allowfullscreen])");
for(i=0;oE=elm[i];i++){
nE = oE.cloneNode(true);
nE.setAttribute("allowfullscreen","true");
oE.parentNode.replaceChild(nE,oE);
}})()

Sorry, but I'm just a person who wants to browse a webpage not write a website. Shouldn't there be an easier way in Firefox, please!?

more options

This is a requirement that came with the change to implement the full-screen API

You can create a new bookmark and paste the JavaScript code I posted above in its location field or evaluate the JavaScript code via the command line of the Web Console (3-bar Menu button or Tools > Web Developer). You can place this bookmark on the Bookmarks Toolbar for easy access. Click the bookmark with the JavaScript code once the page has finished loading and you should be able to click the full screen button. The code currently only works if the iframe's source attribute links to the YouTube website.


javascript:(function(){elm=document.querySelectorAll("iframe[src*=\"youtube\"]:not([allowfullscreen])");
for(i=0;oE=elm[i];i++){
nE = oE.cloneNode(true);
nE.setAttribute("allowfullscreen","true");
oE.parentNode.replaceChild(nE,oE);
}})()