Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I use Windows 10 and I need to enable javascript, adjust SSL and other security settings

  • 7 uphendule
  • 10 zinale nkinga
  • 535 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have followed instructions, read the articles and they don't help. I understand that I can set up an exception for particular trusted sites by clicking on the icon that looks like a lego block beside 'Mozilla Foundation' but it doesn't stay available for long enough.

All Replies (7)

more options

Hi chrispe, this icon --

I understand that I can set up an exception for particular trusted sites by clicking on the icon that looks like a lego block beside 'Mozilla Foundation' but it doesn't stay available for long enough.

-- is to let pages use particular plugins, such as Flash. I think you are having a different problem.

Let's start with secure certificate errors. You should not need to do anything special to use well-run secure sites. If you are getting a lot of "untrusted" sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, Bullguard, ESET, and Kaspersky; AVG LinkScanner / SurfShield can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

If you have any of those specific security products:

That would be the first thing to check. This support article will walk you through it: How to troubleshoot security error codes on secure websites.

If none of those ring a bell:

You could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "Advanced" button and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

Thank you for responding so quickly. My response to your suggestions are below. I haven’t yet tried looking at a sample security certificate. I thought I would see what your response is to my notes so far. Cheers

No it I am not getting a lot of untrusted sites it is just one site – my online banking site. This is the error message that I receive:

• Your web browser is not fully compatible with this service Sometimes a browser update can cause problems with ANZ Internet Banking. Try logging on with a different browser. See software requirements and settings for more information.

When I follow their advice which is to: 1. enable popups and cookies for ANZ.com – I can do that. 2. Enable javascript – I can’t do that 3. Adjust SSL and other security settings to SSL3.0 and TLS1.0 – I can’t do that Clear temp internet browsing data – I can do that .

My date and time zone is correct for the site I am trying to access.

I use Norton for my security software, I don't use any of the ones you mentioned.

I don’t have a Microsoft Account and haven’t set up the Family Safety software. I am not aware of having any malware issues.

I don’t receive the "Your connection is not secure" error message.

more options

Okay, got it.

This is the error message that I receive:

• Your web browser is not fully compatible with this service Sometimes a browser update can cause problems with ANZ Internet Banking. Try logging on with a different browser. See software requirements and settings for more information.

Since you get this message from their site instead of a Firefox error message, I don't think your security settings are causing the problem. Can you give a link to the login page?

When I follow their advice which is to:
  1. enable popups and cookies for ANZ.com – I can do that.
  2. Enable javascript – I can’t do that
  3. Adjust SSL and other security settings to SSL3.0 and TLS1.0 – I can’t do that
Clear temp internet browsing data – I can do that .

Regarding #2, Firefox only has one master on/off switch for JavaScript, so unless half the sites you visit are screaming about JavaScript, it's already enabled.

That said, some add-ons and Firefox's Tracking Protection feature may block scripts from some sites. If Tracking Protection is active on a page, a shield icon will appear in the address bar near the padlock. You can click it for more information if you see it.

Regarding #3, Firefox's minimum connection level is TLS 1.0. The older SSLv2 and SSLv3 are not longer available. Anyway, it's not really clear what they mean by "adjust". ??


Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

more options

The server can use TLS 1.0 apart from SSL3 and thus should be working in the current release.

more options

Here is the link to the login page: https://www.anz.com/INETBANK/bankmain.asp

When I click on the shield it says the connection is not secure and when I ask for more info it says there is mixed content particularly images. I have tried to unblock the mixed content but the only page that has that option closes before I can complete the action.

Woo hoo - I just looked the shield again, looked at permissions and clicked on block images and now I can access the site. Very excited! Thank you for the support.

more options

I don't see any mixed content warning on the home page (screen shot attached), but some banks switch to advertising after you log in, so maybe the problem comes at that point? Anyway, if you can use the site with images blocked, that's a good workaround. But if you can't see important elements of the page, you'll probably have to unblock them.

more options

You could possibly access the website in a PB mode window to see if Tracking Protection blocks this insecure content.