X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do you stop going to a new windows rather than just using tab?

Kuphostiwe

When I open a link it will automatically go to a window. I do not want that to happen. How can I just have the new link go to a new tab instead?

When I open a link it will automatically go to a window. I do not want that to happen. How can I just have the new link go to a new tab instead?

Isisombululo esikhethiwe

Type about:preferences#general<enter> in the address bar. Under Tabs, turn on Open New Window In New Tab

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Dragon NaturallySpeaking HTML Component
  • Google Update
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4339 izisombululo 61024 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Type about:preferences#general<enter> in the address bar. Under Tabs, turn on Open New Window In New Tab

Type '''about:preferences#general'''<enter> in the address bar. Under '''Tabs,''' turn on '''Open New Window In New Tab'''
jscher2000
  • Top 10 Contributor
8885 izisombululo 72689 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Are these links inside a Firefox window and you want a new tab in that window? Usually, that happens, but you could check this setting to see whether it changed:

"3-bar" menu button (or Tools menu) > Options

In the left column, if General is not already selected, click General. Then on the right side, toward the bottom of the list, make sure there is a checkmark next to "Open new windows in a new tab instead"

Is that not working?

Is there a specific site where you have this problem? Sites can specially code links to open in a new window by specifying some features of the window (for example, height and width, no scrollbar, etc.). There is a hidden setting to force even those scripted windows into a new tab instead. Here's how you set it:

(1) In a new tab, type or paste about:config and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered.

(3) There are three similarly named preferences for different scenarios, we're going to focus on the second one, but I mention the others in case you have a question when you see them:

(A) browser.link.open_newwindow - for links in Firefox tabs

3 = divert new window to a new tab (default) 2 = allow link to open a new window 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

0 = apply the setting under (A) to ALL new windows (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

-1 = apply the setting under (A) to external links (default) 3 = open external links in a new tab in the last active window 2 = open external links in a new window 1 = open external links in the last active tab replacing the current page

Does setting that second preference to a value of 0 make any difference?

Are these links inside a Firefox window and you want a new tab in that window? Usually, that happens, but you could check this setting to see whether it changed: "3-bar" menu button (or Tools menu) > Options In the left column, if General is not already selected, click General. Then on the right side, toward the bottom of the list, make sure there is a checkmark next to "Open new windows in a new tab instead" Is that not working? Is there a specific site where you have this problem? Sites can specially code links to open in a new window by specifying some features of the window (for example, height and width, no scrollbar, etc.). There is a hidden setting to force even those scripted windows into a new tab instead. Here's how you set it: (1) In a new tab, type or paste <strong>about:config</strong> and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste <strong>link.o</strong> and pause while the list is filtered. (3) There are three similarly named preferences for different scenarios, we're going to focus on the second one, but I mention the others in case you have a question when you see them: <strong>(A) browser.link.open_newwindow</strong> - for links in Firefox tabs 3 = divert new window to a new tab (<u>default</u>) 2 = allow link to open a new window 1 = force new window into same tab <strong>(B) browser.link.open_newwindow.restriction</strong> - for links in Firefox tabs '''0 = apply the setting under (A) to ALL new windows''' (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (<u>default</u>) 1 = override the setting under (A) and always use new windows <strong>(C) browser.link.open_newwindow.override.external</strong> - for links in other programs -1 = apply the setting under (A) to external links (<u>default</u>) 3 = open external links in a <u>new tab</u> in the last active window 2 = open external links in a <u>new window</u> 1 = open external links in the <u>last active tab</u> replacing the current page Does setting that second preference to a value of 0 make any difference?