X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Flash player disabled, but video still plays.

Kuphostiwe

Flash player disabled, but video still plays.

What would cause this?

Flash player disabled, but video still plays. What would cause this?

Okulungisiwe ngu jorb

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Firefox can use a (built-in) HTML5 media player to play media files without the need to have a plugin like Flash installed.

See also:

Firefox can use a (built-in) HTML5 media player to play media files without the need to have a plugin like Flash installed. See also: *https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

Umnikazi wombuzo

Is there away to disable the (built-in) HTML5 media player?

Is there away to disable the (built-in) HTML5 media player?
cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

You can set these prefs to false on the about:config page.

  • media.windows-media-foundation.enabled
  • media.directshow.enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can set these prefs to false on the <b>about:config</b> page. *media.windows-media-foundation.enabled *media.directshow.enabled You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Umnikazi wombuzo

  • media.windows-media-foundation.enabled , is not listed in about:config
  • media.wmf.enabled is the listed , is this the same?
* media.windows-media-foundation.enabled , is not listed in about:config * media.wmf.enabled is the listed , is this the same?
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

I think the preference names for Windows changed recently. wmf most likely stands for Windows Media Foundation, but that doesn't seem to be clearly documented.

Anyway, are you sure you don't want any HTML5 videos anywhere? If you just want to control when they play, you could try toggling this preference:

  • media.autoplay.enabled
I think the preference names for Windows changed recently. wmf most likely stands for Windows Media Foundation, but that doesn't seem to be clearly documented. Anyway, are you sure you don't want any HTML5 videos anywhere? If you just want to control when they play, you could try toggling this preference: * media.autoplay.enabled

Umnikazi wombuzo

jscher2000

When Flash player is enabled. On some websites, it sticks the scrolling and when replying in message fields the cursor comes and goes. This effects all the tabs that are open.

My thinking was to disable Flash player which fixed the above problem. But when I disabled Flash player on some websites the video ADs still played. So, I was thinking whatever was creating the flash player problem, was a competing video program. That is the reason why I wanted to disable HTML5 video. Then re-enable flash player. To see if that would fix the flash player problem.

Maybe it would be better to not use Flash player unless needed.

jscher2000 When Flash player is enabled. On some websites, it sticks the scrolling and when replying in message fields the cursor comes and goes. This effects all the tabs that are open. My thinking was to disable Flash player which fixed the above problem. But when I disabled Flash player on some websites the video ADs still played. So, I was thinking whatever was creating the flash player problem, was a competing video program. That is the reason why I wanted to disable HTML5 video. Then re-enable flash player. To see if that would fix the flash player problem. Maybe it would be better to not use Flash player unless needed.

Okulungisiwe ngu jorb

cor-el
  • Top 10 Contributor
  • Moderator
17525 izisombululo 158458 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Did you try to set media.wmf.enabled to false?

There are more media.*enabled pref for specific media types.

Did you try to set media.wmf.enabled to false? There are more media.*enabled pref for specific media types.