Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"Your connection is not secure" when trying to access Google or Yahoo

  • 3 uphendule
  • 87 zinale nkinga
  • 9074 views
  • Igcine ukuphendulwa ngu mahalanobis

more options

Hello,

I just reinstalled Firefox and I can't access Google or Yahoo websites. I get "Your connection is not secure" message everytime I try to access them. How can I fix this?

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I just solved it. It was a malware problem. I scanned my PC, now everyhing's fine. Thanks for your time.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 5

All Replies (3)

more options

If you can't inspect the certificate via Advanced (I Understand the Risks) then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website with the https:// protocol prefix (https://xxx.xxx).

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.

more options

The issuer is "IT Department". I didn't attach a screenshot beacause details are not written in English.

Okulungisiwe ngu mahalanobis

more options

Isisombululo Esikhethiwe

I just solved it. It was a malware problem. I scanned my PC, now everyhing's fine. Thanks for your time.