Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Google search result links stopped working

  • 5 uphendule
  • 4 zinale nkinga
  • 841 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Recently I noticed that when I search on Google using FF 44.0, when I clink on a link nothing happens. But when I right click and select Opne in New Tab, it works. I tried restarting in Safe Mode, but the problem persists.

This only seems to be happening on one computer. My other two seem to be working fine. Both are running FF 44.0 as well. All computers are on Win10 with KIS 2015 for Internet Security.

You help is appreciated.

Gene ...

Isisombululo esikhethiwe

Try Firefox in Safe Mode anyway.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

FredMcD said

Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.
Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.
If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Poke around safe web sites. Are there any problems? Then restart.

Thank you for your thoughtful and detailed response. I tried those steps, and the problem persists. Sadly.

I quick note, I already had Hardware Acceleration disables as I was having a problem with the Satellite view in Google Maps. Doing that fixed that problem. But this problem surfaced weeks after I correct the Google Maps issue.

This is new and started in just the past couple of days.

Still open for other suggestions.

Gene ...

more options

Isisombululo Esikhethiwe

Try Firefox in Safe Mode anyway.

more options

I did try Safe Mode, and there was no change.

But interestingly today, the Google Links are working again. No clue as to why. I guess it was PFM.

Thank you very much for your help. I really do appreciate it.

Gene ...

more options

Could have been a fault at Google that was fixed.

Glad to help. Safe Surfing.