Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox not displaying parts of page correctly

  • 7 uphendule
  • 1 inale nkinga
  • 692 views
  • Igcine ukuphendulwa ngu QueenBuzzy

more options

For some reason, Firefox is now not displaying parts of the page correctly. I've noticed this mostly in my Wordpress Jetpack stats, but as I've gone around the web, it's been doing the same with PDFs as well. Videos and regular images are fine.

Here are some sample images. These are supposed to be JetPack stats, you should see line graphs, but it just looks like you changed the TV channel to a non-operating signal.

http://queenoftherandomjob.com/Jetpack-Nerds.jpg http://queenoftherandomjob.com/Jetpack-TOM.jpg http://queenoftherandomjob.com/Jetpack-QRJ.jpg

Here's what I see on a PDF: http://queenoftherandomjob.com/Bernie.jpg And the actual link to the PDF: https://berniesanders.com/wp-content/uploads/2016/01/Wall-St-Letter-1.pdf

I spoke with Jetpack and they said it definitely was a browser issue...I have checked in Safari and Opera and everything is rendering fine there. PDFs, Wordpress...no issue.

This issue started just last week, and I haven't installed or changed anything. Everything was fine in the morning, and then in the evening, it went all wiggy. I do not have Avast anti-virus (this seems to be the culprit in other people's issues,) and I'm on a Macbook. I have uninstalled and reinstalled Firefox, cleared the cache, etc. I'm still having issues.

If anyone has any advice, I'd really appreciate it! Thanks!

Isisombululo esikhethiwe

Could you try disabling Firefox from using hardware acceleration? Firefox occasionally becomes incompatible with graphics driver software when one or the other updates. Either:

  • "3-bar" menu button > Preferences
  • Firefox menu > Preferences

In the left column, click Advanced. Then on the right make sure the "General" mini-tab is selected, and uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you quit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check with Apple to see whether any graphics card/chipset driver updates are available for your system.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (7)

more options

Are you using the internal, or external viewer?

more options

I really don't know...I checked my "add ons" and there wasn't any Adobe "add on" there?

So, that would mean I'm using an external one, right?

more options

I'm using Firefox 44.0 if that helps. Just did a fresh reinstall today.

I looked in Add Ons to see if I could download one for Adobe, and it appears that they don't exist anymore.

more options

Those are PDF files, not clips. Note: players are listed in plugins. https://support.mozilla.org/en-US/kb/disable-built-pdf-viewer-and-use-another-viewer

more options

Isisombululo Esikhethiwe

Could you try disabling Firefox from using hardware acceleration? Firefox occasionally becomes incompatible with graphics driver software when one or the other updates. Either:

  • "3-bar" menu button > Preferences
  • Firefox menu > Preferences

In the left column, click Advanced. Then on the right make sure the "General" mini-tab is selected, and uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you quit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check with Apple to see whether any graphics card/chipset driver updates are available for your system.

more options

Ok, so now it looks like I can go to a PDF page and it still renders squiggly, but it automatically downloads and I can read them that way. Not ideal, but doable.

When you say, "those are PDF files not clips" are you talking about the Jetpack stats? Those are still not showing up. (They're still squiggly)

Thanks for your feedback!

more options

@jscher2000 that did it!

I unchecked the "use hardware excelleration" box, restarted Firefox and all is well with the world :)

Thank you!