Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

how do i fix (firefox not responding)?

  • 11 uphendule
  • 2 zinale nkinga
  • 1363 views
  • Igcine ukuphendulwa ngu FredClose

more options

I continually experience the dreaded rotating blue-green circle with “Firefox not responding” message. My only option is to close the program. When I reopen, FF may work for a site or two but clicking on a new tab invariably triggers “not responding.” If I open FF via Run As Administrator, the problem does not occur. I’ve tried every fix I can find, including: 1) uninstall and download a new copy of FF; 2) Refresh FF; 3) create a new profile (although when I then clicked Start FF, nothing happened); 4) close FF and rename places.sqlite (to places.sqlite.old) and cookies.sqlite (to *.old); 5) set sessionstore resume-from-crash to False; 6) unchecked Use Hardware Accelerator; 7) made sure there is no session-store.js file; 8) change status of Shockwave to Ask to Activate; 9) change HomePage to FF default. What have I missed?

Isisombululo esikhethiwe

The problem reoccurred but this time when I downloaded a new version of FF I deleted the entire FF folder, which I had not done the first time. This seems to have solved the problem. My thanks to ideato and cor-el.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (11)

more options

Hello FredClose, what is your security software ?

try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) and then see if that allows to start firefox without Administrator rights.

thank you

more options

Thank YOU, ideato, for taking the time to reply. I use Norton 360 security software. In case my initial question was unclear, I have no trouble opening FF simply by clicking "Open." But if I do, the "not responding" freeze occurs shortly thereafter. To avoid it, I must click "Run As Administrator." I tried your suggestion, rebooting the computer while holding down F8. Frankly I could see no difference in how Windows opened after doing so, but sure enough, as you predicted, the "not responding" freeze did not occur even when I simply used "Open" to access FF. So now, what does this indicate must be fixed to solve the problem?

more options

If firefox works in Windows Safe mode then probably you have problem with other software, like security software or maybe a system driver, that is running on your computer. I think it is your security software(Norton 360).

Please remove all rules for Firefox and plugin-container from the permissions list in the your firewall and let your firewall ask again for permissions to get full access to Firefox installation and at the plugin-container process and also for updater process. Seek also in your Norton 360 if exist a preference that block firefox access and that is the cause of the freezing.

thanks again

more options

I don't know how to "remove all rules for Firefox and plugin-container." I also don't know how to find a preference that might block FF access.

Norton360 Firewall offers the choice of Allow, Block, or Custom for FF. I changed the setting from Allow to Block. I reopened FF and of course FF could not access any internet site. So I closed FF and changed Block to Allow. Amazingly FF now seems to operate without freezing.

I can't imagine this solved the problem but I will mark it SOLVED until it stops working again. Thank you for your help.

more options

As I suspected, a couple of hours after my previous post, FF is again "not responding." The changing of Allow to Block and back to Allow has not solved the problem. I need some more specific guidelines on how to properly configure Norton360 in order to cure the conflict with FF. Any help is appreciated.

more options

Let's see (because i don't have Norton in front of me) :-)

Go to Norton 360, > Settings > Firewall > Rules or Program Rules > find Firefox > click it and now select Remove. Now click Add and go to Firefox location on your win7 (C:\Program Files\Mozilla Firefox) > select the firefox.exe > and when the prompt asks what you want to do with this program(firefox), choose Allow (or Apply).

any luck ?

thank you

more options

No luck. *Sigh* I never found a firefox.exe file but when I searched for it I discovered a ton of AppHang.firefox.exe_[code] and one firefox symbol under Programs(x86). I assume the symbol is the execute file. I followed your instructions above, removed it and then added it. I opened FF using "Open", clicked on a new tab, and received the "not responding error." Other thoughts?

thanks again.

more options

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and (re)install or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile.


more options

I very much appreciate your continued help but if you read my initial post you will see that I have already uninstalled and reinstalled a new version of Firefox as well as created a new profile. Neither solved the problem. But I will do both again and report back in a new post later today.

Is there nothing to be learned from the AppHang.ff.exe or the AppCrash files?

more options

I have not uninstalled and reinstalled FF yet because the program is again working just fine. No freezes. So I'm going to wait for it to go back to its "not responding" mode and then I will follow your instructions of 1/20, 7:46PM. Thanks for your likely help in the future. Watch this space.

If it continues working for a couple of days I will mark the problem solved, although I haven't really done anything to change its performance.

more options

Isisombululo Esikhethiwe

The problem reoccurred but this time when I downloaded a new version of FF I deleted the entire FF folder, which I had not done the first time. This seems to have solved the problem. My thanks to ideato and cor-el.