X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

All color options in preferences are blank (that is, white)

Kuphostiwe

Using Firefox 42 on Mac. I wanted to change the color option in Preferences > Content > Colors so that pages I browse are in black type instead of gray type. In version 38, this was a snap and worked well. Upgraded to version 42 and when I view that option everything (except the descriptive text) of that color options page is white. The popup color boxes for text color, background color, link colors, etc. are all white. When I browse normal web pages, the last settings I used are still there but now I can't change them.

I tried this on Firefox 38 on another computer and the colors show up and can be changed as before. I'm reluctant to upgrade that Firefox to version 42 in case this is a newly introduced bug.

Using Firefox 42 on Mac. I wanted to change the color option in Preferences > Content > Colors so that pages I browse are in black type instead of gray type. In version 38, this was a snap and worked well. Upgraded to version 42 and when I view that option everything (except the descriptive text) of that color options page is white. The popup color boxes for text color, background color, link colors, etc. are all white. When I browse normal web pages, the last settings I used are still there but now I can't change them. I tried this on Firefox 38 on another computer and the colors show up and can be changed as before. I'm reluctant to upgrade that Firefox to version 42 in case this is a newly introduced bug.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Provides information about the default web browser
  • Version 5.40.2.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4260 izisombululo 59653 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there?

Umnikazi wombuzo

I tried holding down the Shift key (BTW, it's not Option on the Mac) and starting Firefox 42 in Safe Mode. Nothing changed regarding colors in preferences.

I bit the bullet and upgraded Firefox to version 42 on my MBA Mac and the color pref does work there so its probably a startup item or system preference conflict on my Mac Pro using Yosemite that is causing the problem. Next time I reboot I'll trying disabling extensions and see how that affects Firefox.

I tried holding down the Shift key (BTW, it's not Option on the Mac) and starting Firefox 42 in Safe Mode. Nothing changed regarding colors in preferences. I bit the bullet and upgraded Firefox to version 42 on my MBA Mac and the color pref does work there so its probably a startup item or system preference conflict on my Mac Pro using Yosemite that is causing the problem. Next time I reboot I'll trying disabling extensions and see how that affects Firefox.

Umnikazi wombuzo

Shift versus option

I was wrong, option is the key to hold down for Safe Mode on OSX. But it still didn't work - that is I didn't get the Safe Mode dialog box and the colors were still missing. I think I'll try reinstalling Firefox...

Shift versus option I was wrong, option is the key to hold down for Safe Mode on OSX. But it still didn't work - that is I didn't get the Safe Mode dialog box and the colors were still missing. I think I'll try reinstalling Firefox...
cor-el
  • Top 10 Contributor
  • Moderator
17539 izisombululo 158588 izimpendulo
Kuphostiwe

This will happen if you override the website colors and have possibly enabled a High Contrast theme.

Make sure that you allow pages to choose their own colors.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This will happen if you override the website colors and have possibly enabled a High Contrast theme. Make sure that you allow pages to choose their own colors. *Firefox > Preferences > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above" Try "Never" if the default "Only with High Contrast themes" isn't working.

Okulungisiwe ngu cor-el

Umnikazi wombuzo

I tried the "Never" option but the problem persisted.

I also reinstalled Firefox, tried different versions, invoked Safe Mode, etc. Nada.

I used the Command-Option-P-R trick to rebuild the desktop, used a cache cleaner, rebooted the Mac Pro with Shift key held down (essentially safe mode for the whole computer) but after all that I still couldn't get it to work. One last restart and still nothing. I shut down the computer last night and rebooted it this morning and voila, Firefox colors are back like nothing happened.

Go figure.

I tried the "Never" option but the problem persisted. I also reinstalled Firefox, tried different versions, invoked Safe Mode, etc. Nada. I used the Command-Option-P-R trick to rebuild the desktop, used a cache cleaner, rebooted the Mac Pro with Shift key held down (essentially safe mode for the whole computer) but after all that I still couldn't get it to work. One last restart and still nothing. I shut down the computer last night and rebooted it this morning and voila, Firefox colors are back like nothing happened. Go figure.
FredMcD
  • Top 10 Contributor
4260 izisombululo 59653 izimpendulo
Kuphostiwe

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.

Umnikazi wombuzo

I was about to mark this solved until I went to double-check my Prefs again after another restart. Firefox's content prefs had gone back back to all white.

This morning, after another restart, its back to normal colors.

I can't tell if it's my machine or Firefox without a lot of testing I don't have time to do.

I was about to mark this solved until I went to double-check my Prefs again after another restart. Firefox's content prefs had gone back back to all white. This morning, after another restart, its back to normal colors. I can't tell if it's my machine or Firefox without a lot of testing I don't have time to do.
FredMcD
  • Top 10 Contributor
4260 izisombululo 59653 izimpendulo
Kuphostiwe

There is no rush. Take your time.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

There is no rush. Take your time. '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
cor-el
  • Top 10 Contributor
  • Moderator
17539 izisombululo 158588 izimpendulo
Kuphostiwe

See also:

Option-Control-Command-8 : Invert/revert the screen colors
See also: * http://support.apple.com/kb/HT3488?viewlocale=en_US Option-Control-Command-8 : Invert/revert the screen colors